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Preface

This SPMLab software manual is designed to serve as a reference resource for all of the

system’s top-level software functions.  All menu items, tool bar buttons, and primary

acquisition software controls are described.  SPMLab’s image analysis/processing and

scanner calibration are also described, including complete procedures.

This manual does not provide detailed SPM acquisition procedures.  Because these

procedures can differ depending on the instrument you are using, you need to refer to the

instrument operating manual particular to your scanning probe microscope for step-by-

step operating instructions in all the available SPM modes.

Because some ThermoMicroscopes instruments can be configured with options not

compatible with all systems, some menu items, tool bar buttons, and other screen controls

are instrument- and option-dependent and are not described in this manual.  For

information on these, refer to your instrument operating manual and/or the documentation

included with your purchased option(s).  Also, your particular software configuration may

not include every menu item listed in this manual.

The manual is organized to focus on all of the primary software functions used with

SPMLab:

•  Chapters 1 and 2 describe the data acquisition menu items and controls.

•  Chapter 3 describes the scanner calibration functions and procedures.

•  Chapters 4 and 5 describe the image display/processing/analysis menu items,

controls, and procedures.

•  Chapter 6 describes the SPMLab Screen Editor.

Note: This documentation assumes that the user is familiar with the operation of

Windows NT 4.0 operating system.  For more information, refer to the manuals

specific to Windows NT 4.0 that were supplied with your PC.
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General Software Description

SPMLab version 5.01 is for use with the Windows NT 4.0 operating system.  The

software operates in three modes:

•  Data Acquisition

•  Image Analysis

•  Screen Editing

The functions of these three modes comprise all the data gathering, analysis and

presentation software tools available with your instrument.  These modes operate from

independent modules, using data originally obtained in the Data Acquisition mode.  Each

module has a dedicated user interface and command menu.

The Data Acquisition module is where the instrument control and data acquisition

parameters are set and the scan takes place.  Some preliminary real-time image processing

can also be performed in this module.  Using the data obtained in the Data Acquisition

module, the Image Analysis module is used to display, process, and analyze the scanned

images.  Finally, the Screen Editor module brings together the processed image and scan

data to create a useful presentation of the findings.  This allows the user to configure,

display, and print any selected information in a wide range of layouts and formats.  The

Screen Editor can also be used to present information from the Data Acquisition module.
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What’s New in SPMLab 5.01

Data Acquisition Module

•  Counter Board support

(Available with the NSOM option, for systems equipped with a photon counting

board.)

1. New dialog box for counter setup (new menu item:  Setup⇒ Counter).

2. Counter map.

3. FS with Counter.

•  I/O-MOD+ support

With I/O-MOD+, the Drive Attenuation controls are not necessary (and are

therefore not displayed in the Non Contact Control window).

•  Zoom Out

This new control in the Non Contact Control window restores the previously

zoomed area (one level).

•  Phase Detection

Phase detection no longer requires connecting external BNC’s.

•  Save and Load Probe Locations in Point Spectroscopy

Save and load probe locations capability has been added to the Point

Spectroscopy sub-panel.

Image Analysis Module

•  File Manager & Import function

1. SPMLab files can be read down to version 3.05.

2. Third-party binary files can be imported.

•  Line averaging function

"Line Width" setting has been added to the Line Measurement and Line Analysis

dialog boxes.

Screen Edit Module

Printer orientation (portrait or landscape) is saved upon exiting the SPMLab program.



Chapter 1
Data Acquisition
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Overview

This chapter serves as a basic introduction and navigation guide to the Data Acquisition

module of SPMLab, including a general description, menu maps, and command-by-

command functional descriptions of the Data Acquisition module.  Because some

ThermoMicroscopes instruments can be configured with options not compatible with all

systems, some menu items are instrument- and option-dependent.  Therefore, your

particular software configuration may not include every menu item listed in this chapter.

Or, your configuration may include specialized menu items not covered in this general

software manual.

Figure 1-1.  Data Acquisition module screen.

The controls and functions of the Data Acquisition window, shown in Figure 1-1, allow

you to control the Electronic Control Unit (ECU) and stage hardware for scanning and

data collection.  The acquired data can include raw images, line scans, and point and

image spectroscopy.  Data acquisition utilizes the digital signal processor (DSP) for

instrument control and data acquisition.  The DSP drives all real-time aspects of the

instrument control and converts analog signals from the microscope into digital signals

for processing by the PC and for real-time display.  Once data has been acquired, the Data
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Analysis or Screen Editor module can be accessed to process the data (image analysis)

and/or produce reports and print the data (screen editing).

This chapter contains a summary description of all the Data Acquisition menu functions.

For a full description of the acquisition software controls other than the menu items and

tool bar buttons, see Chapter 2 “Data Acquisition Tools.”  You should refer to the

appropriate chapter in your instrument operations manual for specific, step-by-step SPM

procedures.

Opening the Data Acquisition Module

When you launch SPMLab, the program opens in the Image Analysis module by default.

When you first enter the Data Acquisition module, by either selecting Window⇒ Image

Acquire or clicking on the Image Acquisition button  on the Image Analysis tool bar,

the Scanner Selection dialog box, shown in Figure 1-2, opens.

Figure 1-2.  The Scanner Selection dialog box.

The scanner Sys file that matches the scanner you are using should be selected.  If more

than one scanner Sys file is available, make sure the one that matches the scanner you are

using is selected.

If you have more than one stage connected to your ECU, and you want to use a stage

other than the one you used in your previous session, click the Stages… button.  The

Stage Selection dialog box, shown in Figure 1-3, opens.
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Figure 1-3.  The Stage Selection dialog box.

Select the stage you want to use, and click OK.  You will be returned to the Scanner

Selection dialog box.  Click OK to accept your scanner file and stage selections (this

dialog box can be accessed at any time within the Data Acquisition module by selecting

Setup⇒ Scanner Select…).  Next you will see a window, shown in Figure 1-4, warning

you that high voltage will now be energized.

Figure 1-4.  High voltage warning window.

The high voltage notice dialog box provides an explicit opportunity to turn the power to

the scanner back on after you have switched scanners or scanner files.  This dialog box

makes operation with a tripod scanner more consistent with operation with a tube scanner,

as tube scanners operate in a much higher voltage range.  Click on the Engage button to

apply high voltage to the scanner and operate the instrument.  You will then enter the

Data Acquisition module.
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Data Acquisition Menu Items

The Data Acquisition menus and tool bar are shown in Figure 1-5.  Note that the menu

options and tool bar buttons displayed depend on the stage and any options you are using.

This manual describes the menu options and tool bar buttons that are standard to all

stages.  When you order an option, such as STM, the accompanying documentation

describes the menu options and icons specific to that option.

Some of the icons on the tool bar provide single-click access to the more commonly-used

menu options and are indicated beside their associated menu items.  This section gives a

brief description of each menu item.  The icons are described in the section that follows,

“Data Acquisition Tool Bar.”

Acquire

Images...
Point Spectrscopy
SysFile Edit...
Verify Calibration...

Phase Imaging

Advanced Setup

Save As
Save All...
Export... 

Exit

File Edit

Screen Edit ... Ctrl+PCtrl+S
Ctrl+Shift+S
Ctrl+E 

Ctrl+X

Basic Setup

Contrast & Brightness...
Palettes...
Background...

Display

XYZ
Prescan
Oscilloscope
Acquire
Probe Position

Commands Setup

Acquire...
Beam Align...
Additional Parameters...
Scanning...
Stage Select... 
Scanner Select...
Sensor Calibration
Non Contact

Preferences...
Screen Colors...
Trim Pot Adjust

Window

Image Analysis
Analyze Now

Next 
Previous
Tile
Cascade

Topography-Forward
Oscilloscope

1
2

Figure 1-5.  Data Acquisition menus and tool bar.
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The File Menu

The File menu, shown in Figure 1-6, allows you to save and export images.  The File

menu items are described briefly in Table 1-1.

Save As
Save All...
Export... 

Exit

File
Ctrl+S
Ctrl+Shift+S
Ctrl+E 

Ctrl+X

Figure 1-6.  The File menu.

Table 1-1.  The File menu items.

Menu Item Function

Save As… Opens the Save As dialog box, allowing you to name the file and

save the currently selected data (image, F/S, etc.) in SPMLab data

formats.

Save All… Opens the Save All dialog box, which gives you the option of saving

any or all windows currently open in the Data Acquisition module

(images, Topography Forward, EChem, F/S, etc.).  If only one

image window is open when the Save All command is accessed, the

Save As dialog box will be opened by default.

Export… Opens the Export dialog box, which saves the selected data in the

ASCII text format (.txt), for use with other applications.  The feature

allows you to export graphs, scan images, oscilloscope displays, etc.

This function is not available for all data types.

Exit Retracts the tip, stops acquisition, and terminates SPMLab.

The Edit Menu

The Edit menu provides access to the Screen Editor module, which allows annotations

and editing of the screen and acquired images, and printing.  The file can then be saved to

various output file formats for presentations or exported to other image processing

packages.  For a full description of the Screen Editor module software functions, see

Chapter 6, “Screen Editor.”
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The Acquire Menu

The Acquire menu, shown in Figure 1-7, selects the system’s Data Acquisition (scanning)

mode.  A check mark appears next to the modes that are active.  Some modes are

mutually exclusive; others can be active simultaneously.  The Acquire menu items are

described briefly in Table 1-2.

Acquire

Images...
Point Spectrscopy
SysFile Edit...
Verify Calibration...

Phase Imaging

Advanced Setup

Basic Setup

Figure 1-7.  The Acquire menu.

Table 1-2.  The Acquire menu items.

Menu Item Function

Images… Selects the standard acquisition display mode for 2D top-view

images, using the standard Acquisition Control Panel.  This function

can be used to reestablish the standard image display mode and

Acquisition Control Panel configuration.  Previously selected

acquisition modes using a non-standard image display and/or

Acquisition Control Panel configuration (e.g., Step and Scan or

Point Spectroscopy) are deselected.

Point

Spectroscopy

Accesses the Point Spectroscopy menu.  See “The Point

Spectroscopy Sub-menu” below.

Layered Images Accesses the Layered Images menu.  See “The Layered Images Sub-

menu” below.

SysFile Edit Opens the scanner (.SYS) file editor used in computer-controlled

calibration of the scanner (using a standard calibration grid) and/or

manual modification of the calibration parameters.  Upon selecting

SysFile Edit, the Acquisition Control Panel switches to the SysFile

Edit configuration.  For more information, see “System File Edit” on

page 3-9.
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Menu Item Function

Verify

Calibration…

Verifies scanner calibration using a standard calibration grid.  Upon

selecting Verify Calibration, the Acquisition Control Panel switches

to the Verify Calibration configuration, and the Verify Calibration

sub-panel is displayed.  For a full description of this function, see

“Review Files” on page 3-22.

Phase Imaging Allows you to image the changes in phase produced by interaction

between the tip and sample in Non Contact AFM.

Advanced Setup/

Basic Setup

Toggles between the Basic Setup and Advanced Setup modes,

changing the options available in the Acquisition Control Panel

when scanning in the Layered Images and Point Spectroscopy

modes.  The setup option also changes the setup parameters

available when Setup is selected.  The Advanced Setup window

allows for complete control of all experiment parameters.  The Basic

setup allows control of only a fundamental subset of these

parameters.

The Point Spectroscopy Sub-menu

The Point Spectroscopy sub-menu, shown in Figure 1-8, allows you to select a point

spectroscopy mode.  Note that the modes displayed in this menu depend on the optional

configuration of your instrument.  Upon selecting one of these modes, the Acquisition

Control Panel switches to the Point Spectroscopy configuration.  For more information,

see “SPM Modes” and “Point Spectroscopy” in your instrument operation manual.  Some

of the Point Spectroscopy menu items are described briefly in Table 1-3 (the items

displayed in this menu depend on your software configuration).

E / S...
M / S...

Point Spectroscopy    F / S...

Figure 1-8.  The Point Spectroscopy sub-menu.
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Table 1-3.  The Point Spectroscopy sub-menu items.

Menu Item Function

F / S Performs force/distance experiments on the sample on up to four

points selected (by mouse) on the currently displayed image.

E / S Performs force/distance experiments which display the electrostatic

force gradient above the sample surface (EFM-equipped AFM

systems only).

M / S Performs magnetic force/distance experiments (MFM-equipped

systems only).

The Layered Images Sub-menu

The Layered Images sub-menu, shown in Figure 1-9, allows you to select a layered image

mode (in layered imaging-equipped systems only; the layered imaging modes available

with your system depend on the optional configuration of your instrument, i.e., MFM,

STM, etc.).

Layered images are created by displaying data (F/S, EFM, etc.) at each Z height and for

each X,Y data point in an image.  From this information, a 3-D (layered) image can be

constructed.  Upon selecting one of the layered imaging modes, both a topographic image

window and a layered image window are displayed for the selected experiment.  When

one of theses modes is selected, the Acquisition Control Panel switches to the Layered

Images configuration.  The parameters last used for a layered-image experiment are

stored as default parameters.  These parameters can be changed via the Additional

Parameters Setup dialog box, accessed by selecting Setup⇒ Additional Parameters.

For more information, see “SPM Modes” and “Layered Images” in your instrument

operation manual.  The Layered Images sub-menu items are described briefly in

Table 1-4.

EFM...
MFM...
CITS...
CITS...
PROFILE...

Layered Images FIS...

Figure 1-9.  The Layered Images sub-menu.
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Table 1-4.  The Layered Images sub-menu items.

Menu Item Function

FIS Acquires both a topographic image and a layered image with a

force/distance curve at each data point; creates a window for F/S

scanned images.

EFM Acquires both a topographic image and a layered image with an E/S

curve at each data point and creates a window for electrical force

microscopy scanned images.

MFM Acquires both a topographic image and a layered image with an M/S

curve at each data point and creates a window for magnetic

force/distance scanned images.

CITS Acquires both a topographic image and a layered image with a

current/voltage curve acquired at each data point (STM), and creates

a window for STM scanned images.

DITS Acquires both a topographic image and a layered image with a

current/distance curve at each data point (STM) and creates a

window for STM scanned images.

Profile Acquires an image using the feedback Z height at each data point to

establish a topographic profile of the sample.  Unlike the layered

image mechanism where the tip tracks the surface between F/S curve

data points, in the Profile mode the tip is retracted to a fixed

distance between data points.  Therefore, topographic data is

collected without any lateral tip/surface interaction.  No layered

image data is collected in this mode.

The Display Menu

The Display menu, shown in Figure 1-10, provides access to the three basic display

functions that affect images in the Data Acquisition module.  The Display menu items are

described briefly in Table 1-5.

Contrast & Brightness...
Palettes...
Background...

Display

Figure 1-10.  The Display menu.
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Table 1-5.  The Display menu items.

Menu Item Function

Contrast &

Brightness…

Opens the Contrast & Brightness dialog box, providing slider

controls which allow adjustment of an image’s contrast and

brightness.  The values are set to 50% by default.

Palettes… Opens the Palettes dialog box, which allows selection of the image’s

color palette from a predefined menu.  Color palettes can be edited

or created in the Image Analysis module.

Background… Opens the Background Filter dialog box, which allows selection of a

digital low pass, high pass, or band pass filter from a range of

options.  This function is used for real-time display of data during

acquisition.  The filters only affect the display.  Unfiltered raw data

is always stored by the system during acquisition.

The Commands Menu

The Commands menu, shown in Figure 1-11, accesses the primary hardware interface

functions for the instrument.  The Commands menu items are described briefly in Table

1-6.

XYZ
Prescan
Oscilloscope
Acquire
Probe Position

Commands

Figure 1-11.  The Commands menu.
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Table 1-6.  The Commands menu items.

Menu Item Function

XYZ… Opens the Z Motor window, allowing speed control setup of the Z

motor.  The Z motor voltage set in this mode remains active until the

voltage is reset or until the system is reinitialized.  (Some systems

allow reconfiguration of X and Y motor voltage as well.)  For a full

description of this function, see “Z Motor Speed Control” on page

2-54.

Prescan… Opens both the Prescan sub-panel in the Acquisition Control Panel

and the Oscilloscope window.  This menu item is used to access the

prescan configuration functions (beam alignment, PID adjustments,

etc.).  This function can also be accessed by clicking the  button

on the tool bar.  For a full description of the control panel functions,

see “Acquisition Control Panel” on page 2-3.

Oscilloscope Opens the Oscilloscope window (or closes it if it is already active).

This function can also be accessed by clicking on the  button on

the tool bar.  For a full description of this function, see “Signal

Window” on page 2-23.

Acquire Begins the scan (image acquisition).  While scanning, the Display

sub-panel in the Acquisition Control Panel becomes active.

Toggling off the function halts image acquisition and returns the tip

to its starting position.  This function can also be accessed by

clicking the  button on the tool bar.  Note:  When Acquire is

selected (or the  button is toggled on), the main Acquire menu is

disabled.

Probe Position… Opens a dialog box that allows precise positioning of the SPM

probe by pixel, X,Y location, or by X and Y piezo voltages.  By

using the dialog box and the scan window, a series of probe position

coordinates can be designated for use in various experiments.  The

points can be configured in a table on the dialog box and saved for

use with later experiments.  For a full description of this function,

see “Probe Positioning” on page 2-48.
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The Setup Menu

The Setup menu, shown in Figure 1-12, accesses the setup dialog boxes for the primary

acquisition modes.  Some interface setup options are also accessed through this menu.

The Setup menu items are described briefly in Table 1-7.

Setup

Acquire...
Beam Align...
Additional Parameters...
Scanning...
Stage Select... 
Scanner Select...
Sensor Calibration
Non Contact

Preferences...
Screen Colors...
Trim Pot Adjust

Figure 1-12.  The Setup menu.

Table 1-7.  The Setup menu items.

Menu Item Function

Acquire… Opens the Image Acquire Setup dialog box, which provides access

to image acquisition settings.  See “Image Acquire Setup” on page

2-27.

Beam Align… Opens the Beam Alignment window, which provides real-time

display of the position of the laser spot on the photodetector.  This

window provides a more convenient way to perform the beam

alignment.  This function can also be accessed by clicking the 

button on the tool bar.  For a full description of this function, see

“Beam Alignment” in Chapter 2.

Additional

Parameters…

Opens the Additional Parameters Setup dialog box, which allows

configuration of the advanced mode settings for the Point

Spectroscopy and Layered Images modes.  The dialog box opened

with this function depends on whether the Advanced Setup or Basic

Setup mode is active.  Note:  This menu item is only enabled when

the Point Spectroscopy and Layered Images acquisition modes are

active.  For a full description of this function, see “Point

Spectroscopy” in your instrument operation manual.
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Menu Item Function

Scanning… Opens the Scanning dialog box, which allows the selection of one-

directional or bi-directional scanning when the repeat scan function

 is activated.

With one-directional scanning, successive scans in the repeat-scan

mode will always begin from the top of the scan range (i.e., top →
bottom, top → bottom, top → bottom, etc.).  With bi-directional

scanning, successive scans in the repeat-scan mode will begin from

the top or bottom of the scan range, depending on the previous scan

(i.e., top → bottom, bottom → top, top → bottom, bottom → top,

etc.).  For a full description of this function, see “Bi-Directional

Scanning” on page 2-47.

Stage Select… Opens the Stage Selection dialog box for selection of the stage

model (Explorer, Aurora).  This operation must be performed

whenever a new type of stage is installed in your system.  Activating

this function will automatically disable any current scanning

operation and open a series of dialog boxes prompting you to

change the stage and select a new scanner file.  For a full description

of this function, see “Stage/Scanner Setup” and “Stage Selection” in

your instrument operation manual.

Scanner Select… Allows selection of a scanner Sys file.  After changing the scanner

and activating the function, the Scanner Selection dialog box is

opened for selection of a new scanner file.  This dialog box is also

presented when initially entering the Data Acquisition module.

ECU-Plus power can also be switched on or off in this dialog box.

For a full description of this function, see “Stage/Scanner Setup”

and “Scanner Selection/Installation” in your instrument operation

manual.

Sensor

Calibration…

Opens the Probe/Cantilever Setup dialog box, for setting force

calibration and automatic sensor calibration parameters.  For a full

description of this function, see “Spring-Constant Calibration/

Sensor Calibration” in your instrument operation manual.



Data Acquisition Menu Items 1-15

Menu Item Function

Non Contact… Opens the Non Contact Control window for computer-controlled

non contact configuration.  This dialog box sets up the non contact

system (mode, phase angle, gain, etc.) and allows adjustment of

drive amplitude and drive frequency.  (This option is functional only

on systems equipped for computer-controlled non contact scanning.)

For a full description of this function, see “Computer-Controlled

Non Contact Mode” in your instrument operation manual.

Preferences… Opens the Acquisition Preferences dialog box for selection of tip

approach and display preferences.  These options allow you to set

up automatic force and sensor calibrations during tip approach and

automatic image Z scaling, leveling, and shading display options.  If

utilized during the scan, the Z-scaling, leveling, and shading options

can be automatically applied when accessing the stored image from

the Image Analysis module.

Screen Colors… Opens the Color Settings dialog box, which enables you to set the

colors for various elements in the screen, image, and graph displays.

Trim Pot Adjust Optimizes the trim potentiometers for the ECU-Plus’ ADC outputs.

This function also optimizes the tip bias voltage.

The Window Menu

The Window menu, shown in Figure 1-13, provides access to the Image Analysis module

and allows control over all windows open in the current interface.  The Window menu

items are described briefly in Table 1-8.

Window

Image Analysis
Analyze Now

Next 
Previous
Tile
Cascade

Topography-Forward
Oscilloscope

1
2

Figure 1-13.  The Window menu.
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Table 1-8.  The Window menu items.

Menu Item Function

Image Analysis Switches to the Image Analysis module.  All settings and functions

in the Data Acquisition module remain unchanged while in the

Image Analysis module.  This function can also be accessed by

clicking on the  button on the tool bar.  Once in Image Analysis,

selecting the Image Acquire command, or clicking on the 

button, switches back to the Data Acquisition module.

Analyze Now Switches to the Image Analysis module and transfers a copy of the

selected image (or partial image) from the Data Acquisition module.

Next Selects the “next” window in the interface (e.g., Topography-

Forward, Topography-Reverse, Oscilloscope), cycling through each

currently open window with each activation of the command.

(Selecting any window listed in the numbered inventory at the

bottom of the Window menu will make that window active

immediately.)

Previous Selects the “previous” window in the interface (e.g., Topography-

Forward, Topography-Reverse, Oscilloscope), cycling through each

currently open window with each activation of the command.

(Selecting any window listed in the numbered inventory at the

bottom of the Window menu will make that window active

immediately.)

Tile Arranges the windows on the screen so they are positioned adjacent

to each other.

Cascade Arranges the windows on the screen so they are positioned in an

overlapping, offset configuration.
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Data Acquisition Tool Bar

The Data Acquisition tool bar, shown in Figure 1-14, provides single-click access to some

of the most commonly-used functions.  Each button on the tool bar is described below.

Tip Up

Tip Down Pause Scan

Continuous/Repeat Scan

AutoSave Disable

File  Save All...

Commands   Oscilloscope Instant Scan/Commands         Acquire

Window        Image Analysis

Commands  Prescan

Setup        Beam Align

Figure 1-14.  The Data Acquisition tool bar.

  Save All

Opens the Save All dialog box, which gives you the option of saving any or all windows

currently open in the Data Acquisition module (images, Topography Forward, F/S, etc.).

This function can also be accessed by selecting File⇒ Save All.

Note: If only one image window is open when the Save All command is selected, the

Save As dialog box will be opened by default.

  Tip Up

Activates the Z motor in real-time to raise the tip from the sample.  The Z motor is

activated as long as the button is pressed.

CAUTION:

When lowering the tip to the sample surface, always closely monitor the process

to avoid tip damage caused by excessive pressure.

  Tip Down

Activates the Z motor in real-time to lower the tip to the sample.  The Z motor is activated

as long as the button is pressed.  (The button is disabled when the tip is in feedback.)

  PreScan

Opens the PreScan sub-panel of the Acquisition Control Panel.  Clicking on the button

also automatically opens the Oscilloscope window.  This function can also be accessed by
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selecting Commands⇒ PreScan or by clicking on one of the scroll buttons   on

the Acquisition Control Panel.

  Oscilloscope

Opens the Oscilloscope window.  This function can also be accessed by selecting

Commands⇒ Oscilloscope.

  Beam Align

Opens the Beam Align window, which provides real-time display of the position of the

laser spot on the photodetector.  This window provides a more convenient way to perform

the beam alignment.  This function can also be accessed by selecting Setup�����

Align…

  Pause Scan

Pauses a scan in progress.  When you click this button, the probe will immediately stop on

the sample, but will it remain in feedback and will not withdraw or return to its starting X,

Y position.  Clicking on the button again resumes the scan from the point where the probe

was stopped.

  Instant Scan

Activates a scan of the sample in accordance with your configuration of the Data

Acquisition module.  This function can also be accessed by selecting

Commands⇒ Acquire.

  Continuous/Repeat Scan

Performs continuous scanning, once a single scan has been activated.  Current data in the

scan window will be overwritten by each subsequent scan until scanning is stopped or the

Continuous Scan button is toggled off (unless Auto Save has been toggled on from the

Image Acquire Setup dialog box, accessed by selecting Setup⇒ Acquire).

This function can also be implemented by toggling on the Repeat Scan option in the

Image Acquire Setup dialog box, accessed by selecting Setup⇒ Acquire.

  Auto Save Disable

Temporarily disables the Auto Save function.  To reestablish Auto Save, toggle the button

off again.  The button is disabled unless Auto Save has been toggled on in the Image

Acquire Setup dialog box, accessed by selecting Setup����	
���
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  Layered Image—“Movie”

Sequentially displays each layered image acquired in the layered imaging window.  The

function continually cycles through each of the layers until the button is toggled off.  The

button is disabled unless the layered imaging setup is configured for more than one layer.

The number of layers is specified in the Layers field of the layered imaging sub-panel of

the Acquisition Control Panel, accessed by selecting Setup����	
��������������
���
�

only available in the Advanced Setup mode, accessed by selecting Acquire���������

Setup.)

  Image Analysis

Switches to the Image Analysis window.  All settings and functions in the Data

Acquisition module remain unchanged while in the Image Analysis module.  This

function can also be accessed by selecting Window������������
��





Chapter 2
Data Acquisition Tools



2-2 Data Acquisition Tools

Overview

The Data Acquisition interface controls the instrument’s scanning and data collection

functions.  After proper set-up of the SPM stage and associated hardware (covered in the

“Hardware” sections of your instrument operation manual), data acquisition with the SPM

involves configuration and use of the various software acquisition options.

This chapter describes how SPMLab's basic software instrumentation controls are used to

acquire images, but it does not provide step-by-step acquisition procedures.  Specific

step-by-step SPM procedures are covered in your instrument operation manual.  A

comprehensive list and summary definition of every first-level Data Acquisition menu

item and tool bar button are given in the previous chapter.
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Acquisition Control Panel

The Acquisition Control Panel, shown in Figure 2-1, provides the primary access to the

instrument’s interactive configuration options.  Scan parameters, scan orientation, tip

approach, display options, modulation options, and calibration functions are all set in the

Acquisition Control Panel.  Some functions, such as the laser and feedback controls, are

enabled exclusively with particular SPM modes.

Sub-Panel
Scroll Buttons

Scan Area
Configuration

Automatic Tip Approach
to Sample Surface

Performs Sensor Response

Laser Control
(AFM Mode)

Detector Signal Modes
(AFM mode)

Tip Z Controls

Scan
Parameters

Zooms or Translates
within the Scan Range

Reorients the 
Scan Direction

Acquisition Sub-Panel 
(PreScan)

Figure 2-1.  Acquisition Control Panel.



2-4 Data Acquisition Tools

Scan Parameters

Once feedback is established and scanning is in progress, optimal images can be acquired

by adjusting the feedback and scan parameters correctly.  To achieve this optimization, it

is necessary to adjust the set point, scan rate, proportional gain (P), integral gain (I), and

derivative gain (D) in the Acquisition Control Panel.  The scan parameter fields, shown in

Figure 2-2, allow you to adjust these parameters while monitoring the associated signals

in the Signal window during Line Scan or during the scan.

Figure 2-2.  Scan Parameter Fields.

Set Point (nA)

During a scan, the system will extend and retract the Z piezo to maintain the feedback

current at the value specified in the Set Point field.  During tip approach, the computer

uses the set point value to establish the correct amount of Z movement necessary to bring

the system into proper feedback.  As the tip gets closer to the surface, the deflection of the

cantilever causes the sensor current to increase.  Once the current reaches the defined set

point, the computer will consider the system to be in feedback; the approach motor will be

turned off; and the feedback loop will be activated to keep the sensor current at the set

point.

Note: For non-contact amplitude mode data acquisition, Set Point is defined in % units,

determined as a percentage of the cantilever oscillation amplitude.  For non-

contact phase mode data acquisition, Set Point is defined in nA.

Scan Range (µm)

The Scan Range field determines the distance of one side of the square scan area (e.g., a

1.0 µm scan range is equivalent to a 1.0 µm x 1.0µm square area).  The options in this

field are determined by the type of scanner you have installed in your system, i.e., the

scanner file loaded to determine the system’s calibration coefficients.
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Scan Rate (µm/s)

The tip scans the sample surface at the speed specified in the Scan Rate field.  Scan speed

is as important as the PID settings in acquiring an optimal scanned image.  It is possible

to scan a sample so fast that the Z piezo cannot react quickly enough to track the surface

accurately.

Resolution

The value in the Resolution field determines the number of sampling points for a given

scan range (e.g., a setting of 300 would set up acquisition of a 300 pixel-per-line by 300

line image within the given scan range).  Therefore, a higher resolution setting creates

more data points for a scan, but because more scan lines are acquired, it also increases the

length of time it takes to complete the scan.

PID Settings

The PID (proportional, integral, and derivative) feedback control system uses corrections

which are the weighted sum of terms proportional to the error signal, the integral of the

error signal, and the derivative of the error signal.  The error signal is the difference

between the sensor signal and the set point.  The optimum settings for the coefficients are

largely dependent on sample properties, scan rate, and the probe tip geometry.  Therefore,

they need to be determined experimentally.

The interactive relationship between optimal feedback/scan conditions and PID settings,

scan rate, and set point is described in the “PID Settings” section of your instrument

operation manual.

Proportional

Values ranging from 0-30 can be entered in the Proportional field.  Sample properties

greatly affect the optimal value for proportional gain, which must be determined

experimentally.  Initial settings are dependent on the application and on the instrument.

Integral

Values ranging from 0-30 can be entered in the Integral field.  Initial settings are

dependent on the application and on the instrument.

Derivative

The value in the Derivative field should initially be set to 0.  Raising this value may

reduce unwanted oscillation, allowing a higher integral gain setting.  The optimal value is

best determined experimentally.
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Zoom/Translation and Rotation

The Scan-Area Configuration group, shown in Figure 2-3, functions as an interactive

translation and orientation tool that allows you to zoom in or out from the originally

specified area in the Scan Range field, translate (move) the scan area, and reorient the

angle of rotation of the scan.

Figure 2-3.  Zoom/Translation and Rotation.

Zooming and Translating

Clicking on the Zoom/Translate button opens the Translate Location sub-panel, shown in

Figure 2-4.  This function allows you to use the mouse to translate and/or resize the scan

area.  (The button is disabled unless the scan window is active.)  When the function is

initially activated, the inner square represents the current scan area.

Current scan area

Figure 2-4.  The Translate Location sub-panel.

To translate the scan area without changing the size of the scan range:

1. Left-click once within the square and move the mouse to translate the scan area

within the boundaries of the larger region.

2. Right-click to set the new location and exit the sub-panel.

The new coordinates will be indicated in the Locate field.
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The operation can be performed while a scan is underway.  Whenever the zoom or

translate function is activated, the instrument automatically begins a new scan

immediately.

To resize the scan range (zoom in or out):

1. Left-click once within the inner square, then left-click again and drag.

2. As you drag the mouse, the changing scan range is constantly updated in the

Scan Range field.

Moving the mouse without holding down the button still allows you to translate the scan

range.

3. Right-click to set the newly resized scan range and exit the sub-panel.

Both operations can also be accomplished by using the cursor in the same way on the

image in the scan window.

Reorienting the Scan Direction

To reorient the rotation of the scan, you can define the new orientation angle directly on

the scan window or enter a new angle in the Rotate field (or both).

To automatically rotate the sample using the orient tool:

1. Click on the Orientate button.

The cursor will change to a crosshair when you pass it over the scan area, as

shown in Figure 2-5.

2. Click and drag to draw out a line that defines the horizontal scan direction (after

orientation).

3. Release the mouse button, and then use the mouse to move the resulting line to

change its position in the scan area.

To redraw the line, click and drag again.
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Figure 2-5.  Initial orientation of sample.

4. Once the line is placed appropriately, right-click to rotate to the new scan

direction and restart the scan.  The new orientation is shown in Figure 2-6.

Figure 2-6.  New orientation of sample, after applying rotation function.

The scan orientation can also be rotated by typing a new value directly into the Rotate

field.  The operation can be performed while a scan is underway.  Whenever the rotation

angle is entered by any method, the instrument automatically begins a new scan

immediately.

Note: When using the zoom or rotate functions, system calibration (see below) is

turned off.  To re-engage system calibration, reselect a standard range from the

Scan Range field.
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Zoom Out

Click the Zoom Out button to restore the previously zoomed area (one level only).

Calibration Field

The Calibration field reflects the current calibration mode your instrument is using, which

is a function of the System File Edit operation, accessed by selecting Acquire⇒ SysFile

Edit.  For most operations, the field should read “System.”  For more information, refer to

“System File Edit” on page 3-9.

Acquisition Sub-panels

The various acquisition sub-panels available in the standard scanning mode are accessed

by clicking the  and  buttons.

When scanning in nonstandard modes, such as SysFile Edit or Verify Calibration,

alternate Data Acquisition sub-panels will open; these are described in the sections that

cover those scanning modes.

The PreScan Sub-panel

The PreScan sub-panel, shown in Figure 2-7, allows access to the Tip Approach, Sensor

Response, and Laser and Detector signal controls.  This sub-panel is necessary for proper

setup after replacing an AFM cantilever and for checking laser alignment before a scan.

The PreScan sub-panel can also be opened by selecting Commands⇒ PreScan or by

clicking on the  button on the tool bar.

Figure 2-7.  The PreScan sub-panel.
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Tip Approach

Clicking on this button initiates a computer-controlled automatic tip approach to the

sample surface.  Once the detector signal (sensor) current reaches the defined set point,

the computer will consider the system to be in feedback and activate the feedback loop to

keep the sensor current at the set point.

Sensor Response

Occasionally during tip approach, long range tip/sample interactions, such as static

charge, can cause sensor current to increase.  This can cause the current level to reach the

set point and engage the feedback loop before the tip actually reaches the surface.  This

phenomenon is known as “false feedback.”  Clicking on the Sensor Response button can

test for false feedback.  The operation opens the Force Calibration window and ramps up

the Z-piezo through approximately 10% of its total Z range while measuring sensor

response (in contact AFM, cantilever deflection is measured).  The operation creates a

sensor current vs. voltage plot that illustrates the response curve.  When the system is in

true feedback, a straight-line response ramping up from zero is plotted, as shown in

Figure 2-8.

Figure 2-8.  The ideal sensor response curve—“true feedback.”

If the sensor response curve indicates that the system is in false feedback, the warning

message shown in Figure 2-9 will appear:
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Figure 2-9.  “False feedback” sensor response curve.

The system must be in feedback (or false feedback) to perform the sensor response

operation.

Laser

WARNING:

ALWAYS disengage the tip and then power OFF the laser with this function

before lifting the SPM head from the sample.  NEVER look directly into the

laser beam at either the LOW or HIGH settings.

The Laser field group box, shown in Figure 2-10, provides control of the instrument’s

detector laser.  The function is used during tip installation and alignment, and during

scanning, as described in all applicable procedures.

Figure 2-10.  The Laser panel.

Detector Signal

The Detector Signal group box, shown in Figure 2-11, allows you to choose between

three modes of optimizing the photodetector/laser alignment.  Each of these settings

allows you to optimize the alignment of the laser, mirror, and photodetector in a specific

way so you can optimize photodetector response for feedback and for lateral force

scanning.  Each detector signal setting is used in one of the steps of the alignment process.

Figure 2-11.  The Detector Signal group box.
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Sum

Selecting the Sum option setting produces a sensor signal which calculates the sum of the

four segments of the photodetector, (A+B+C+D), as shown in Figure 2-12.

The Sum option facilitates maximizing of sensor current during adjustment of the laser,

mirror, and photodetector knobs (see Figure 2-13).  It is the coarsest, and usually the first,

of the laser alignment adjustments.

A B

C D

Figure 2-12.  Photodetector.

LASER

MIRROR
PHOTODETECTOR

SAMPLE
INTEGRA TED
TIP

CANTILEVER

Figure 2-13.  Laser, mirror and photodetector configuration.

L-R

Selecting the L-R mode causes the sensor to output the difference between the left and

right pairs of the photodetector segments, ((A+C) - (B+D)).  This facilitates optimization
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of the photodetector for the lateral force mode.  It is usually the second of the laser

alignment adjustments.

T-B

Selecting the T-B mode causes the sensor to output the difference between the top and

bottom pairs of photodetector segments, ((A+B) - (C+D)).  This setting is used by the

feedback loop during normal scanning.  The feedback signal will maintain a constant

sensor current value by adjusting the Z piezo.  The T-B adjustment is optimized with the

mirror and is usually the third of the laser alignment optimization adjustments.

Z Adjust

The Z Adjust buttons, shown in Figure 2-14, are used to compensate for Z piezo drift or

sample expansion/contraction.  The function is typically used when the Z piezo voltage

drifts away from the set point or desired setting.  The voltage level is monitored at the Z

piezo signal trace in the Oscilloscope window.

Figure 2-14.  The tip Z controls.

Three operations occur consecutively when either the Z Adjust Up or Z Adjust Down

button is activated:

-The Z piezo retracts.

-The Z motor raises or lowers the head, depending on which button is activated.

-The Z piezo is activated, and the feedback loop compensates for the Z motor

adjustment by bringing the tip back into feedback.

The  button causes the Z motor to raise the head; the  button causes the Z

motor to lower the head.  The operation can be performed (while the tip is in feedback) in

either the static state or during a scan.
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The Display Sub-panel

The ThermoMicroscopes Instant Scan function allows you to adjust Z scaling, display

shading, and display leveling while a scan is in progress.  This is accomplished with the

Display sub-panel, shown in Figure 2-15.

Figure 2-15.  The Display sub-panel.

Note: To change the display parameters, the image window must be active.  If multiple

images are displayed simultaneously, the changes will only affect the active

highlighted image.

Most of the Display sub-panel options described in this section can be pre-set as defaults,

prior to scanning, through the Acquisition Preferences dialog box, accessed by selecting

Setup⇒ Preferences (see “Preset Acquisition Preferences” on page 2-21).  While

scanning, the Display sub-panel options allow you to override the default settings and

adjust the functions in real-time.

Leveling

Image leveling fits the scanned image to a geometric figure and then subtracts the figure

from the image, i.e., levels the entire image line by line or to a plane.  The Leveling drop-

down list allows you to apply four leveling options in real-time:  1st Order Line, 2nd Order

Line, 1st Order Plane, or 2nd Order Plane.

Line leveling (also called 1D leveling) fits each line of the image to a line, in the X

direction only.  The fitted line is then used to level the line out of the image.  The

following equations represent the fitted lines, based on the selected order:

1st Order Line:  Z = ax + b

2nd Order Line:  Z = ax2 + bx + c
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Plane leveling (also called 2D leveling) levels the data in both the X and Y directions.

The following equations represent the fitted planes, based on the selected order:

1st Order Plane:  Z = ax + by + c

2nd Order Plane:  Z = ax2 + by2 + cxy + dx + cy + f

Post-acquisition, basic and advanced leveling functions can be applied in the Image

Analysis module.  These procedures are described in “Leveling” in Chapter 5.

Shading

Shading can enhance the details of the scanned image by simulating a light source, which

creates shadows that can clarify small features.  The Shading drop-down list allows you to

apply left or right shading to a scan, in real-time.

Post-acquisition, basic, and advanced shading functions can be applied in the Image

Analysis module.  These procedures are described in the “Shading” section in Chapter 5.

Z Scaling

Z scaling controls how the color palette represents the surface topographic information at

every X,Y coordinate of the image.  Proper adjustment can improve visualization of

surface details.  The default mapping of the colors to the Z data is linear across the entire

Z range of the data in the image, as shown in Figure 2-16.  Other Z scaling options

include:  Min /Max, Standard Deviation, 0/Max, and Manual.

Color
Palette
Index

Z MIN Z MAX

Figure 2-16.  Default Z scaling.

Proper adjustment of how the color palette is mapped to the Z range of the data can

significantly alter the visualization of surface details.  The Z scaling options in the Instant

Scan mode include optimization of the function based on the minimum and maximum Z

values of the previously scanned area, the standard deviation of the Z data, the absolute 0

and maximum Z values, or manual adjustment of the Z range over which the palette will

be applied.
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Z MIN Z MAX

# of
Data

Points

Figure 2-17.  Min/Max Z scaling.

Min/Max

Min/Max Z scaling, shown in Figure 2-17, linearly distributes the palette from the

minimum to the maximum Z values of the scanned area (updated at a predetermined

interval).  This option optimizes Z scaling most effectively when a histogram of the

sample’s Z data is evenly distributed across the Z range of the image.

Standard Deviation

Standard Deviation Z scaling, shown in Figure 2-19, updates Z scaling based on the

standard deviation of the Z-value of the scanned area (updated at a predetermined

interval).

In the Standard Deviation mode, the Histogram group box is opened, shown in Figure 2-

18, allowing you to adjust the width and offset of the color-distribution.  This option

optimizes Z scaling most effectively when the majority of the sample’s Z data forms a

relatively narrow distribution but a few data points are above (or below) the width of the

curve’s standard deviation (i.e., spikes in the data or specks of contamination on a

relatively flat sample).

Figure 2-18.  Histogram group box.

The standard deviation function distributes the color palette across the portion of

the histogram that contains the majority of the data.
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Z MIN Z MAX

# of
Data

Points

Offset

Width

Z MIN Z MAX

Offset

Width

Color
Palette
Index

Z MEAN

Figure 2-19.  Standard Deviation Z scaling.

0/Max

0/Max Z Scaling, shown in Figure 2-20, linearly distributes the palette from

absolute zero to the maximum Z values of the scanned area (updated at a

predetermined interval).

0 Z MIN Z MAX

# OF
DATA

POINTS

Z RANGE

Figure 2-20.  0/Max Z scaling.

0/Max Z Scaling is used when you want to start the grayscale color map from absolute

zero, even though the minimum may be higher than zero.
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Z Offset

Z Range

Lower
Surface

0 nm

Mesa Tops

200 nm

Figure 2-21.  Manual Z scaling.

Manual

Manual Z scaling, shown in Figure 2-21, enables the Z Range and Z Offset fields, which

allow you to define the settings by typing in values or adjusting the spinners.

The image contrast is adjusted based on the manually entered Z range and Z offset values,

as shown in Figure 2-22.

Figure 2-22.  Entering Manual Z scaling values.

The Manual mode can be used to optimize Z scaling on a flat sample with high mesas or

deep holes scattered across the surface.  This type of sample has two possible areas of

data of interest:  the top surface and the bottom surface.  A normal color distribution

would display the large structures, but smaller details on the top and bottom surfaces

would be lost.  The manual mode allows you to adjust the Z offset and narrow the color

distribution to a range that will effectively ignore (saturate with color) the lower surface,

so the details on the mesa tops can be easily seen.  Conversely, higher features can be

ignored so details on the lower surfaces will be seen.

Update Z Scaling

The Update Z Scaling button applies the Z scaling settings immediately, while the scan is

in progress.
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Z scaling is updated after each line for the first three lines of the scan and then at a

constant interval (defined as Resolution/15).  The Update Z Scaling button is not

available when Z scaling is set to the Manual option.

Applying Acquisition Display Settings to Saved Images

All Z scaling, leveling, and shading display functions you apply when acquiring an image

can also be applied when the image file is opened in the Image Analysis module.  To

apply the display settings in the Image Analysis module, select the Apply Acquisition

Display Settings option in the File Manager dialog box in the Image Analysis module, as

shown in Figure 2-23.

Figure 2-23.  The Apply Acquisition Display Settings option.

When opening an acquired image from the Image Analysis module, click on the 

button or select File⇒ File Manager, then select the Apply Acquisition Display Settings

option (in the bottom of the window) and select the file you want to open.  The original

raw data is not changed by applying the acquisition display settings, and the raw data file

can always be opened in its original form simply by making sure the Apply Acquisition

Display Settings option is toggled off.

Automatic Application of Display Settings

The Z scaling, leveling, and shading options described in this section can be set up prior

to scanning to be performed automatically during image acquisition.  This is

accomplished with the Acquisition Preferences dialog box, accessed by selecting

Setup⇒ Acquisition Preferences.  The display settings in this dialog box are the same as

those described below in the Display sub-panel features (see “Preset Acquisition

Preferences”).  Any changes to the Instant Scan display functions on the Display sub-

panel will override the settings configured with the Acquisition Preferences dialog box.
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The Modulation Sub-panel

The Modulation sub-panel, shown in Figure 2-24, allows you to adjust the tip modulation-

amplitude and data averaging for use in the modulated force scanning mode.  (This mode

is described fully in your instrument operation manual.)  This panel is only enabled during

modulated force operation.

Figure 2-24.  The Modulation sub-panel.

You can define the Z amplitude of the tip modulation (see Figure 2-25) using the

Amplitude field.  The amplitude setting can be adjusted from 0.0-40.0 Å.

Figure 2-25.  Modulated force amplitude.

You can also set the ratio of data sampling per modulation cycle with the Averaging field.

A setting of 11 cycles, for example, would sample the data every 11th cycle.  Increasing

the averaging ratio improves the signal/noise ratio (amplitude of the signal compared to

background noise), but requires that the sample be scanned more slowly in order to allow

the selected number of cycles to be averaged at each pixel.  The averaging setting can be

adjusted from 1-20 cycles.
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Preset Acquisition Preferences

Some image acquisition prescan tasks and some image display functions can be set up to

be performed automatically whenever a scan is initiated.  Test for False Feedback and

Determine Sensor Response can be preset to execute automatically during tip approach.

In addition, the real-time image display options Z Scaling, Leveling, and Shading can be

pre-selected.  This allows you to automatically level, scale, and shade images prior to

entering the Image Analysis module.  The acquisition and display options are set in the

Acquisition Preferences dialog box, shown in Figure 2-26, which is accessed in the Data

Acquisition module by selecting Setup⇒ Preferences.

Figure 2-26.  The Acquisition Preferences dialog box.

Tip Approach

The Tip Approach acquisition preferences allow two operations to be performed

automatically whenever tip approach is activated.

Test for False Feedback

This function automatically tests for false feedback during tip approach by analyzing a

force-distance curve of the feedback sensor current.  If the curve has a negative slope, the

software determines the system to be in false feedback, and a warning message appears.

Note: If you want to acquire an image from the FastTrack channel, the Test for False

Feedback option must be selected.
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Determine Sensor Response

The Determine Sensor Response function automatically determines sensor response in

nA/nm (cantilever deflection (nA) vs. piezo displacement (nm)).  The function is also

performed by clicking the Sensor Response button (on the PreScan sub-panel of the

Acquisition Control Panel).  For a detailed description of false feedback and sensor

response, see “Sensor Response” on page 2-10.

Note: If you want to acquire an image from the FastTrack channel, the Determine

Sensor Response option must be selected so that the appropriate scale factor can

be applied.

Display

The Display group box allows you to preset the automatic Z Scaling, Leveling, and

Shading functions before scanning.  During any scan, these presets will automatically be

applied to the images.

The functionality of the three options, which can also be accessed via the Display sub-

panel of the Acquisition Control Panel, is described fully in “Display Sub-panel” on page

2-14.  While the scan is in progress, any further display functions applied with the Display

sub-panel will override the preset display options set in the Acquisition Preferences

dialog box.

Any Z Scaling, Leveling, or Shading display functions you apply when acquiring an

image can also be applied when the image file is opened in the Image Analysis module

(see “Applying Acquisition Display Settings to Saved Images” on page 2-19).

Miscellaneous

Show ToolTips

Checking this box enables the ToolTips function.  Whenever you rest the mouse pointer

over a tool bar button, text will appear that gives the name of the function accessed by

that button.

Screen Edit Full Details

When this box is checked, all the image acquisition screen controls, including the

Acquisition Control Panel and the Signal window, will be displayed when you enter the

Screen Editor module.

Save All Image Buffers

This box applies to the File⇒ Save As… function in the Image Analysis module.  When

this box is checked, all the images in the Buffer array will be saved when an image is
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saved.  If this box is not checked, the following warning will appear when you select

File⇒ Save As…:

Figure 2-27.  Save image buffers warning.

The Signal Window

The Signal window, shown in Figure 2-28, allows you to monitor various signals in real-

time so you can observe the effects of the feedback parameters and other settings.  The

Signal window is active by default when entering the Data Acquisition module.  The

window can be re-sized.

Figure 2-28.  The Signal window.

The Signal window functions in three modes:  Oscilloscope, Spectrum, and Line Scan.

When the window is opened, the oscilloscope mode is active by default.  The Signal

window can also be opened by clicking on the  button on the tool bar.

While the window is active, you can toggle between the modes by clicking on the Scope,

Spectrum, or Line buttons in the upper-right portion of the window.
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Common Controls

The following controls/options are common to all modes of the Signal window.

Signal Menu

The Signal Menu, shown in Figure 2-29, allows selection of different signals for display.

Different signals are available for each mode of the signal window.  The signals available

in this menu may differ depending upon the options you have installed with your

microscope.

Figure 2-29.  The Signal menu.

 Freeze Trace freezes the trace so measurements can be performed by clicking the

cursor in the signal window.

Top/Bottom allows you to toggle the upper and lower signal traces in order to expand a

single trace to the full display area.

Scan Controls

The following controls are used to control the vertical scale of the signal windows.

Offset manually sets the offset of the vertical scale.  The offset field allows you to set the

center point of the vertical scale manually.

Range manually sets the range of the vertical scale.

Full sets the vertical scale to the full range appropriate for the currently selected signal.

Manual manually sets the vertical scale to the values entered in the Offset and Range

fields.

Auto automatically sets the vertical scale to a range slightly larger than the highest or

lowest excursion in the previous sweep.  The setting is appropriate for viewing small

signal variations on the trace.
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Set combines the functions of the Auto and Manual controls.  When you click the Set

button, the software first calculates the average signal level and the signal range for the

signal you are observing.  The values for average level and the range are then placed in

the Offset and Range fields.  The software then allows you to manually adjust the Offset

and Range fields as desired.

Oscilloscope

Clicking on the Scope button within the Signal window displays the time-based user-

selected signals.  Two Oscilloscope signals—Internal Feedback and Z Piezo—are

displayed by default.  Other input signals can be accessed through the Signal pull-down

menu.  If input signals are not available due to lack of ADCs, the particular input signal

will be marked by a double asterisk (**).

By left-clicking in the signal trace field, a vertical marker is attached to the cursor,

providing an exact time-based signal measurement reading anywhere the marker is

placed.  Clicking on the right mouse button exits the function.

Sample Time Changes the time scale for the oscilloscope display.

Line Scan

Clicking on the Line button initiates a continuous scan cycle over a single line on the

sample, displaying a graph of the Z height (Topography) and a graph of the sensor signal

current (Internal Sensor) for that user-defined line, as shown in Figure 2-30.

Figure 2-30.  Line scan.

On a topography trace, left-clicking in the signal field attaches a vertical marker to the

cursor, which provides an exact X vs. Z reading anywhere the marker is placed.  Click on

the right mouse button to exit the function.  On an internal sensor trace, left-clicking in

the signal trace field attaches a vertical marker to the cursor, which provides an exact X
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vs. sensor current reading anywhere the marker is placed.  Click on the right mouse button

to exit the function.

The Line Scan window presents the same controls/options as the Oscilloscope window,

with the following exceptions:

F displays the forward scanned line.

R displays the reverse scanned line.  Note:  R is only enabled if the appropriate Rev

option switch is toggled on in the Image Acquire Setup dialog box, accessed by selecting

Setup⇒ Acquire.

Level toggles the automatic leveling function.  The automatic leveling function allows

you to remove slope from the line trace when observing the Topography signal, making

observation of features easier and more convenient.  This flattening is a software

correction.  The geometry of the tip/sample interaction is not physically changed by the

Level function.

Scan Line specifies the number of the line that will be scanned (dependent upon the

selected image resolution setting).

Spectrum

Clicking on the spectrum button initiates a Spectrum analysis of the Z piezo, tip voltage,

sensor current (Internal Feedback), or external inputs, as shown in Figure 2-31.

Figure 2-31.  Spectrum.

The Spectrum analysis function is typically used after feedback is achieved to monitor

vibration affecting the SPM system.  By left-clicking in the signal trace field, a vertical

marker is attached to the cursor, which provides an exact frequency versus intensity

reading anywhere the marker is placed.  Click on the right mouse button to exit the

function.
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The Spectrum window presents the same controls/options as the Oscilloscope window,

with the following exceptions:

Frequency allows you to set the spectral frequency sweep range.  The low end of the

frequency range is set to 0 Hz by default; the high-end frequency is set in the Frequency

field.  The default range is 2 kHz, adjustable to a maximum setting of 25 kHz.  A

frequency range of 0-0.5 kHz is useful for monitoring vibration-induced effects.

Average toggles on the spectrum analyzer’s averaging function, which displays the

continuously calculated average of successive sweeps of the spectrum.  The averaging

function minimizes the effects of random noise.  By continually updating the trace based

on the latest sweep and averaging all of the previous sweeps, the effects of random, non-

repeating noise spikes are minimized.  The number of sweeps used in the averaging is

continuously updated in the Average field.

Reset resets the number of sweeps used in the averaging function to 1, resetting the

running Spectrum average.

Image Acquire Setup

The Image Acquire Setup dialog box, shown in Figure 2-32, allows you to control several

key areas of your scanning configuration.  Data channels, tip voltage and feedback source,

calibration file, data file information, gain setting, and scan pattern are all configured

from this dialog box.  To open the Image Acquire Setup dialog box, select

Setup⇒ Acquire in the Data Acquisition module.

Figure 2-32.  The Image Acquire Setup dialog box.
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Data Channels

Up to four data channels (forward or reverse) can be acquired in a single scan, i.e., you

can acquire up to four images, each in a different scan mode, during one scan.  Each scan

channel will have its own real-time display window in the main Data Acquisition

interface.

Every scan mode allows you to acquire images during the forward or reverse scan, or

both, as shown in Figure 2-33.  This information can be valuable because tip geometry

and sample topography can be such that a forward scan image and a reverse scan image of

the same area may yield different information.

Figure 2-33.  Forward and reverse scanning.

Topography generates a topographic image of the scan area.  The quality of this image is

affected by the scan parameters defined in the Data Acquisition module (see the

“Feedback” section in your instrument operation manual).  With TrueMetrix systems, the

image is corrected for linearity and hysteresis in the Topography mode.

Internal Sensor generates an image in which the internal sensor current is plotted to

show topographic features (see the “Feedback” section in your instrument operation

manual).

Z Modulation generates a modulated force image of the scan area.  (For more information

on this scanning mode, see “SPM Modes” and “Modulated Force” in your instrument

operation manual.

Lateral Force generates a lateral force image of the scan area.  (For more information on

this scanning mode, see “SPM Modes” and “Lateral Force Microscopy” in your

instrument operation manual.)

IN 1 & 2 provides data channel connections directly to the BNCs, IN 1 or IN 2, on the rear

panel of the ECU-Plus.  This allows external signals, such as voltage or current from
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electrochemistry experiments or information from an external feedback loop, to be plotted

as the Z component of an image.

FastTrack (available in AFM contact mode only) compensates for some forms of piezo-

induced distortion of the image.  Using the FastTrack feature, you can display difficult-to-

resolve details in the acquisition image.  Before acquiring an image from the FastTrack

channel, you should select the Test for False Feedback and Determine Sensor Response

options from the Acquisition Preferences dialog box, accessed by selecting

Setup⇒ Preferences.

Z Piezo (TrueMetrix systems only) generates an image in which the voltage on the Z

piezo is plotted to show topographic features.  This function is useful for imaging very

flat surfaces, where the feature size is smaller than the noise floor of the linearizers.

Tip Voltage

The Tip Voltage channel selection option provides the option of selecting one of the

system’s auxiliary output DACs (DAC 1 or DAC 2) to provide voltage to the SPM tip.

This option is used for specialty applications in STM, SEPM and other modes.  For most

scanning operations in all modes, the default Internal setting should be used.

Feedback

For specialized experiments, signals can be fed into the system’s ADC external inputs.

This option is used for specialized applications.  For most scanning operations, the default

Internal setting should be used.

Selecting the IN 1 or IN 2 options enables an adjustable conversion factor.

Connect ALO to Out 2

This checkbox applies to instruments using the I/O-10 interface.  Checking this box sets

the T-B signal to Out 2 of the I/O-10 interface, to enable the use of external feedback.

Miscellaneous

The Miscellaneous group box in the Image Acquire Setup dialog box provides access to

the Calibration source file setup, the Z Setpoint setting, and the Jog Approach function.

Calibration

The Calibration field allows you to enable/disable use of the standard system (scanner)

calibration file when performing a scan.  The system calibration file determines the

scanner calibration coefficients that translate X, Y, and Z piezo voltages and other scan

parameters into topographic measurement data.  The options are System File and Off.
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During normal operation, the system should always be operated in the System calibration

mode.

For information on re-calibration and editing the system file calibration coefficients, see

“System File Edit” on page 3-9.

Z Setpoint

This setting sets the initial Z piezo voltage level before the scan is initiated.  The Z piezo

range for tripod scanners is 0 to +100 V; for tube scanners, +/- 220 V.  By default, the Z

set point is set to the middle of the Z range of the scanner, e.g., for a 10 µm Z scanner, the

piezo can accommodate topographic measurements that are 5 µm above the midpoint of

the Z range and 5 µm below the midpoint.  If the sample is either quite tilted with respect

to the scan plane, or the sample is quite rough, the set point may need to be set away from

the midpoint.

Thermal expansion/contraction of the sample can also cause significant drift of the piezo

from its original position (after reaching feedback).  If for any of these reasons the Z

piezo drifts out of its voltage range, the feedback loop saturates, losing the ability to

respond, and the constant force condition is violated.  In this situation, the tip can crash.

This condition can be seen on the oscilloscope with the Z Piezo (topography) signal when

the red line goes off scale or a line scan plot shows abrupt truncation and a horizontal line

scan segment.  To correct the saturation of the feedback loop, you need to readjust the tip

position away from the direction in which it saturates.  This can be done by disengaging

and reengaging the tip into feedback.

While the scan is in progress, the Z piezo voltage level is determined by the topography

of the sample and can be monitored with the Z Piezo signal trace on the Oscilloscope.

Jog Approach

Jog Approach sets up a stepped tip approach mechanism whenever the Tip Approach

function is activated from the Acquisition Control Panel.  This activates the head's Z

motor to lower the tip toward the surface in steps, rather than in a continuous, linear

approach.  At the bottom of each jog step, the tip's Z piezo is ramped slowly toward the

surface to determine if the feedback set point level (fixed in the Acquisition Control

Panel) has been reached and feedback can be achieved.  If not, the Z piezo retracts the tip

and the Z motor is “jogged” again to lower the head another step, where the Z piezo is

ramped again (see Figure 2-34).  The advantage of activating the Jog Approach function

is that there is less risk of crashing the tip into the surface during the final tip approach.

The only drawback is that the tip approach time may be significantly slower when the

function is activated.
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Figure 2-34.  Jog approach.

Auto Save

The Auto Save group box in the Image Acquire Setup dialog box, shown in Figure 2-35,

allows you to automatically save scan images under a name and in a folder of your own

choosing.  To access the Auto Save feature, select Setup⇒ Acquire.

Figure 2-35.  The Auto Save group box.

The On checkbox turns the Auto Save function on and off.  The File field allows you to

name the image.  The Path field, just below the File field, allows you to create a path and

designate a folder for the files.

If you name a directory in the Path field that does not exist, the Auto Save Directory Error

dialog box, shown in Figure 2-36, will ask if you wish to create it.  Click on the Yes

button to automatically create this directory.

Figure 2-36.  Auto Save Directory Error dialog box.

By supplying a heading in the File field (six characters maximum) and selecting On, the

image will be saved at the end of each scan, in either the single-scan or repeat-scan

modes.  A numerical suffix will be automatically appended to the file name (e.g.,

SCAN1), and the software will automatically append the correct file extension to the file

name.  The numerical suffix for the file name will be automatically incremented with each
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scan (e.g., SCAN2, SCAN3, etc.).  The Auto Save function can be temporarily disabled

by clicking on the Auto Save Disable button  on the Data Acquisition tool bar.

Scan Mode

1D Scan disables Y scanning to generate a scan image by scanning a single line

repeatedly (see Figure 2-37).  1D scanning can be used in electrochemistry experiments

and to analyze deposition data.  This feature is also used for diagnosing various

intermittent phenomenon which might occur in the system (e.g., to determine microscope

stability or to observe thermal drift).

Figure 2-37.  1D scanning.

Line (enabled for 1D scanning only) allows you to select the line that will be scanned in

the 1-dimensional mode.

2D Scan scans in both the X and Y directions to generate a scan image from the

consecutive lines in the scan area (see Figure 2-38).  This is the most common method of

generating an image of a scan area.

Figure 2-38.  2D scanning.

Y/X Ratio allows you to change the Y/X scan resolution ratio to limit scan resolution in

the Y direction.  For example, selecting a value of 2 in the Y/X Ratio field sets the

scanner to skip every other horizontal scan line, filling in the missing data with a

duplicate of the prior line, as shown in Figure 2-39.  The default is 1.
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Figure 2-39.  Y/X Ratio.

Note: When using a Y/X ratio of 2 or more, the scan resolution divided by the Y/X

ratio must be an integer.  Otherwise, the system will not allow the selection.

(Scan resolution is specified in the Resolution field of the Acquisition Control

Panel.)

Z Gain

The Z piezo gain is set in the Z Gain group box to determine the optimal gain vs. image

resolution.  The general rule of thumb for the Z gain setting is:  if the sample’s maximum

feature height is less than 10% of the Z range of the scanner, select Low for optimal

resolution; if the sample’s maximum feature height is within 10-90% of the scanner’s Z

range, select High.  Selecting the Auto Adjust option enables the system to automatically

determine the optimal Z gain setting.

Z Gain Setting Voltage Ranges.

Scanner Type Low High
Tripod 0-40 V 0-100 V.

Tube +/- 40 V +/- 220 V
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Non Contact Operation

The first part of this section describes the controls of the Non Contact Control window.

The second and third parts describe the procedures for using SPMLab with amplitude

detection and phase detection, and the fourth part provides a simple procedure for taking

phase images in non-contact operation.

The Non Contact Control Window

The Non Contact Control window, shown in Figure 2-40, is opened by selecting

Setup⇒ Non Contact.  The Active checkbox must be checked to enable the controls and

options within the window.

Figure 2-40.  The Non Contact Control window.

Range

The Range field, shown in Figure 2-41, specifies the range of the oscillation frequency

range of the sweep that is applied to the piezo in order to drive the cantilever.

Figure 2-41.  Non contact settings and controls.
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The set range should include the oscillation frequency of the probe you are using for data

acquisition.  The resonant frequency range can be found on the cover of the box

containing the non-contact cantilevers.

Amplitude

The Amplitude field sets the drive voltage of the piezo that drives the cantilever.  This

value can be set by highlighting and typing directly into the field or by clicking on the

spinners.

Frequency

The Frequency field sets the oscillation frequency of the cantilever or displays the drive

frequency selected directly on the spectrum.

This value can be set by one of two methods:

In the Frequency field:

1. Highlight and type directly into the numeric field, OR

2, Click on the spinners.

In the frequency Spectrum:

1. Position the cursor in the spectrum, and click on the left mouse button.

2. Position the attached line marker at the resonant frequency in the

spectrum, and left-click again to select the frequency.

3. Click on the right mouse button to exit the function.  The value in the

Drive Frequency field will change accordingly.

Input Gain

The Input Gain field sets the amplifier gain before demodulation for the collected detector

signal.

Spectrum

Clicking on the spectrum button runs a sweep of the currently specified frequency range.

You can stop the frequency sweep by pressing the Esc key.

Full Spectrum

Clicking on the Full Spectrum button changes the specified frequency range to the full

range and runs a sweep.
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Zoom In

After running a sweep, clicking on the Zoom In button allows you to zoom in to a

specified frequency range using the following method:

1. Click the Zoom In button.

2. Left-click within the spectrum display.

3. Position the cursor at the lower limit of the zoom-in range and click the left

mouse button.

4. Move the cursor to the upper limit of the zoom-in range and click the left mouse

button again.

5. Click the right mouse button to perform a sweep of the new range.

You can perform the zoom function as many times as necessary.

Zoom Out

Clicking on the Zoom Out button successively backs out to the frequency ranges set prior

to applying the zoom-in function.  You can apply the zoom-out function as many times as

you applied the zoom-in function, then the button is disabled.  Zooming out to a new

frequency range automatically runs a new sweep.

Active

The Active checkbox, shown in Figure 2-42, activates Non Contact mode.

Figure 2-42.  The Active checkbox.

IMPORTANT: In Non Contact mode, Active must be unchecked to properly perform

beam alignment.

I/O-MOD

The I/O-MOD menu allows you to select Non Contact or SEPM (scanning electrostatic

potential microscopy) in order to properly set up and operate these modes.  If the SEPM

option is not installed, this menu will not be displayed.  Refer to the documentation on

SEPM for more information on using this mode.
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Mode

Clicking on the Amplitude option button in the Mode group box, shown in Figure 2-43,

sets the feedback-control loop to respond to changes in cantilever oscillation amplitude.

Amplitude detection is the non-contact method usually used for standard non-contact

operation.  Clicking on the Phase option button in the Mode group box sets the feedback-

control loop to respond to changes in cantilever oscillation phase angle.  Phase detection

is usually the method used when the oscillation amplitude is very small and/or when

higher sensitivity is needed for stable feedback.

Figure 2-43.  The Mode group box.

Phase Controls

The Phase controls, shown in Figure 2-44, allow you to select the phase angle which gives

the optimal signal.  The Phase controls are only enabled when the Phase option button is

selected in the Mode group box.

Figure 2-44.  The Phase controls.

The Auto Phase button automatically sets the phase to a value that sets the Internal

Feedback signal level to a zero.  The +90 button allows you to shift the phase by +90°.

The Phase field displays the selected phase angle and allows you to alter the angle by

small increments.

Drive Attenuation

These settings are not displayed with systems equipped with I/O-MOD+, as I/O-MOD+

has a logarithmic amplifier that gives higher bit resolution at low voltages.

Figure 2-45.  The Drive Attenuation settings.

The Drive Attenuation settings, shown in Figure 2-45, allow two levels of attenuation of

the probe’s oscillation driving amplitude.  At a setting of 1, the +/-10V signal is not
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attenuated; at a setting of 10 it is attenuated to +/-1V; and at a setting of 100, the signal is

attenuated to +/-0.1V.

Amplitude Detection Procedure

This section describes the amplitude detection procedure for Non Contact mode

operation.  Refer to the operation manual for your instrument for details on the suggested

cantilever probes, initial settings, etc.

Initial Setup

1. Simultaneously rotate the two probe height thumbscrews clockwise at least one half-

rotation to ensure that the probe is elevated above the stage and sample surface.

2. If your system does not already have the Z scanner installed, install the appropriate

one in accordance with the procedure described in the instrument manual.

3. Mount an appropriate cantilever/probe assembly in the magnetic seat of the Z scanner

assembly.  (See the instrument manual for more information on non-contact probes.)

If you are not familiar with the cantilever/probe mounting procedure, refer to the

instrument manual.

4. Mount the sample.

5. Enter the Data Acquisition module (if necessary) by selecting Window⇒ Image

Acquire or by clicking on the  button on the tool bar.

6. Align the laser beam to the tip by following the Laser Alignment procedure described

in the instrument manual, making sure that the final mirror adjustment brings the

Internal Feedback signal to approximately 0 nA.

7. Select Setup⇒ Non Contact.

The Non Contact Control window appears.

8. Select the Non Contact Active option.

Note: The software will warn you if you do not have the Laser on High and the T-

B detector selected.

9. Click to select the Amplitude button in the Mode group box.

The system is set to the amplitude detection non-contact mode.
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10. Depending on the installed Z scanner, set the initial value in the Amplitude field to

the appropriate setting in accordance with the suggested settings in your instrument

manual.

11. Depending on the installed Z scanner, set the initial value in the Input Gain drop-

down list to the appropriate setting in accordance with the suggested settings in your

instrument manual.

12. Select the Range to cover the resonance frequency of your cantilever.  The resonance

frequency of a cantilever is listed on the top of the cantilever box.

Frequency Sweep

1. Click on the spectrum button.

The system sweeps the chosen frequency range, displaying the cantilever oscillation

amplitude.

The Spectrum is displayed as cantilever oscillation amplitude versus frequency, with

200 sampling points.  Because the normal FWHM (full width at half maximum) of a

resonance peak is typically about 500 Hz ~ 2 kHz, the full frequency sweep is only

used to locate the resonance.  The zoom function in the following step allows a

higher resolution display at the cantilever’s resonant frequency peak.

2. After the spectrum is displayed, click on the Zoom In button.

a. Identify the sharp, narrow peak within the resonant frequency range of your

cantilever.  This is your cantilever’s resonant frequency peak.

b. Position the cursor anywhere in the spectrum display, and click on the left mouse

button.

A vertical line marker is attached to the cursor.

c. Position the line marker to the immediate left of the resonant frequency peak,

and click the left mouse button.

The lower limit of the reduced frequency range is set.

d. Position the line marker to the immediate right of the peak, then click the left

mouse button again.

The upper limit of the reduced frequency range is set.  A range of approximately

5 kHz will be appropriate for the first zoom.
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e. Click on the right mouse button.

The zoom function is exited, and the system sweeps the newly-specified

frequency range.  You can zoom in again if necessary.  A frequency range of 2-3

kHz should be adequate for the final sweep range.

3. Adjust the value in the Amplitude field so that the free-oscillation amplitude

(displayed on the oscilloscope’s Internal Feedback signal) reads between -30 nA and

-50 nA.  You can also adjust the value in the Input Gain field to achieve this result.

Note: Do not set the Amplitude to a value that is greater than 0.5 V.  If an

Amplitude setting ≤ 0.5 V does not result in a signal more negative than -30

nA, then increase the value in the Input Gain field and click on the spectrum

button again.

Note: If the upper portion of the resonant frequency peak is truncated (cut off) or

split into two peaks, the oscillation signal is too large and is saturating the

detector.  If this is the case, lower the Input Gain voltage (or adjust the

Amplitude value), and click on the spectrum button again to run another

sweep.  Lowering the drive amplitude voltage decreases the cantilever

oscillation amplitude.  Repeat this step as necessary to bring the peak within

the spectrum’s maximum amplitude range.

Setting Drive Frequency and Adjusting the Set Point

1. Position the cursor anywhere in the frequency spectrum, and click on the left mouse

button.

A vertical line marker is attached to the cursor.

2. Select the drive frequency by positioning the marker at the top of the peak and

clicking the left mouse button again.  This sets the operating drive frequency.

3. Click the right mouse button to exit the function.

If necessary, you can reset the drive frequency by repeating these steps.

When you select the top of the peak, the Internal Feedback signal in the Oscilloscope

window will be at a minimum.

Note: If the sensor signal is too noisy at the peak, re-position the drive frequency

cursor just to the left or right of the peak in order to find a “cleaner” signal.

4. Adjust the value in the Set Point field to 50%.



Non Contact Operation 2-41

A value of 100% corresponds to the free-oscillation amplitude of the cantilever; a

value of 50% corresponds to a 50% damping of oscillation, etc.  The default value of

50% will be sufficient for establishing feedback under most normal conditions.

Feedback/Tip Approach

WARNING:

Do not use the  button/function (on the Acquisition Control

Panel) when performing computer-controlled non-contact operation, as this will

damage the probe tip.

1. Minimize the Non Contact Control window so you can easily access the rest of the

interface, but DO NOT close the window.

2. Ensure that the High button is selected in the Laser group box.

3. Ensure that the T-B button is selected in the Detector Signal group box.

4. Select Setup⇒ Acquire.  The Image Acquire Setup window opens.

a. Click to select the Topography and/or other desired channels in the Data

Channels group box.

b. Click Exit to close the window

5. Click on the Tip Approach button.

This will bring the tip into feedback at 50% of the registered amplitude of the

cantilever.

6. Once in feedback, select the Line Scan option on the Oscilloscope in order to adjust

the feedback parameters to optimize system performance.

The Internal Feedback signal should be stable and have low noise.  If not, move the

tip away from the sample surface by increasing the set point (e.g., a setting of 55%).

Or, move the tip closer to the sample surface by decreasing the set point (e.g., a

setting of 45%).

WARNING:

Decreasing the set point too much risks tip damage.

7. Click on the Instant Scan button  to initiate collection of a single image.
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You can also click on the Repeat Scan button , initiating a continuous scan mode.  This

will cause the scan to repeat after the last scan line in the scan area is reached, overwriting

the previous image.  Click on the button again to resume single-scan operation.

The Auto Save function may be invoked to save each successive scan.

Phase Detection Procedure

This section describes the phase detection procedure.  Refer to the operation manual for

your instrument for details on the suggested cantilever probes, initial settings, etc.

Initial Setup

1. Simultaneously rotate the two probe height thumbscrews clockwise at least one half-

rotation to ensure that the probe is elevated above the stage and sample surface.

2. If your system does not already have the Z scanner installed, install the appropriate

one in accordance with the procedure described in the instrument manual.

3. Mount an appropriate cantilever/probe assembly in the magnetic seat of the Z scanner

assembly.  (See the instrument manual for more information on non-contact probes).

If you are not familiar with the cantilever/probe mounting procedure, refer to the

instrument manual.

4. Mount the sample.

5. Enter the Data Acquisition module (if necessary) by selecting Window⇒ Image

Acquire or by clicking on the  button on the tool bar.

6. Align the laser beam to the tip by following the Laser Alignment procedure described

in the instrument manual, making sure that the final mirror adjustment brings the

Internal Feedback signal to approximately 0 nA.

7. Select Setup⇒ Non Contact.

The Non Contact Control window appears.

8. Select the Non Contact Active option.

Note: A warning will appear if you do not have the Laser on High and the T-B

detector is not selected.

9. Click on the Amplitude button in the Mode group box.
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The system is set to the amplitude detection non-contact mode.

Note: This portion of the procedure is more straightforward in the Amplitude

mode.  The procedure for selecting Phase mode appears later in this section.

10. Depending on the installed Z scanner, set the initial value in the Amplitude field to

the appropriate setting in accordance with the suggested settings in your instrument

manual.

11. Depending on the installed Z scanner, set the initial value in the Input Gain drop-

down list to the appropriate setting in accordance with the suggested settings in your

instrument manual.

12. Select the Range to cover the resonance frequency of your cantilever.  The resonance

frequency of a cantilever is listed on the top of the cantilever box.

Frequency Sweep

1. Click on the spectrum button.

The system sweeps the chosen frequency range, displaying the cantilever oscillation

amplitude.

In the specified range, the spectrum is displayed as probe oscillation amplitude

versus frequency, with a resolution of 200 sampling points at 2 kHz.  Because the

normal FWHM (full width at half maximum) of a resonance peak is typically about

30 Hz ~ 2 kHz, the full frequency sweep is only used to locate the resonance.  The

zoom function allows a higher resolution display at the probe’s resonant frequency

peak.

2. Click on the Zoom In button.

a. Identify the sharp, narrow peak within the resonant frequency range of your

cantilever.  This is your cantilever’s resonant frequency peak.

b. Position the cursor anywhere in the spectrum display, and click on the left mouse

button.

A vertical line marker is attached to the cursor.

c. Position the line marker to the immediate left of the resonant frequency peak,

and click the left mouse button.

The lower limit of the reduced frequency range is set.
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d. Position the line marker to the immediate right of the peak, then click the left

mouse button again.

The upper limit of the reduced frequency range is set.

e. Click on the right mouse button.

The zoom function is exited, and the system sweeps the newly specified frequency range.

You can perform this zoom function again if necessary.  A frequency range of 5 kHz

should be adequate for the final zoom.

Setting the Drive Frequency

1. Adjust the value in the Amplitude field so that the free-oscillation amplitude

(displayed on the oscilloscope’s Internal Feedback signal) reads between -30 nA and

-50 nA.  You can also adjust the value in the Input Gain field to achieve this result.

Note: Do not set the Amplitude to a value that is greater than 0.5 V.  If a drive

amplitude setting of ≤ 0.5 V does not result in a signal more negative than

-30 nA, increase the value in the Input Gain field, and click on the spectrum

button again.

Note: If the upper portion of the resonant frequency peak is truncated (cut off) or

split into two peaks, the oscillation signal is too large and is saturating the

detector.  If this is the case, lower the Input Gain voltage (or adjust the

Amplitude value), and click on the spectrum button again to run another

sweep.  Lowering the drive amplitude voltage decreases the cantilever

oscillation amplitude.  Repeat this step as necessary to bring the peak within

the optimum amplitude range.

2. Position the cursor anywhere in the frequency spectrum, and click on the left mouse

button.

A vertical line marker is attached to the cursor.

a. Select the drive frequency by positioning the marker at the top of the peak and

clicking the left mouse button again.

b. Click the right mouse button to set the drive frequency and exit the function.

If necessary, you can reset the drive frequency by repeating these two steps.

When you select the top of the peak, the Internal Feedback signal in the

Oscilloscope window will be at a minimum.
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Note: If the sensor signal is too noisy at the peak, re-position the drive

frequency cursor just to the left or right of the peak in order to find a

“cleaner” signal.

Setting the Phase

1. Click on the Phase button in the Mode group box.

2. Click on the Auto Phase button.

The system automatically selects the phase that produces an Internal Feedback signal

level of 0.

3. Click the +90 button to change the phase angle while you observe the signal levels of

the Internal Sensor Feedback trace on the oscilloscope.

4. If you click on the spectrum button to sweep the frequency range after each 90°
increment in the phase, you should see each of the waveforms shown in Figure 2-46.

Example 1

Example 3 Example 4

Example 2

Figure 2-46.  90°changes in phase angle.

5. Select the phase angle shift that produces the most negative Internal Feedback signal

level, as observed in the Oscilloscope window.  The Spectrum trace should resemble

the trace displayed in Example 2.
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Adjusting the Set Point

1. Place the cursor on the Internal Feedback trace in the Oscilloscope window, click the

left mouse button, and take note of the signal level (in nA) as the Internal Feedback

signal for reference in the following step.  (The signal level is displayed above the

trace.)

2. Adjust the Set Point field in the Acquisition Control Panel to a setting 25%-50%

more positive than the actual Internal Feedback signal recorded in the previous step,

e.g., if the signal is -6nA, adjust the set point value to ≈ -3nA.

Feedback/Tip Approach

WARNING:

Do not use the  button/function (on the Acquisition Control

panel) when performing the computer-controlled non-contact operation.  Using

Sensor Response in this mode will damage the probe tip.

1. Minimize the Non Contact Control window so you can easily access the rest of the

interface, but DO NOT close the window.

2. Ensure that the High button is selected in the Laser group box.

3. Ensure that the T-B button is selected in the Detector Signal group box.

4. Select Setup⇒ Acquire.  The Image Acquire Setup window opens.

a. Click to select the Topography mode in the Data Channels group box.

b. Click Exit to close the window

5. Click on the Tip Approach button.

6. Once in feedback, select the Line Scan option on the Oscilloscope in order to adjust

the feedback parameters to optimize system performance.

The Internal Feedback signal should be stable and have low noise, and the Z Piezo or

Topography trace should be repeatable.  If not, move the tip away from the sample

surface by decreasing the set point (more negative), or move the tip closer to the

sample surface by increasing the set point.

WARNING:

Decreasing the set point too much risks tip damage.
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7. Click on the Instant Scan button  to initiate the collection of a single image.

You can also click on the Repeat Scan button , initiating a continuous scan mode.

This will cause the scan to repeat after the last scan line in the scan area is reached,

overwriting the previous image.  Click on the button again to resume single-scan

operation.  The Auto Save function may be invoked to save each successive scan.

Phase Imaging

Phase imaging allows you to image the changes in phase produced by interaction between

the tip and sample in Non Contact AFM.

You can activate phase detection mode and change the 90° offsets of the signal to observe

different contrast levels in the phase image.  You must switch back to Amplitude mode

after changing the phase offset and before taking another phase image.

Additional Interface Features

Bi-Directional Scanning

One-directional or bi-directional Y scanning can be selected in the Scanning dialog box

when the repeat scan function ( ) is activated.  The Scanning dialog box, shown in

Figure 2-47, is opened by selecting Setup⇒ Scanning.

Figure 2-47.  The scanning dialog box.

With one-directional scanning, successive scans in the repeat scan mode will always

begin from the top of the scan range (i.e., top → bottom, top → bottom, top → bottom,

etc.).  One-directional scanning is the default mode.  With bi-directional scanning,

successive scans in the repeat scan mode will begin from the top or bottom of the scan

range, depending on the previous scan (i.e., top → bottom, bottom → top, top →
bottom, bottom → top, etc.).  See Figure 2-48.
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Figure 2-48.  Bi-directional & one-directional scanning.

This function operates the same whether forward or reverse scan channels are selected

and has no effect unless repeat scanning has been activated.

Probe Positioning

The Probe Position function allows precise positioning of the probe by pixel, by X,Y

location, or by voltage.  The Probe Position dialog box, shown in Figure 2-49, is opened

by selecting Commands⇒ Probe Position.  After performing a scan, the dialog box can be

used in conjunction with the scan window to define an exact point or a series of points on

the sample surface for use in various experiments, e.g., measuring current over time at

each location.  A series of coordinates can also be stored in a table and saved for use with

later experiments, targeting the exact same locations within different scans.  This function

is strictly for probe positioning.  This dialog box is used only to translate the probe to the

defined positions; no specific data collection function is accessed.

The probe can be positioned in one of two modes:  Interactive or Use List.  The

Interactive mode positions the cursor immediately, based on your placement of the cursor

in the scan area.  The Use List mode allows you to set up a series of positions, based on

pixel or X,Y coordinates.
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Figure 2-49.  The Probe Position dialog box.

Interactive Positioning

For immediate positioning:

1. Select the Interactive option.

2. Move the mouse into the scan area of the scan window.

The exact X,Y location of the cursor is displayed in the Cursor Location field.

3. Click the crosshair on the coordinates where you want the probe to be

positioned, as shown in Figure 2-50.

The probe will be automatically translated to that position over the scan area.

Clicking on a new position translates the probe again.
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Figure 2-50.  Interactive and Use List scanner positions.

List Positioning

To set up a series of coordinates with the list function:

1. Select the Use List option

2. Move the mouse into the scan area of the scan window

The exact X,Y location of the cursor is displayed in the Cursor Location field

3. Click the crosshair on each of the coordinates where you want the probe to be

positioned.

Each point will be marked on the scan window with an incremental number and

the corresponding coordinates will appear in the table in the dialog box.  See

Figure 2-50 and Figure 2-51.

New positions can also be added to the table by entering values in the X and Y

fields and clicking the Add button.

4. After defining the positions, click on the Move button to translate to each of the

specified positions.

Between each translation, the probe will pause for the amount of time defined in

the Delay field.

If you want to manually control the pause time between each position, enter any

negative number in the Delay field.  The probe will pause at each location, and
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the Move button will become the Continue button.  Click the Continue button

when you want to move to the next location.

Figure 2-51.  Use List locations table.

The Distance mode defines the coordinates in the measurement units of the scan range,

referenced from the lower-left corner of the scan range.

The Pixel mode defines the coordinates by data point, referenced from the upper-left

corner of the scan range.

After defining the coordinates, you can switch between the Distance and Pixel mode, and

the coordinates will be converted automatically.

To clear any or all sets of point coordinates:

1. Select the row to be deleted.

2. Click on the Clear button.
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To save a set of coordinates as a table:

1. Click on the Save button.  The Save Position Table dialog box, shown in Figure

2-52, opens.

Figure 2-52.  The Save Position Table dialog box.

2. Choose a directory and enter a filename for the table.  The file will have a .tbl

extension.

3. Click OK to return to the Probe Positioning dialog box.

To load previously saved probe position tables:

1. Click on the Load button.  The Open Position Table dialog box, shown in Figure

2-53, opens.

Figure 2-53.  The Open Position Table dialog box.
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2. Select the .tbl file you want to use.

3. Click OK to return to the Probe Positioning dialog box.  The table will be

displayed.

Voltage Positioning

To position the probe based on the X and Y piezo voltages:

1. Select the Volts mode.

The Voltage Location dialog box, shown in Figure 2-54, will be opened.  You

can change the piezo voltages within a set range.  In the case of a linearized

scanner, the value represents the voltage on the input of the closed-loop feedback

system.

Figure 2-54.  The Voltage Location dialog box.

2. Click the Move button to translate based on the new values.

When positioning the probe in the Volts mode, the List function is disabled, and

it is only possible to translate to one position at a time.

Video Controls

The Video dialog box, shown in Figure 2-55, is accessed by selecting Setup⇒ Video.

Figure 2-55.  The Video dialog box.
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The Video dialog box provides access to the on/off toggles for the video CCD camera and

for the sample illumination bulb.  The dialog box also allows you to control bulb

brightness.

Note: This option is only available on systems equipped with the I/O-12 board.

Z Motor Speed Control

The Z Motor dialog box, shown in Figure 2-56, allows you to control the speed of the Z

motor.  Select Commands⇒ XYZ to access this function.

Figure 2-56.  The Z Motor dialog box.

The voltage value in the Approach field controls the speed of the Z motor during the final

tip approach for scanning.  The voltage in the Standard field controls the speed of the Z

motor during Z movement of the SPM head.  Clicking on the Default button resets both

voltages to their default values.  The Z motor voltage settings defined with this function

remain active until the voltage is reset or until the system is reinitialized.

Clicking on either the  or  button in the dialog box actuates the Z motor at the

speed defined in the Standard field.

Beam Alignment

The Beam Align window provides a real-time display of the position of the laser spot on

the photodetector.  The window allows you to observe the position of the laser spot on the

photodetector during the alignment process.  The Beam Align window, shown in Figure

2-57, is opened by selecting Setup⇒ Beam Align…, or clicking the  button on the tool

bar.

The Contact and Non Contact option buttons allow you to use the Beam Align window

with both contact and non-contact tips.  Tip selection is important because the limits for

correct operation differ in Contact and Non Contact modes.

The OK button closes the Beam Align window after you have aligned the deflection

sensor.
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Figure 2-57.  The Beam Align window.

The SUM, TB and LR lines display values for the Sum, T-B, and L-R signal levels in the

photodetector.  A colored spot indicates the position of the laser spot on the

photodetector.  The color varies to indicate whether the detector is aligned properly or

not.  The diameter of the spot is proportional to the Sum signal.

The laser spot moves in the display as you adjust the laser position on the photodetector.

The laser spot also changes colors as the different signal levels change.  The laser spot

turns red if the Sum signal level is too small.  It turns yellow if T-B or L-R are not within

proper bounds.  Green indicates optimum settings.

The values in the SUM, T-B and L-R lines also vary as the detector alignment changes.

In contact mode, the Sum value should be more than 18 nA, the L-R value should be

between -5 and +5nA, and the T-B value should be between -55 and -30nA.

In non-contact mode, the Sum value should be more than 8 nA, the L-R value should be

between -5 and +5 nA, and the T-B value should be between -5 and +5 nA.

Note: These values are optimal when using ThermoMicrocopes cantilevers.  Optimal

values may vary when using third-party cantilevers.

You can observe the position of the laser spot in the Beam Align window during the

initial alignment, and you can monitor the values for Sum, T-B and L-R in the Beam

Align window during the final alignment.  Clicking the OK button closes the Beam Align

window.  Refer to the section of your instrument manual on beam alignment for more

information about adjusting the deflection sensor.
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Note: When using the I/O-10 interface with the Beam Align window, you will hear a

clicking sound.  This sound is normal and is caused by a relay in the 1010 Stage.



Chapter 3
AFM Scanner Calibration
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Overview

Measurement accuracy for ThermoMicroscopes scanners is verified and, if necessary,

recalibrated using the SPMLab software.  Calibration information is based on contact

scans of the ThermoMicroscopes calibration grid (or any calibration standard with a

known periodicity).  With SPMLab, scanner calibration is validated with the Verify

Calibration function.  X and Y, non-linearity, and crosstalk specifications are user-

defined, dependent on the specific applications of the SPM setup.  If you determine that

your scanner is out of calibration, the scanner file coefficients (which are specific to your

individual scanner) are recalculated and edited with the System File Edit function.  Two

methods of applying the System File Edit function are offered:  manual and computer-

controlled.  Both are described fully in this chapter.
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Verify Calibration

The Verify Calibration function checks the calibration of your scanner by comparing an

acquired image of a calibration standard against the known periodicity of the standard.

To perform the procedure successfully, you should be familiar with the basic contact

mode scanning method.

Verifying your scanner calibration involves three steps:

I. Scan a standard ThermoMicroscopes calibration grid to acquire a topographic

image.  An equivalent sample with a periodic structure that has known

dimensions can also be used.

II. Process the image with the calibration software, based on user-defined criteria.

After processing, new calibration, linearity, and crosstalk (orthogonality)

coefficients are computed.

III. Rescan the calibration standard using the new calibration coefficients, and

compare the data to the known feature size.  Then determine if the instrument

meets the calibration standards of your application.

Sample Preparation/Image Acquisition

1. Obtain a clean ThermoMicroscopes standard calibration sample or equivalent

standard with a known periodic pattern.

2. Translate the sample to locate an appropriate area of periodic structures.

3. Mount the sample on the SPM stage.  If necessary, straighten its orientation to

minimize pattern rotation in the acquired image.

4. In the Scan Range field of the Acquisition Control Panel, set the appropriate

scan range for the sample area to be measured.

The scan range divided by the pitch size should be greater than four

([Range/Pitch Size] > 4).

The optimum number of periodic structures within a scan range is 8-12.  E.g.,

when calibrating a 25 µm scan range, use a calibration standard with a 2 µm or 3

µm pitch.  See Figure 3-1.
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Figure 3-1.  Setting the scan range.

5. Set the Scan Rate to 4x your set scan range (in µm/s).  See Figure 3-2.

6. Set the Resolution to 500.  Lower image resolution settings can be used, but they

may result in less accurate boundary definition.  This will reduce calibration

accuracy.

7. Make sure that the laser is properly aligned on the scanning cantilever.  If you

are not familiar with this procedure, see the “Beam Alignment” section in your

instrument operation manual.

Figure 3-2.  Acquisition parameters for scanner calibration.
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8. Set the value in the Rotate field to 0 degrees.

9. Click on the Tip Approach button.

Once the tip is in feedback, click on the Scan button .  (Make sure that the Repeat Scan

button  is toggled off.)

If you are not familiar with the standard AFM contact scanning procedure, refer to the

“Contact Mode Scanning Procedure” in your instrument operation manual.

The sample is scanned and a topographic image is acquired.

Calibration and Linearization

Once feedback has been reached and an image acquired, you will enter the Verify

Calibration mode.

1. After the scan is complete, select Acquire⇒ Verify Calibration.

The Verify Calibration sub-panel is displayed on the Acquisition Control Panel,

as shown in Figure 3-3.

Note: Acquire⇒ Verify Calibration is only enabled when the image window

is active.

Figure 3-3.  The Verify Calibration sub-panel.

2. Select the By Threshold button in the Find Dots group box.

For most calibration verifications with standard calibration sample grids, you

will be using the By Threshold edge detection mode.  For a detailed description

of when to use the threshold mode and when to use the By Slope mode, see

“Edge Detection:  Slope vs. Threshold” on page 3-20.
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3. In the Z Level field, accept the default value (the approximate equivalent of 1/2

the maximum Z height (in nm) of the sample structures).

4. Click on one of the two threshold buttons, based on the following criteria:

-To highlight and use the data above the Z Level setting (when measuring

structures with a positive Z height, such as columns or mesas), click on the

 (Above Threshold) button.

-To highlight and use the data below the Z Level setting (when measuring

structures below the surface, such as holes or trenches), click on the 

(Below Threshold) button.

5. In the Size field, enter the pitch size (in µm) of the structures being used for

calibration.

The pitch size of the ThermoMicroscopes calibration samples can be found on

the standard calibration specification sheet that comes with the samples.  For

non-standard samples, pitch size must be known.

6. Click on the Survey button.

The acquired image, shown in Figure 3-4, is leveled, the structures are detected

using the threshold criterion, and the structures with a Z height above (or below)

the Z Level threshold are highlighted.

Figure 3-4.  Leveled calibration image with structures highlighted.
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If necessary, you can adjust the value in the Z Level field to help the system properly

detect the structures.

Image Editing

In order to get well-defined structures for the calibration, it may be necessary to use the

image editing tools.  The purpose is to obtain clear, uniform structures that can be

accurately measured.  These editing tools, listed below, are available from the drop-down

list containing the Draw tool.

Paint Line paints a missing line in the highlight color.

Paint Area paints an area in the highlight color.

Erase Line erases a line from the highlighted area.

Erase Area erases a defined area from the highlighted area.

Figure 3-5.  Calibration image with selected row highlighted.

1. Once the image has been cleaned up, use the following method to draw a

horizontal line along a row that contains at least four consecutive, well-defined

structures:
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a. With the Draw function selected from the drop-down list, click the left

mouse button and drag a line long enough to intersect at least four posts,

then release.

b. Move the cursor to position the line appropriately.

c. When you are satisfied with the line’s position, right-click to exit the

function.

The selected row is highlighted, as shown in Figure 3-5.

IMPORTANT: Avoid drawing the lines on partial structures, such as those

cropped by the boundary of the scan range.

2, In the same manner, draw a vertical line along a column that contains at least

four consecutive, well-defined structures.

The selected column is highlighted.

Note: Sometimes you may observe small areas that are highlighted outside of the

periodic structures.  These may be caused by debris on the sample.  Avoid

selecting a row or column that contains such artifacts, or use the image editing

tools to erase them.  If more than one row or column of structures is highlighted,

click on the Undo button.  Then, adjust the boundary thickness or use the image

editing tools to erase areas that should not be highlighted.

Verifying Calibration

1. In the Verify Calibration sub-panel, click on the Review button.

The Review Calibration Info. window appears, as shown in Figure 3-6.

The nominal pitch size (value entered in the Size field of the Verify Calibration

sub-panel), mean, maximum, and minimum pitch size are recorded for both the

X and Y directions.

2. Use the values to verify that your sample scan is within calibration tolerances for

your applications.  If not, you may need to recalibrate your system using the

System File Edit function, described in the following section.

WARNING:

Do not scan ( ) if Cross-Talk is greater than +/-10° or Non-Linearity (%) is

greater than 10.  Severe tip damage could result.
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Figure 3-6.  The Review Calibration Info. window.

System File Edit

The System File Edit function recalibrates your scanner by editing the scanner Sys files.

Recalibration of your scanner with System File Edit is indicated when topographic

measurements of a standard calibration grid are inaccurate (e.g., known pitch size = 9 µm,

but measured pitch size = 8µm), and/or crosstalk or linearity are out of specification for

your application.  The terms “Sys file,” “system file,” and “scanner file” are used

interchangeably in the context of this document.

There are two methods of recalibrating the scanner:

1. Manual recalibration is accomplished through direct editing of the scanner

system file to reset the X and Y piezo voltages based on actual vs. measured

values.  Manual recalibration is the shorter method, preferable when the scanner

is only slightly out of calibration and linearity and crosstalk coefficients are

within specification for your applications.
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The full procedure is described in “Manual System File Edit,” below.

2. Computer-controlled recalibration is accomplished by acquiring and editing an

image of a standard calibration grid based on user-defined edge-detection

criteria, calibrating and linearizing the system based on the measured non-

linearity and crosstalk coefficients, and saving the new coefficients to a new

version of the Sys file.  Computer-controlled recalibration is preferable when the

scanner measurements are out of calibration, and linearity and crosstalk

coefficients are also out of specification for your applications.

The full procedure is described in “Computer-Controlled System File Edit,” on

page 3-13.

Manual System File Edit

Manual recalibration of your scanner is indicated when topographic measurements of the

standard calibration grid are inaccurate (e.g., known pitch size = 9 µm, but measured

pitch size = 8µm), but crosstalk and linearity are within specifications for your

applications.

Recalibration through manual system file editing involves five steps:

1. Obtain a scan of the calibration grid.

2. Use one of the image analysis measurement tools to measure the periodic

structures of the image.

3. Compare the known structure pitch size to the measured structure pitch size.

4. Calculate the change in X and Y piezo voltages needed to correct the error.

5. Manually edit the system file to change the X and Y voltages.

Sample Preparation/Image Acquisition

1. Obtain a clean ThermoMicroscopes standard calibration sample (Si test grid) or

equivalent with a known periodic pattern.

2. Translate the sample to locate an appropriate area of periodic structures.

3. In the Scan Range field of the Acquisition Control Panel, set the appropriate

scan range for the sample area to be measured.
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The optimum number of periodic structures within a scan range is 8-12 (e.g.,

when calibrating a 25 µm scan range, use a calibration standard with a 2 µm or 3

µm pitch).

4. Make sure that the laser is properly aligned on the scanning cantilever.  If you

are not familiar with this procedure, see “Beam Alignment” in your instrument

operation manual.

5. Click on the Tip Approach button.

6. Once the tip is in feedback, click on the Scan button .

If you are not familiar with the standard contact scanning method, refer to

“Contact Mode Scanning Procedure” in your instrument operation manual.

The sample is scanned, and the topographic image is acquired.

Calibration

1. Measure the calibration grid, using the image analysis tools (e.g., Line Analysis).

2. Select Acquire⇒ SYS File Edit.

The Scan Calibration sub-panel will be displayed, as shown in Figure 3-7.

Figure 3-7.  The Scan Calibration sub-panel.

3. Make sure that the System option button is selected in the Apply Calibration

group box and that your current system file (with the .SYS extension) is selected

from the Sys file drop-down list.

4. Click on the Review Files button.
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The System File Editing dialog box opens, as shown in Figure 3-8.

Figure 3-8.  The System File Editing dialog box.

5. Select the line in the file that corresponds to the scan range you selected (e.g., for

a 50 µm scan range, select the line that begins with “Range 2=50.000000

µm…”)

6. Calculate Vnew for both X and Y as follows:






=

Distance Known

Distance Measured
VV OldNew

VOld is the current value in the X Voltage or Y Voltage field in the Scan

Range group box.  VNew is the corrected voltage.
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7. In the Scan Range group box of the System File Editing dialog box, enter the

calculated value of VNew for the X direction in the X Voltage field.

8. Enter the calculated value of VNew for the Y direction in the Y Voltage field.

IMPORTANT:  Do not change any other fields in the System File Editing dialog

box.

9. Click on the OK button to accept the changes and exit the dialog box.

10. Select Setup⇒ Scanner Select and reselect the newly edited scanner Sys file to

activate the changes.

Computer-Controlled System File Edit

Computer-controlled recalibration of your scanner is indicated when topographic

measurements, crosstalk, and linearity do not meet specifications for your applications.

Calibrating your scanner using the Sys File Edit function involves three basic steps:

1. A standard ThermoMicroscopes calibration sample grid is scanned and a

topographic image is acquired.  (An equivalent sample with a periodic structure

that has known dimensions can also be used.)

2. The image is examined by the software, based on user-defined criteria.  After

examination, new calibration, linearity, and crosstalk coefficients are computed.

3. After achieving acceptable results, the new calibration coefficients are saved to

the scanner (.SYS) file.  The existing Sys file is backed up automatically with the

.SBK file extension.

Sample Preparation/Image Acquisition

1. Obtain a clean ThermoMicroscopes standard calibration sample (Si test grid) or

equivalent with a known periodic pattern.

2. Mount the sample on the SPM stage.  Straighten its orientation to minimize the

rotation in the acquired image.

3. Translate the sample to locate an appropriate area of periodic structures.

4. Set the appropriate scan range for the sample area to be measured in the Scan

Range field of the Acquisition Control Panel.

The scan range divided by the pitch size should be greater than four

([Range/Pitch Size] > 4).
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The optimum number of periodic structures within a scan range is 8-12.  E.g., when

calibrating a 25 µm scan range, use a calibration standard with a 2 µm or 3 µm pitch.  See

Figure 3-9.

Figure 3-9.  Setting the scan range.

5. Set the Scan Rate to 4x your set scan range (in µm/s).  See Figure 3-10.

6. Set the Resolution to 500.

Lower image resolution settings can be applied, but they may result in poor

boundary definition, reducing calibration accuracy.

Figure 3-10.  Acquisition parameters for scanner calibration.
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7. Set the value in the Rotate field to 0 degrees.

8. Make sure that the laser is properly aligned on the scanning cantilever.  If you

are not familiar with this procedure, see “Beam Alignment” in your instrument

operation manual.

9. Click on the Tip Approach button.

Once the tip is in feedback, click on the Scan button .  (Make sure that the

Repeat Scan button  is toggled off.)

If you are not familiar with the standard contact scanning method, refer to

“Contact Mode Scanning Procedure” in your instrument operation manual.

The sample is scanned and an image is acquired.  Once the image has been

acquired, you will enter the SysFile Edit mode.

Calibration and Linearization

1. After the scan is complete, select Acquire⇒ SYS File Edit (this menu option is

only enabled when the image window is active).  The Scan Calibration sub-panel

will be displayed, as shown in Figure 3-11.

Figure 3-11.  The Verify Calibration sub-panel.

2. Select the By Threshold button in the Find Dots group box.

For most Sys File Edit recalibration operations with standard calibration sample

grids, you will be using the By Threshold edge detection mode.  For a detailed

description of when to use the threshold mode and when to use the By Slope

mode, see “Edge Detection:  Slope vs. Threshold” on page 3-20.
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3. In the Z Level field, accept the default value (the approximate equivalent of 1/2

the maximum Z height (in nm) of the sample structures).

4. Click on one of the two threshold buttons, based on the following criteria:

-To highlight and use the data above the Z Level setting (when measuring

structures with a positive Z height, such as columns, posts, or mesas), click

on the  (Above Threshold) button.

-To highlight and use the data below the Z Level setting (when measuring

structures below the surface, such as holes or trenches), click on the 

(Below Threshold) button.

5. In the Size field, enter the pitch size (in µm) of the structures being used for

calibration.

The pitch size of the ThermoMicroscopes calibration samples can be found on

the standard calibration specification sheet that comes with the samples.  For

non-standard samples, pitch size must be known.

Figure 3-12.  Leveled calibration image with structures highlighted.

6. Make sure that the System button in the Apply Calibration group box is toggled

on.

For more information on the Apply Calibration function see “Apply Calibration”

on page 3-20.
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7. Click on the Survey button.

The acquired image is leveled, and the structures are detected using the threshold

criterion.  Structures with a Z height above (or below) the Z Level threshold are

highlighted, as shown in Figure 3-12.

If necessary, adjust the value in the Z Level field to help the system properly

detect the structures.

Image Editing

In order to get well-defined structures for the calibration, it may be necessary to use the

image editing tools.  The purpose is to obtain clear, uniform structures that can be

accurately measured.  These editing tools, listed below, are available from the drop-down

list containing the Draw tool.

Paint Line paints a missing line in the highlight color.

Paint Area paints an area in the highlight color.

Erase Line erases a line from the highlighted area.

Erase Area erases a defined area from the highlighted area.

1. Once the image has been cleaned up, use the following method to draw a

horizontal line along a row that contains at least four consecutive, well-defined

structures:

a. With the Draw function selected from the drop-down list, click the left

mouse button and drag a line long enough to intersect at least four posts,

then release.

b. Move the cursor to position the line appropriately.

c. When you are satisfied with the line’s position, right-click to exit the

function.

The selected row is highlighted, as shown in Figure 3-13.

IMPORTANT: Avoid drawing the lines on partial structures, such as those

cropped by the boundary of the scan range.
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Figure 3-13.  Calibration image with selected row highlighted.

All the tools follow the convention of left-click, drag, and release to define the

line/area.  Move the cursor to position the line/area.  Right-click to apply the

function and exit the command.

2. In the same manner, draw a vertical line along a column that contains as many

consecutive, well-defined structures as possible (at least four).

The selected column is highlighted.

Note: Sometimes you may observe small areas that are highlighted outside of

the periodic structures.  These may be caused by debris on the sample.

Avoid selecting a row or column that contains such artifacts, or you can

use the image editing tools to erase them.  If more than one row or

column of structures is highlighted, click on the Undo button.  Then,

adjust the Z Level, or use the image editing tools to erase areas that

should not be highlighted.

Once one row and one column have been successfully highlighted, the linearity

coefficients, crosstalk coefficients (orthogonality between X and Y), and scan

range are computed.  The nonlinearity percentage and the angle between X and

Y (crosstalk) are reported, as shown in Figure 3-14.

Figure 3-14.  Nonlinearity percentage and angle between X and Y (crosstalk).
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3. If the value in the Cross Talk field is greater than +/-10°, or the value in the Non

Linearity (%) field is greater than 10 (X or Y values), click on the Undo button

and repeat steps 1 and 2.

Errors this great cannot be corrected by the software and indicate an erroneous

measurement, severe drift, or a damaged scanner.  In the case of an erroneous

measurement, visually inspect the sample and determine if a new, cleaner area of

the sample should be scanned.

WARNING:

Do not scan ( ) if Cross Talk is greater than +/-1° or Non Linearity (%) is

greater than 10.  Tip damage could result.

4. Click the Scan button  at this point to test the results by applying the new

calibration coefficients to another scan to observe the measurements in the

acquired image.

5. When the scan is complete, inspect the image to confirm that calibration and

linearity are correct.

For example, a new 75µm scan of five structures, each with a known pitch of 15

µm, should display the equivalent of the pitch of exactly five full structures, as

shown in Figure 3-15.

Figure 3-15.  Confirming calibration and linearity.

Note: At this point you can also run the Verify Calibration procedure to check

your data.  See “Verify Calibration” on page 3-3.

Saving New Coefficients

When you are satisfied, save the new calibration coefficients to the system file by clicking

on the Save button.
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The Save function writes the calibration parameters to the system file on your hard disk

(i.e., in the c:\spmlab.306\scanners directory), under the same name as the file that

shipped with your system.  In case you need to revert back to the previous system file

data, the existing system file (prior to applying the Sys File Edit function) is stored in a

back-up file with the .SBK extension.  Also, the original calibration Sys file for each

scanner is stored on the floppy disk that shipped with the system.

User Settings

Apply Calibration

The Current button in the Apply Calibration group box (see Figure 3-16) applies the

current scan’s calibration coefficients and crosstalk to the next scan.

The System button applies the system file calibration coefficients and crosstalk to the

scan.

The Off button disables any calibration coefficients from being applied to the scan.

Figure 3-16.  The Apply Calibration group box.

The first scan will always be based on the system file calibration coefficients (System) or

on no pre-existing coefficients (Off).  The Current setting is disabled until at least one

scan has been performed to create a new set of calibration coefficients.

This set of options allows you to apply known calibration variables to successive scans.

For example, if a scan shows that the nonlinearity and crosstalk variables are not yet

within acceptable limits, you can apply the calibration variables of the scan you just

performed (Current), or you can apply the original Sys file variables (System) to the next

scan.  You can continue this process on each subsequent scan, applying the current or

system variables until the nonlinearity and crosstalk are within acceptable limits for your

applications.  As long as the errors continue to improve as you apply the current

coefficients, you will continue to base the calibration on successively improving data.

Edge Detection:  Slope vs. Threshold

The acquired image is examined by the system in order to detect and analyze the

structures (grid pattern) based on the edge-detection criteria you define.  These criteria

are set within one of two options:  slope or threshold, selected with the By Slope and By

Threshold buttons in the Find Dots group box.  Selecting either of the two buttons

displays a sub-panel with controls specific to that mode.
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Slope is the recommended detection method when the sample has very clear, well-defined

edges.  Also, this is the best method when the sample is not flat or cannot be leveled well.

Threshold is the recommended method when the standard sample has well-defined height

transitions along the feature edges.

By Slope detects the edges of the structures by calculating the slope and slope width.

Any slope that is narrower in width than the value in the Boundary Thickness field (see

Figure 3-17) is defined as an edge.

Figure 3-17.  Edge detection by slope.

The accuracy of the calibration process is dependent on the definition of the structures

that are detected in this step.  Structures that are well-defined and have clean, closed

boundaries will result in a more accurate calibration.

With the slope method, only the boundaries of the detected structures are highlighted.

(The highlight color is chosen in the Color Settings dialog box, accessed by selecting

Setup⇒ Screen Colors.)

The value in the Boundary Thickness field sets the thickness of the boundary lines drawn

around the structures.  The smaller the number, the thinner the boundary; the greater the

number, the thicker the boundary.  Adjust the value in the field until you get a closed

boundary around the feature.  The goal is to get as many adjacent and well-defined

periodic structures as possible, in both the horizontal and vertical directions.

By Threshold detects the structures by setting a Z threshold and analyzing structures

above or below this horizontal threshold.  See Figure 3-18.

Figure 3-18.  Edge detection by threshold.
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The Z Level field defines the location of the horizontal threshold.  Click on the Above

Threshold button  to highlight and consider the data above the selected Z level in the

calibration.  Click on the Below Threshold button  to highlight and consider the data

below the selected Z level in the calibration.  The Above Threshold option is typically

used for structures with a positive Z height (columns or mesas).  The Below Threshold

option is typically used for depressed structures (holes or trenches).

Review Files

You can review the current parameters in the system file by clicking on the Review Files

button to open the System File Editing dialog box, as shown in Figure 3-19.

Figure 3-19.  The System File Editing dialog box.
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Highlighting any line that can be edited causes the corresponding field(s) in the dialog

box to become active.  Parameter values can be edited within a predefined limit range.

Values outside of the these limits cannot be entered.

Three files are available for review and/or editing from the Review Files drop-down list:

the current Sys file, the back-up (.SBK) file, and the Current Parameters file.

Back-up and current parameters files can only be reviewed; there are no editing

capabilities with these options.

Note: Values in the Crosstalk field must be entered as the calculated tangent of the

actual crosstalk value you are editing.





Chapter 4
Image Processing/Analysis Menu and Tool Bar
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Overview

When you initially power up SPMLab, the software enters the Image Analysis module.

The Image Analysis software processes files created with SPMLab software (down to

version 3.05), files provided by AutoProbe ProScan software (with the extension .hdf),

and other binary files (see “Importing Files” on page 5-8).  Image Analysis processes in

any of three lower level modes:  Display, Processing, and Analysis.  In the Display mode,

functions such as background subtraction, contrast and brightness, 3D display, and palette

editing are controlled.  Visualization of the image is enhanced without affecting the data.

In the Processing mode, image, curvature, leveling, convolutions, arithmetic processing,

filtering, etc. are all handled.  In the Analysis module, the image is analyzed with various

statistical and measurement routines, such as line profile, peak and valley analysis,

particle and grain analysis, and step measurement.

This chapter provides a summary description of all the functions on the Image Analysis

menu and tool bar, as shown in Figure 4-1.  The more advanced functions of the Image

Analysis module are described fully in Chapter 5.

Figure 4-1.  Image Analysis module main screen.
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Image Analysis Menu Items

The Image Analysis menus and tool bar are shown in Figure 4-2.  Note that the menu

options and tool bar buttons displayed depend on the options you are using.  This manual

describes the menu options and tool bar buttons that are standard to all systems.  When

you order an option, such as Grain and Particle Analysis, the accompanying

documentation describes the menu options and icons specific to that option.

Buffers

Select...

Next

Previous

Duplicate

Delete

File Manager...

Save as...
Export...
Import... 

Exit

File Edit

Screen Edit ... Ctrl+P

Data Edit...

Normalize Z

Ctrl+O

Ctrl+S
Ctrl+E 
Ctrl+I

Ctrl+X

Contrast & Brightness...
Palettes...
Palette Editor...
2D Color Editor
2D Color

Shading...
Histogram...
Equalization...
Color Mapping...

3D Graphic...
Scale 1:1

Zero Set...
Zero Set Off
Scale XY...
Common Color Bar...

Display

Levelling...
Background...
System Background...
Convolution...
Filter...
Arithmetic...
Scale & Zoom...
Rotation...

1D FFT...
2D FFT...

Calibration

Process Analysis
Line Measure...
Peak / Valley Measure...

Line Analysis...

Area Analysis

Particle Analysis...

Grain Analysis...

Critical Dimension...

Setup

Scan Parameters...

Screen Colors...

Preferences...

Window

Image Acquire...

Next...

Previous...

Duplicate...

Tile...

Cascade...

Figure 4-2.  Image Analysis menus and tool bar.

Some of the icons on the tool bar provide single-click access to the more commonly used

menu options and are indicated beside their associated menu items.  This section gives a

brief description of each menu item.  The icons are described in the section that follows,

“Image Analysis Tool Bar.”
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The File Menu

The File menu, shown in Figure 4-3, allows you to access the File Manager as well as

save, export and import images.  The File menu items are described briefly in Table 4-1.

File Manager...

Save as...
Export...
Import... 

Exit

File
Ctrl+O

Ctrl+S
Ctrl+E 
Ctrl+I

Ctrl+X

Figure 4-3.  The File menu.

Table 4-1.  The File menu items.

Menu Item Function

File Manager… Opens the File Manager dialog box, which displays all files which

have the SPMLab and AutoProbe ProScan (.hdf) file formats.

Standard file management tools are accessible, such as Delete,

Copy, Browse, etc.  This function can also be accessed by clicking

on the  button on the tool bar.  For a full description of this

function, see “File Manager” in Chapter 5.

Save As… Opens the Save As dialog box, allowing you to save the currently

selected image in the SPMLab format.  This function can also be

accessed by clicking on the  button on the tool bar.  For details

on saving the image buffers, see “Save All Image Buffers” on page

2-22.

IMPORTANT:  After applying any display functions to a scan

image, it is strongly recommended that you save the processed

image under a new file name.  This ensures that a copy of the

original scan data will always be available, unchanged by any

process or display functions.

Export… Opens the Export dialog box, which saves the selected data in the

ASCII text format (.txt), for use with other applications.  The feature

allows you to export graphs, scan images, oscilloscope displays, etc.

This function is not available for all data.
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Menu Item Function

Import… Opens the Import Data dialog box, which allows you to import

DBOSS SPM files and other binary files for processing in the Image

Analysis module.  Files can also be converted to the standard

SPMLab data file format.  For  more information on this function,

see “Importing Files” on page 5-8.

Exit Exits SPMLab, after prompting you to save any unsaved data.

The Edit Menu

The Edit menu, shown in Figure 4-4, provides access to the editing tools, which are

described briefly in Table 4-2.

Edit

Screen Edit ... Ctrl+P

Data Edit...

Normalize Z

Figure 4-4.  The Edit menu.

Table 4-2.  The Edit menu items.

Menu Item Function

Screen Edit… Opens the Screen Editor module, which enables annotations,

moving of text and images on the screen, printing, and saving the

screen or portions of the screen to various output file formats for

presentations, export to other image processing packages, etc.  For a

full description of the Screen Editor module software functions, see

Chapter 6, “Screen Editor.”

Data Edit… Opens the Data Edit tool bar, which provides four tools for basic

data (image) editing:  area editing, line removal, glitch removal, and

step removal.  For a full description of this function, see “Image

Editing” in Chapter 5.

Normalize Z Stretches the image Z data to half of the full Z data range

(655530/2).  If smoothing is applied, all data will be interpolated

between the available data points.
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The Buffers Menu

When processing any image in the Image Analysis module, each successive version of the

image is stored in the buffer array (to a maximum of six).  The Buffers menu, shown in

Figure 4-5, provides access to functions that allow access to the images in the array, as

well as the ability to duplicate and delete the images.  The Buffers menu items are

described briefly in Table 4-3.  For a full description of all buffer functions, see “Buffers”

in Chapter 5.

Buffers

Select...

Next

Previous

Duplicate

Delete

Figure 4-5.  The Buffers menu.

Table 4-3.  The Buffers menu items.

Menu Item Function

Select… Opens the Image Buffers dialog box, which simultaneously displays

all images currently in the buffer array.  From this dialog box, any

image can be imported to a new window, saved, deleted, or

duplicated.

Next Selects the next image in the buffer array.  This function is disabled

if there are no more images in the array sequence.  This function can

also be accessed by clicking on the  button on the tool bar.

Previous Selects the previous image in the buffer array.  This function is

disabled if there are no previous images in the array sequence.  This

function can also be accessed by clicking on the  button on the

tool bar.

Duplicate Duplicates the currently selected image and adds the duplicate to the

buffer array.  This function can also be accessed with the Image

Buffers dialog box by selecting Buffers⇒ Select.

Delete Deletes the currently selected image.  This function can also be

accessed with the Image Buffers dialog box by selecting

Buffers⇒ Select.
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The Display Menu

The Display menu, shown in Figure 4-6, provides access to the Image Analysis functions

that allow you to determine how your image will look, including contrast and brightness

functions, color palettes, color distribution, 3D positioning, etc.  The Display menu items

are described briefly in Table 4-4.  For a full description of all the Display functions, see

“Image Display” in Chapter 5.

Contrast & Brightness...
Palettes...
Palette Editor...
2D Color Editor
2D Color

Shading...
Histogram...
Equalization...
Color Mapping...

3D Graphic...
Scale 1:1

Zero Set...
Zero Set Off
Scale XY...
Common Color Bar...

Display

Figure 4-6.  The Display menu.

Table 4-4.  The Display menu items.

Menu Item Function

Contrast &

Brightness…

Opens the Contrast & Brightness dialog box, which provides real-

time, 0-100% contrast and brightness slider controls for the selected

image.  For a full description of this function, see “Contrast &

Brightness” in Chapter 5.

Palettes… Opens the Palettes dialog box, which provides access to the color

palettes library.  Any palette’s effect on an image can be viewed

before accepting.  This function can also be accessed by clicking on

the  button on the tool bar.  For a full description of this

function, see “Palettes and Palette Editing” in Chapter 5.



4-8 Image Processing:  Analysis Menus & Tool Bar

Menu Item Function

Palette Editor Opens the Palette Editor dialog box, which allows real-time editing

of the RGB values of the selected color palette’s histogram.  For a

full description of this function, see “Palette Editing” in Chapter 5.

2D Color Editor Opens the 2D Color Mapping dialog box, which allows color

distribution and/or sharpness editing for the Pseudo 2D and True 2D

modes.  Using the dialog box in the Pseudo Color mode allows

editing of sharpness, as well as height vs. slope color distribution for

the image, to be applied when Pseudo 2D is selected (8-bit

graphics/256 color mode).  Using the dialog box in the True Color

mode allows editing of the image's sharpness value, to be applied

when True is selected (16- or 24-bit graphics mode).

Note:  If your system is configured for an 8-bit graphics card, the 2D

Color Mapping dialog box will only function in the Pseudo Color

mode.

For a full description of this function, see “2D Color Editor” and

“True 2D Color” in Chapter 5.

2D Color Allows you to choose Pseudo 2D and True 2D.  Pseudo 2D applies

the height vs. slope, sharpness, and color distribution settings

selected in the 2D Color Mapping dialog box.  This option is

available for 8-, 16-, or 24-bit color graphics configurations.  True

2D applies the sharpness setting selected in the 2D Color Mapping

dialog box.  This option is only available in 16- or 24-bit color

graphics configurations.

Note:  The Pseudo 2D and True 2D color menu options will be

disabled until your image has had shading applied.  The True 2D

menu option will be disabled unless your graphics configuration is

set to either the 16- or 24-bit color mode.

For a full description of these functions, see “Pseudo 2D Color” and

“True 2D Color” in Chapter 5.
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Menu Item Function

Shading… Opens the Shading dialog box, which enables you to shade the

image based on a simulated light source.  The dialog box allows the

automatic positioning of a left or right light source, or user-defined

vector positioning of the light source.  The automatic left/right light-

source shading can also be accessed by clicking on the  or 

buttons on the tool bar, respectively.  For a full description of this

function, see “Shading” in Chapter 5.

Histogram… Opens the Histogram dialog box, which displays the data histogram

for the selected image and enables you to edit the image’s color

histogram.  You can apply the edited histogram to the whole image

or a portion of the image.  This function can also be accessed by

clicking on the  button on the tool bar. For a full description of

this function, see “Data Histogram:  Color Distribution” in

Chapter 5.

Equalization… Redistributes the data histogram across the color palette so that an

equal amount of data is applied to each color.

Color Mapping… Opens the Color Mapping dialog box, which enables you to edit the

RGB distribution of the color palette applied to the currently

selected image.  The edited color palette can then be applied

immediately and/or saved to the palette library, which is accessed by

selecting Display⇒ Palettes.  For a full description of this function,

see “Color Mapping” in Chapter 5.

3D Graphic… Opens the Graphic dialog box, which allows 3D user-defined

positioning of the image display-angle.  This function can also be

accessed by clicking on the  button on the tool bar.  For a full

description of this function, see “Graphic/3D Image Manipulation”

in Chapter 5.

Scale 1:1 Reverts a scaled (up or down) top-view image to a 1:1 ratio, where

one pixel is equal to one data point.

Zero Set… Opens the Zero Set dialog box, which enables you to define a zero

set point for the image’s Z data.  You can then use two different

color palettes to display the data above and below the zero set point.

For a full description of this function, see “Zero Set” in Chapter 5.
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Menu Item Function

Zero Set Off Cancels the zero set point and dual palettes selected with the Zero

Set function, reverting the image to its original settings.  For a full

description of this function, see “Zero Set” in Chapter 5.

Scale XY… Opens the XY Scale dialog box, which enables you to change the

image’s X,Y scale setting and measurement unit.  Generally, this

function is used to round the scale values.

Note:  No mathematical conversion takes place when changing the

image’s X,Y scale or measurement unit, i.e., for a 12 µm x 12 µm

image, changing the measurement unit to Å will result in an image

that incorrectly lists the X,Y dimensions as 12 Å x 12 Å.  You must

perform the calculation manually to determine the new X,Y scale

based on the new unit, then change XY Scale value accordingly.

Common Color

Bar

Opens the Common Color Bar dialog box, which provides two

methods of applying common parameters to different images:

-The Common Color Bar dialog box provides the ability to

compare up to six similar images by applying a common Z

range to all of them.

-The Advanced Common Color Bar dialog box provides a

histogram of each image currently open.  Offset, Z max,

and Z min can then be set individually for each histogram,

and a common range setting can be applied.  For a full

description of this function, see “Common Color Bar” in

Chapter 5.
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The Process Menu

The Process menu, shown in Figure 4-7, provides access to functions that fall into the

category of operations that affect the presentation and interpretation of your data.  Image

tilt, filtering, zooming, shading, etc. are all Process operations.  The Process menu items

are described briefly in Table 4-5.  For a full description of all the Process functions, see

“Image Processing” in Chapter 5.

Levelling...
Background...
System Background...
Convolution...
Filter...
Arithmetic...
Scale & Zoom...
Rotation...

1D FFT...
2D FFT...

Calibration

Process

Figure 4-7.  The Process menu.

Table 4-5.  The Process menu items.

Menu Item Function

Leveling… Opens the Leveling dialog box, which offers a variety of automatic

and advanced leveling routines, designed to remove curvature

and/or tilt from an image.  First-order 2D (plane subtract) leveling

can be performed automatically by clicking on the  button on the

tool bar.  For a full description of this function, see “Leveling” in

Chapter 5.

Background… Opens the Background dialog box, enabling you to perform

background subtraction on an image.  Background subtraction is a

user-defined rolling-ball and rolling-arc filtering process used to

eliminate an image’s background features, preserving the surface

features for analysis.  For a full description of this function, see

“Background Subtraction” in Chapter 5.
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Menu Item Function

System

Background…

Opens the System Background Subtraction dialog box, which is

used to calculate and eliminate anomalous instrument/scanner

curvature (also called “bow”) from image data.  This allows surface

feature analysis, assuming a totally flat-bottomed sample.  For a full

description of this function, see “System Background” in Chapter 5.

Convolution… Opens the Convolution dialog box, enabling you to apply a pixel-by-

pixel filtering function to the image, from a standard kernel, a user-

defined kernel, or a kernel library.  (A kernel is a matrix of numbers

used to modify the pixel from its center.)  For a full description of

this function, see “Convolution” in Chapter 5.

Filter… Opens the Filter dialog box, which enables you to filter the Z data in

an image.  The filtering function is set to smooth low-, median-, or

high-frequency features, based on user-defined matrix size and Z

frequency settings.  For a full description of this function, see

“Filter” in Chapter 5.

Arithmetic… Opens the Arithmetic dialog box, which enables you to add,

subtract, multiply, or divide two images; or a scaled percentage of

the first image with the second image.  For a full description of this

function, see “Arithmetic” in Chapter 5.

Scale & Zoom… Opens the Scale & Zoom dialog box, which enables you to choose

from a range of pixel resolutions, scaling the image up or down.  For

a full description of this function, see “Scale & Zoom” in Chapter 5.

Rotation… Opens the Rotation dialog box, which enables you to apply a fixed

or user-defined rotation to the image.  For a full description of this

function, see “Rotation” in Chapter 5.

1D FFT… Opens the 1D FFT dialog box, which displays the currently selected

image’s power spectrum and enables you to filter the image in either

the X, Y, or X and Y directions.  For a full description of this

function, see “Single-Axis Fast Fourier Transform” in Chapter 5.
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Menu Item Function

2D FFT… Opens the 2D FFT dialog box, which displays the currently selected

image’s power spectrum in two dimensions and enables you to

configure the filtering with a set of Spectrum editing tools.  This

function can also be accessed by clicking on the  button on the

tool bar.  For a full description of this function, see “Two-

Dimensional Fast Fourier Transform” in Chapter 5.

Calibration Provides access to the Make Coefficients and Load Coefficients

options.

Make Coefficients allows you to automatically calculate the

coefficients related to scanners (calibration, linearity, etc.)

based on a stored image (normally a standard calibration

grid image).

Load Coefficients allows you to use the coefficients calculated

with the Make Coefficients function and apply them to an

arbitrary image, provided both images are scanned under

the same conditions.

The Analysis Menu

The Analysis menu, shown in Figure 4-8, provides access to the system's array of analysis

functions, allowing detailed quantitative examination of the image in a variety of modes.

The Analysis menu items are described briefly in Table 4-6.  For a full description of all

the Analysis functions, see “Image Analysis” in Chapter 5.

Analysis
Line Measure...
Peak / Valley Measure...

Line Analysis...

Area Analysis

Particle Analysis...

Grain Analysis...

Critical Dimension...

Figure 4-8.  The Analysis menu.
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Table 4-6.  The Analysis menu items.

Menu Item Function

Line Measure… Opens the Line Measurement dialog box, which enables you to

select and compare three line profiles (horizontal, vertical, and/or

variable) from the selected image.  The generated data includes

XYZ location data, point difference, point distance, and angle data.

This function can also be accessed by clicking on the  button on

the tool bar.

Peak / Valley

Measure…

Opens the Peak/Valley Measurement dialog box, which analyzes an

image, creating data and histograms representing the peak spacing

(the distance between adjacent peaks) and peak angle (the slope

between a peak and its nearest valley).

Line Analysis… Opens the Line Analysis Setup dialog box, which enables you to

perform up to three concurrent cross-sectional line analyses,

calculating height, roughness, bearing ratio, and fractal

measurements.

Area Analysis Accesses the following Area Analysis modules:

Roughness… Opens the Area Standard Roughness dialog box, which calculates

and displays the roughness parameters for the entire image or a user-

defined portion (exclusive or inclusive).

Measurement… Opens the Area Measurement dialog box, which calculates the

projected area and surface area of the entire image or the area of a

user-defined portion (exclusive or inclusive).

Fractal… Opens the 2D Fractal Analysis dialog box, which uses a “lake

filling” algorithm to calculate the fractal coefficient for the surface.

It calculates the number of lakes in the image (based on user-defined

criteria), then performs a fractal analysis of the image.

Bearing Ratio… Opens the 2D Bearing Ratio dialog box, which creates a bearing

ratio plot for the selected image.  The bearing ratio (percentage of

total data appearing above a user-selected Z level) can be calculated

for any user-defined point on the plot.
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Menu Item Function

PS Density… Opens the Power Spectral Density dialog box, which creates a

Power Spectrum for the selected image.  The PSD function is

defined as the square magnitude of the Fourier transform of the

surface.  RMS measurements can be calculated for any user-defined

pair of points on the plot.

Particle

Analysis…

Opens the Particle Analysis dialog box, which performs a particle

analysis (count, volume, volume histogram, area, perimeter, avg.

height, max. height) based on user-defined minimum detectable

particle size and Z threshold parameters.

Grain Analysis… Opens the Grain Analysis dialog box, which performs a grain

analysis (count, volume, volume histogram, area, area histogram,

avg. height, max. height) based on user-defined minimum detectable

grain size parameters (by slope or Z threshold).

Critical

Dimension…

Opens the Critical Dimension dialog box, which provides four basic

geometric patterns you can use to define and analyze critical

dimensions (width, step height, angle, radius, etc.) of any defined

area in the selected image.

The Setup Menu

The Setup menu, shown in Figure 4-9, provides access to acquisition hardware and

software configuration information, as well as the Color Settings dialog box.  The Setup

menu items are described briefly in Table 4-7.

Setup

Scan Parameters...

Screen Colors...

Preferences...

Figure 4-9.  The Setup menu.
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Table 4-7.  The Setup menu items.

Menu Item Function

Scan

Parameters…

Opens the File Info window, which lists the vital data acquisition

statistics for the selected image (SPMLab version, stage type, probe

type, scan rate, scan direction, etc.).  This function can also be

accessed by clicking on the  button on the tool bar.

Screen Colors… Opens the Color Settings dialog box, which enables you to set

various user interface colors for the screen, image, and graphs.

Preferences… Opens the Acquisition Preferences dialog box (see page 22).

The Window Menu

The Window menu, shown in Figure 4-10, provides access to the Data Acquisition

module and allows control over all windows open in the current interface.  The Window

menu items are described briefly in Table 4-8.

Window

Image Acquire...

Next...

Previous...

Duplicate...

Tile...

Cascade...

Figure 4-10.  The Window menu.
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Table 4-8.  The Window menu items.

Image Acquire… Switches to the Data Acquisition module.  All settings and functions

in the Image Analysis module remain unchanged while in the Data

Acquisition module.  This function can also be accessed by clicking

on the  button on the tool bar.  Once in the Data Acquisition

module, you can switch back to Image Analysis by selecting

Window⇒ Image Analysis or clicking on the  button.

Next… Selects the next image window in the interface, cycling through each

currently open window with each activation of the command.

Selecting any window listed in the numbered inventory at the

bottom of the Window menu will make that window active

immediately.

Previous… Selects the previous image window in the interface, cycling through

each currently open window with each activation of the command.

Selecting any window listed in the numbered inventory at the

bottom of the Window menu will make that window active

immediately.

Duplicate… Creates a duplicate of the currently selected image, which can then

be processed independently with any of the applicable Image

Analysis functions.

Tile… Arranges the windows on the screen, so they are positioned adjacent

to each other.

Cascade… Arranges the windows on the screen, so they are positioned in an

overlapping, offset arrangement.
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Image Analysis Tool Bar

The Image Analysis tool bar, shown in Figure 4-11, provides single-click access to some

of the most commonly-used functions.  Each button on the tool bar is described below.

Figure 4-11.  The Image Analysis tool bar.

  File Manager

Opens the File Manger dialog box, which displays all files which have the SPMLab and

ProScan (.hdf) file formats.  Standard file management tools are accessible, such as

Delete, Copy, Browse, etc.  This function can also be accessed by selecting File⇒ File

Manager.

  Save As

Opens the Save As dialog box, which gives you the option of saving any or all windows

currently open in the Data Acquisition module.  This function can also be accessed by

selecting File⇒ Save As.

  Scan Parameters

Opens the File Info window, which lists the vital data acquisition statistics for the selected

image (SPMLab version, stage type, probe type, scan rate, scan direction, etc.).  This

function can also be accessed by selecting Setup⇒ Scan Parameters.

  Previous Buffer

Selects the previous image in the buffer array.  The button is disabled if there are no

previous images in the array sequence.  This function can also be accessed by selecting

Buffers⇒ Previous.

  Next Buffer

Selects the next image in the buffer array.  The button is disabled if there are no more

images in the array sequence.  This function can also be accessed by selecting

Buffers⇒ Next.
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  1st Order, 2D Level

Performs 1st order 2D (plane) leveling on the selected image.  This function is one of

several leveling routines that can be accessed by selecting Process⇒ Leveling.

  Left Shade

Performs automatic left light-source shading on the selected image.  This function can

also be performed by selecting Process⇒ Shading and clicking on the Left Shade button.

  Right Shade

Performs automatic right light-source shading on the selected image.  This function can

also be performed by selecting Process⇒ Shading and clicking on the Right Shade button.

  Histogram

Opens the Histogram dialog box, which displays the data histogram for the selected

image, and enables you to edit the image’s color histogram.  You can apply the edited

histogram to the whole image or a portion of the image.  This function can also be

accessed by selecting Process⇒ Histogram.

  Palettes

Opens the Palettes dialog box, which provides access to the color palettes library.  Any

palette’s effect on an image can be viewed before accepting.  This function can also be

accessed by selecting Display⇒ Palettes.

  Graphic

Opens the Graphic dialog box, which allows user-defined 3D positioning of the image

display-angle.  This function can also be accessed by selecting Display⇒  Graphic.

  Line Measure

Opens the Line Measurement dialog box, which enables you to create and compare two

line profiles (horizontal, vertical, or variable) from the selected image.  The generated

data includes XYZ location data, point difference, point distance, and angle data.  This

function can also be accessed by selecting Analysis⇒  Line Measure.
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  2D FFT

Opens the 2D FFT dialog box, which displays the currently selected image’s power

spectrum in two dimensions, and enables you configure the filtering with a set of

Spectrum editing tools.  This function can also be accessed by selecting Process⇒  2D

FFT.

  Layered Image—Curve Extraction

Opens the Curve Extraction dialog box, which enables you to specify any pixel in a single

layer of a layered image, then extract a force distance curve for that pixel.  This function

is only accessed through the tool bar and is disabled unless a layered image is currently

selected.  Layered image files can be identified by the .ffl file suffix.

  Layered Image—Extract Layer

Creates a copy of the currently active layer in a layered image window.  This new window

can then be processed with all the available Image Analysis tools and functions.  (When a

layered image window is active, most Image Analysis functions are disabled.)  This

function is only accessed through the tool bar and is disabled unless a layered image is

currently selected.  Layered image files can be identified by the .ffl file suffix.

  Layered Image—Display Image

Sequentially displays each layer in a layered image file.  The function continually cycles

through each of the layers until the button is toggled off.  This function is only accessed

through the tool bar and is disabled unless a layered image is currently selected.  Layered

image files can be identified by the .ffl file suffix.

  Image Acquire

Switches to the Data Acquisition module.  All settings and functions in the Image

Analysis module remain unchanged while in the Data Acquisition module.  This function

can also be accessed by selecting Window⇒ Image Acquire.



 Chapter 5
Image Display, Processing, and Analysis
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Overview

The SPMLab Image Analysis software module functions as a data analysis and image

processing system which offers a sophisticated array of tools you can use to evaluate scan

files acquired in the Data Acquisition module.  In addition to an image editing function

which enables you to remove scanning anomalies, the module allows you to perform three

primary categories of operations:  display, processing, and analysis.

The display and processing functions are designed to optimize the image data’s color,

visual, and dimensional characteristics so you can display the image in a format that

facilitates both accurate measurement and visualization of the surface features.  In the

display mode, functions such as contrast and brightness, 3D display, and color palette

editing are controlled.  Visualization of the image is enhanced without affecting the data.

In the processing mode, image curvature, leveling, convolutions, arithmetic processing,

filtering, etc. are all handled.  In the analysis mode, the image is analyzed with statistical

and measurement functions, such as line profile, peak and valley analysis, particle and

grain analysis, and background subtraction.

This chapter provides functional and procedural descriptions of the main components of

the Image Analysis module.  For a complete listing and summary description of every

menu item and tool in the module, refer to Chapter 4, “Image Processing/Analysis Menu

& Tool Bar.”
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File Manager

The SPMLab File Manager, shown in Figure 5-1, allows you to open, copy, find

information about, delete, convert or export any data file in the SPMLab format and

AutoProbe ProScan (.hdf) format.  The function provides browsing capabilities based on

file name, file type, and the scan image thumbnail.  The File Manager is accessed by

selecting File⇒ File Manager or by clicking on the  button on the tool bar.

Figure 5-1.  The File Manager.

Information Field/Directory Manager

SPMLab and AutoProbe ProScan (.hdf) files are opened with the Directory and Drives

fields, which provide access to your computer’s directory structure in the same manner as

the Windows File Manager.  To navigate to another directory, click on the […] in the

Directory field.

The main field in the file manager window provides important information about the

SPMLab- and ProScan-formatted files in the currently selected directory.  A preview

image—for SPMLab-formatted files only—will be displayed for the selected image file.
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File Name

The File Name column lists the SPMLab- and ProScan-formatted files in the current

directory.  Only file formats selected with the File Types function will be listed.  (See

“File Type,” below.)

Description

The Description column lists the information recorded in the Description field during the

File Save As function (in either the Data Acquisition or Image Analysis module).  This

entry can be changed—for SPMLab-formatted files only—at any time by clicking on the

Description button.

Date/Time

The Date/Time column lists the date and time that the file was saved.

Type

The Type column lists the scanning mode of the acquired image (Topo = topography,

Sensor = internal sensor, etc.).

Dir.

The Dir. column lists the direction of the scan (Fwd = forward, Rev = reverse).

Process

An X in the Process column indicates that the image file has been processed in some way

in the Image Analysis module.
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File Manager Controls

The File Manager controls, shown in Figure 5-2, are located on the right side of the File

Manager window.

Figure 5-2.  The File Manager controls.

File Type opens the File Type dialog box, shown in Figure 5-3, which allows you to

select the specific SPMLab extensions and file types that will be listed in the SPMLab

File Manager.  This dialog box can also be used for deciphering a file’s scan mode based

on its extension.
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Figure 5-3.  The File Type dialog box.

Individual file types can be selected or deselected as appropriate, or you can use the

Select All button to select every option or the Unselect All button to deselect every

option.

Browse/List brings up a preview image of each SPMLab-formatted file in the directory.

In the browse mode, this button toggles to List, which returns you to the standard File

Manager listing by file name.  Double-clicking on a preview image opens the file for

image processing.

Open opens the selected file for image processing.  The button is disabled unless a file or

files are selected.

Info opens the File Info window, shown in Figure 5-4, which provides all relevant scan

and setup parameters for the selected image file.  The information is not editable.  The

button will be disabled unless one (and only one) file is selected.

Copy opens the File Copy dialog box, which allows you to copy a file to another name or

directory.  The original file will be preserved under its original file name.

Rename opens the File Rename dialog box, which allows you to change the selected file’s

name.  No other file details will be changed.

Note: The Rename and Copy functions will not allow you to change a file’s default

extension.
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Figure 5-4.  The File Info window.

Delete permanently removes the selected file from the directory and drive.

Description opens the File Description dialog box, which allows you to change or add to

the text in the file’s description field (for SPMLab-formatted files only).

Convert converts .spm files created in earlier versions of the SPMLab software to the

current SPMLab format.  One advantage in making this conversion is the addition of the

Browse thumbnail preview image displayed in the upper-right portion of the File Manager

window.

Note: Converted files will no longer read into the SPMLab DOS software.  If

necessary, create a duplicate of the earlier DOS file and convert only the

duplicate.

Export exports, as ASCII files, SPMLab data ,including scan files, line profiles, curves

from the Point Spectroscopy mode, and Electrochemistry data.  The ASCII data can be

imported into other compatible software applications.

Keep Dir, when toggled on, sets up the File Manager to automatically reopen at the last

selected directory.

Apply Acquisition Display Settings applies all Z-scaling, leveling, and shading display

functions used when scanning the image in the Data Acquisition module.  The original

raw scan data is not changed by applying the option.  And the raw data file can always be

used in its original form simply by making sure the option is toggled off when the file is
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opened, or by selecting the previous buffer button  on the Image Analysis tool bar (see

“Image Buffers,” below).

Importing Files

The Import Data dialog box, shown in Figure 5-5, allows you to import DBOSS SPM

files and other binary files, such as SPM files from third-party vendors, for processing in

the Image Analysis module.  Select File⇒ Import to open the dialog box.

Figure 5-5.  The Import Data dialog box.

Use the List Files of Type listbox to locate the file you want to import, and click the OK

button to open the file.  If you are importing a file from a third-party vendor, the Import

Binary Data dialog box, shown in Figure 5-6, opens.

Figure 5-6.  The Import Binary Data dialog box.

Use this dialog box to enter and/or confirm the binary data that will appear in the file’s

header.  Check the Signed checkbox if the data is in the form of a signed integer.  The

image must be square, i.e., X resolution = Y resolution.  Click OK to confirm these

settings, and the image will be opened.
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To convert a DBOSS file to the standard SPMLab data file format, select a DBOSS file

and click on the Convert button.  The Save Data As dialog box, shown in Figure 5-7,

opens.

Figure 5-7.  The Save Data As dialog box.

Select a directory and enter a file name.  A file extension will be assigned based on the

file’s detected scan mode.  Click the OK button to return to the Import Data dialog box,

where the file can then be opened.

Image Editing

Data Edit

Selecting Edit⇒ Data Edit opens the Data Edit tool palette, shown in Figure 5-8, which

provides four powerful image editing tools.  These tools actually edit the image data file,

allowing you to remove erroneous data, unwanted data, noise spikes, and noise lines.

Note: Images must be in top view for editing.  The best results will always be achieved

when you edit an image BEFORE any shading functions have been applied.

There are four editing functions that can be used on the top-view data.  If any of the four

options are selected, the cursor will change to a crosshair or line cursor when positioned

over the image.  After applying any function, the operation can be reversed by clicking on

the Undo button on the tool palette.  To return the image to its original state, click on the

Original button.  After exiting the edit function, you can also revert to the image's original

state using the image buffers.
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Figure 5-8.  The Data Edit tool palette.

Coarse Pixel Averaging

The Coarse Pixel Averaging tool  allows you to define an area around a data anomaly

and eliminate it by filling in the area with the average of the surrounding pixels.  This is

useful for removing unwanted or invalid pixels from the image and can be repeated as

many times as is necessary.

To use Coarse Pixel Averaging:

1. Select the Coarse Pixel Averaging tool.

2. Left-click and drag to define the area to be corrected.

3. Release the mouse button and move the bounding box as needed to target the

feature you are editing, as shown in Figure 5-9.

If necessary, you can redefine the bounding box with the left-click and drag

operation.  A single pixel or larger area can be selected.
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4. Right-click to apply the function within the bounding box.

Figure 5-9.  Pixel editing:  before and after.

Single Line Editing

The Line Editing tool  uses the same averaging algorithm as the Coarse Pixel

Averaging tool, but the function is applied to a single horizontal line on the scan image.

When you apply the function, each pixel on the entire selected line is replaced with the

average of the pixels directly above and below it.  This tool is useful for removing streaks

and horizontal noise lines from an image, as shown in Figure 5-10.

Figure 5-10.  Applying the line editing tool:  before and after.

1. Select the Line Editing tool

2. Left-click and drag in the image to open the editing line.
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3. While holding the left mouse button down, move the editing line over the scan

line to be averaged.  As you move the line cursor over the scan, the line number

under the cursor will be indicated on the Data Edit tool palette.

Release the mouse button to apply the function.

Fine Pixel Averaging

The Fine Pixel Averaging tool  eliminates glitches (or spikes) from the image using an

algorithm that finds small data spikes or high points within the bounding box, then

replaces the glitches with the average of the surrounding normal Z data.  Because the

algorithm is specifically designed to locate small, anomalous data spikes, this tool usually

will not be effective in removing larger high spots or tall features.

1. Left-click and drag to define the area to be corrected.

2. Release the mouse button and move the bounding box, as needed, to target the

feature you are editing.

Figure 5-11.  Defining an area to be edited.

If necessary, you can redefine the bounding box with the left-click-and-drag

function.  A single pixel or a larger area can be selected.

3. Right-click to apply the function within the bounding box.

Figure 5-12.  Area after editing.
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Figure 5-13.  Applying the Fine Pixel Averaging (glitch removal) tool:  before and after.

Step Removal

The Step Removal tool  allows you to equalize the Z level of two or more horizontal

steps in a scan image.  Sometimes this step effect will occur because of debris breaking

off of, or adhering to, the tip during a portion of the scan or because the end of the tip

breaks off during the scan.  The result will be a change in the average Z level midway

through the scan, independent of actual topography.

Figure 5-14.  Applying the step removal tool:  before (left) and after (right).
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1. Select the Step Removal tool.

2. Left-click and drag on the image above or below the step.  A horizontal line

cursor will appear, and after you release the mouse button, a horizontal marker

will remain.

3. Left-click and drag again on the other side of the step.  A horizontal line cursor

will appear, and when you release the mouse button, the software will eliminate

the step difference between the two selected lines.

The function may need to be repeated for complete equalization between two or more

steps.

As with all of the data editing tools, it is important to remember that when you edit pixels

on an image, you are actually editing the scan data.  In the example shown in Figure 5-15,

the Coarse Pixel Averaging tool was used to remove a 77 nm high spot in the scan.  With

the feature edited out, the Z range data for the entire scan changed, dramatically altering

the Z-scaling/color distribution for the image.

Figure 5-15.  Topography scan before data editing (left) and after tall feature is removed
(right).  Note the change in Z range.
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Image Buffers

Each time the image on the screen is edited or processed, it becomes the current (and last)

image in a series of six buffers, allowing you to reselect up to six stored versions of the

image you are analyzing.

The Buffers⇒ Next and Buffers⇒ Previous commands serve the same functions as the

Buffer buttons on the tool bar, which allow you to browse forward  or backward 

through the buffered images.

Once buffers 2 through 6 are filled, each subsequent change to the image will appear in

Buffer 6, permanently bumping the oldest of the changed images out of Buffer 2.  The

original saved version of the image file will always be stored in Buffer 1, regardless of the

number of changes applied.  A set of buffers will be maintained for each image file you

currently have opened.

The Buffers⇒ Select function opens the Image Buffers dialog box, shown in Figure 5-16.

Figure 5-16.  The Image Buffers dialog box.

Click on any image to select that buffer.  The selected buffer’s name will be highlighted in

red.

New Window creates a duplicate scan window of the selected buffer image.  (This will be

an independent image file, not a new buffer.)
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Save As saves the selected buffer as a new image file, without altering the original scan

data.

Delete permanently deletes the selected buffer.  This function can also be performed

without invoking the dialog box by selecting Buffers⇒ Delete while the buffered image

you want to delete is active.

Duplicate copies the active window and places it in the next buffer position.  This

function can also be performed without opening the dialog box by selecting

Buffers⇒ Duplicate while the buffered image you want to duplicate is active.

Note: When an image selected from a buffer is modified, any buffers containing

subsequent image modifications are deleted.
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Image Display

The Display menu of features provides an array of functions that allow you to modify

basic visual display characteristics of your image—such as contrast and brightness—and

some more advanced display characteristics such as 2D color options and color palettes.

As with many options in the Image Analysis module, it is important to remember that

some of the functions will actually change the meaning of the data you are presenting.

Therefore, display capabilities should always be used with the practical significance of

the raw data in mind.

Contrast & Brightness

Selecting Display⇒ Contrast & Brightness opens the Contrast & Brightness dialog box,

shown in Figure 5-17.  Both contrast and brightness can be modified with the sliders

while monitoring the results on the image.  To return to the original values, click on the

Default button.

Contrast and brightness adjustments change the distribution of the active color palette

used for the image.

Figure 5-17.  Scan Image before (left) and after (right) Contrast & Brightness changes are
applied.  Note the relative difference in the distributions of the color palettes.

Palettes and Palette Editing

Palette Menu

You can apply any of the predefined or user-defined (previously saved) color palettes to

your image by selecting the Display⇒  Palettes function, which opens the Palettes dialog

box.  This allows you to select the palette that best displays the important characteristics
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of your image.  The Palette menu can also be opened by clicking on the  button on the

tool bar.  Examples of some palette settings are shown in Figure 5-18.

Figure 5-18.  Examples of some palette settings.

Color palettes are not part of the stored data for an image file.  Any image that is opened

(or viewed through the file manager preview function) will always be displayed in the

currently selected palette, regardless of what palette was used on the original data.  If a

specific palette should always be used on a specific image, or if a custom palette is

designed specifically for an image (as described in the following Palette Editing section),

use the Description function in the File Manager to attach a note specifying the palette

name to the file.

Palette Editing

Any palette can be modified and saved using the Palette Editor control panel, shown in

Figure 5-19, which is opened by selecting Display⇒  Palette Editor.  The Palette Editor

control panel allows you to individually modify the selected palette’s red, green, and blue

intensity while monitoring the results on the image.  The goal of palette editing is to

create a palette that best highlights and displays the features of interest in your image.

For example, within a 1000 nm Z range, you can modify or create a palette that displays

features above 700 nm in an orange palette, while features below 700 nm are displayed in

a gold palette, thereby drastically increasing the visual emphasis applied to the higher

features of interest.
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Figure 5-19.  The Palette Editor control panel.

When selecting the function, the current palette will be displayed for editing, but all

palettes are available from the Palette drop-down list.  Any of the three color slopes (Red,

Green and Blue) can be changed individually by selecting the appropriate button and “re-

drawing” the color's slope in the window.  The changes will be seen on the image in real

time.  The best way to become familiar with the editing functions is to experiment.

To re-draw a color’s slope:

1. Left-click anywhere on the color line, as shown in Figure 5-20.

2. Drag to a new position.

1

2

Figure 5-20.  Re-drawing a color line.

Any editing on a palette can be reversed by clicking on the Revert button (provided you

haven't saved the changes).  Changes to a palette will be permanently saved with the Save

function, or you can save a new palette from your changes by using the Save As function.

IMPORTANT: The Save function will permanently save any changes to existing,

predefined palettes.  When making changes to existing palettes, it is recommended that

you use the Save As function to save the edited palette under a new name and then edit

the palette and save the changes.
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Selecting the Rainbow1 palette, shown in Figure 5-21, provides a good illustration of the

relationship of the varying intensity of the color lines to the resultant color palette.

Figure 5-21.  The Rainbow1 palette.

The color intensity is plotted on the Y axis, versus the Z height which is plotted on the X

axis.  Where colors share portions of a slope, the addition of those primary colors forms

the resultant color for that portion of the Z range.  For example, a palette with an even

positive slope consisting primarily of red and blue, with a low level of green, will produce

a purple palette, where higher image features are represented by a correspondingly

brighter intensity of purple (see Figure 5-22).

Blue Red

Green

Figure 5-22.  The Purple1 palette.

The Smooth function will apply a small smoothing factor to any color lines that have

become jagged or disconnected due to editing, an operation that can be repeated as many

times as necessary to gain the desired amount of change.

Note: For advanced color palette editing capabilities, including palette editing to a

corresponding data histogram, see “Color Mapping,” below.

Color Mapping

Color mapping offers an array of tools which allow you to customize your color palette as

it correlates to the histogram for the currently selected image data.  Selecting Display⇒
Color Mapping opens the Color Mapping dialog box, shown in Figure 5-23.
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Figure 5-23.  The Color Mapping dialog box.

The Color Mapping dialog box controls five distinct color functions for enhancing and

modifying the displayed image:

-Color Intensity

-Color Histogram

-Mapping Function

-Single Color Editing

Data Histogram Using these functions, you can assign specific color combinations to

corresponding Z ranges in your image.  This would enable you, for example, to assign red

to a lower step in a scan image and green to an upper step.

Color Intensity

The Intensity function allows you to individually modify the selected palette’s red, green,

and blue (RGB) intensity while monitoring the results on the preview image.  The editing

process works the same as described in “Palette Editing,” above, with the addition of the

corresponding color and data histograms.  The goal is to create a palette which best

highlights and displays the features of interest in your image (as they are represented in

the histograms).  Any of the three color slopes (Red, Green, and Blue) can be changed

individually by selecting the appropriate button in the RGB Component field and

“redrawing” the color's slope in the window.  The changes will be seen on the image in

real time.

When editing the RGB levels of a palette, you should correlate the color levels to the

Color Histogram, which is to the right of the Intensity field.  In turn, the Color Histogram
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field correlates to the Data Histogram field.  Doing so will allow you to assign the color

you want to specific features as they are represented on the histograms.

Before saving, changes made to the color palette can be reversed by clicking on the

Revert button.

When selecting the function, the current palette will be displayed for editing, but all

palettes are available from the Palette drop-down list.  Changes to a palette will be

permanently saved with the Save function, or you can save a new palette from your

changes by using the Save As function.

IMPORTANT:  The Save function will permanently save any changes to existing,

predefined palettes.  When making changes to existing palettes, it is recommended that

you use the Save As function to save the edited palette under a new name and then edit

the palette and save the changes.

Color Histogram/Mapping Function

The Color Histogram for the current image data is used primarily for two functions:  to

correlate Z data levels to the Intensity field to the left, and to correlate to the Mapping

Function, immediately to the right.

- The default linear data distribution can be specified by selecting the Linear

Distribution Button .

This distributes the data linearly across the color palette, as originally scanned.

- The distribution can be equalized, distributing the colors equally across the

entire Z range, by selecting the Equalize button 

- The distribution can be customized and the Mapping Function manually changed

by selecting the User button .

Selecting the function creates four editing points on the mapping scale, which

can be manipulated to highlight corresponding steps or features on the image.

Click and drag on any of the editing points to change the slope.  Note that the

cursors on the color bar, color histogram, and data histogram will all

simultaneously track changes to the editing points.  See Figure 5-24.
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Corresponding
Markers

Selected
Mapping
Point

Figure 5-24.  Map editing.

Select Apply to have the changes reflected on the preview image.  Select OK to accept

changes and apply them to your image.

Data Histogram

The Data Histogram is displayed in the lower right corner of the screen.  By moving the

yellow pointer, the color and RGB distribution for a specific Z height is displayed in the

Index window.  To change the color at that specific point on the Histogram, use the Single

Color Editor for appropriate editing.  In this way you can create a marker on your color

palette that highlights a specific Z range with an alternative color.

X, Y, Z Coordinates

The X, Y, and Z coordinates for any pixel on your scan image can be displayed by simply

moving the cursor over the location you want to target on the preview image, as shown in

Figure 5-25.
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Figure 5-25.  Displaying X, Y, and Z Coordinates.

Color Mapping Tips

- Equalizing the image will often add contrast to data that has very small surface

features.  It can also add clarity for black and white printing applications.

- The Single Color Editor is often very useful for separating Z regions.  Try

adding a single bright color within the palette of an unshaded image.  Doing this

at regular intervals along the histogram can give a “topographical map” look.

- The Intensity window can be used to delete Z ranges and highlight specific data

as well as add dramatic color effects for presentation materials.

Shading

The SPMLab shading functions allow you to shade images, creating a simulated light

source which can dramatically enhance image features by creating highlights and

shadows, as shown in Figure 5-26.

Figure 5-26.  Topographic image before (left) and after (right) shading.
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The Shading dialog box, shown in Figure 5-27, is accessed by selecting Display⇒
Shading.  This dialog box allows the automatic positioning of a left or right light source

or user-defined vector positioning of the light source.

Figure 5-27.  The Shading dialog box.

There are two shading options available:

- Auto left/right shading:  Selecting Left shading or Right Shading simulates a

light source to the left or right of your image at a 45° angle from level.  The

automatic left/right shading can also be applied by clicking on the  or 

buttons on the tool bar.

- Vector Shading:  Allows free movement of the light source by either dragging

with the left mouse button across the sphere and releasing to set the light source

or entering the appropriate values in the Phi and Theta fields.

Theta sets the light angle relative to the plane of the surface, from –90° to +90° with 0° at

the point directly above the sample.  Phi is the angle of rotation at which the light hits the

surface, from 0° to 360°.  See Figure 5-28.

Clicking on Shade applies the vector shading values to the highlighted image.  Clicking

on Revert eliminates the applied shading.
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SURFACE

THETA

PHI

Figure 5-28.  Theta and Phi light source settings.

Hint:  Phi and Theta settings of 0° appear to splash the light onto the surface, directly

from above.  Followed by 2D shading (described in “2D Color Editor:  True 2D Color”

on page 5-29), this function can work well to visually highlight many types of surface

features.

It is important to remember that when an image is shaded, the color scale is no longer

used to represent Z height.  Instead, it is used exclusively to represent topographic slope,

as depicted by the angle of the light source.  In the set of images to the right, note that the

color palette on the unshaded image represents scaling from 0-180 nm, i.e., the color

distribution represents only height information.  After the image is shaded, the color

palette is entirely redistributed to represent only slope information.  If Z height is critical

information, retain a copy of the original, unshaded data.  Also, the 2D display options,

described in “2D Color Editor:  Pseudo and True 2D Color,” below, offer a combined

color palette distribution, which divides the palette between slope and height

representation.

Figure 5-29.  Topographic image before shading (left) and right-shaded (right).
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2D Color Editor:  Pseudo and True 2D

2D color functions are always applied after shading, allowing you to determine how much

of the image’s color contrast information will be used to depict the height of the features

in an image, and how much color contrast will be used to depict feature slopes.  When an

image is shaded to enhance the visual characteristics of the data, all of the color

information is devoted to depicting the slope of the features, rather than the height.  When

data is represented in this way, the height data in the color scale is replaced with light-

source angle data, making it difficult to determine Z height based on color alone.

(Shading functions are described in “Shading” on page 5-24.)  2D color editing allows

you to divide the color palette between height and slope information, thereby providing

the enhancement of shading effects with the height information of a topography-based

color scale.

When shading an image, note the change in the raw data’s color palette from Z data to

light angle data, as shown in Figure 5-30.

Figure 5-30.  Change in raw data’s color palette from Z data (left) to light angle data (right).

The two color mapping options that can be applied are Pseudo 2D and True 2D.  Pseudo

2D, accessed by selecting Display⇒ 2D Color⇒ Pseudo 2D, allows you to designate the

slope versus height distribution of 230 out of 256 colors in the selected color palette.

True 2D, accessed by selecting Display⇒ 2D Color⇒ True 2D, divides the selected color

palette depending on your graphics card setting:  16-bit = 65k, 24-bit = 16M.  The

parameters for both modes are set in the 2D Color Mapping dialog box, accessed by

selecting Display⇒ 2D.

With both 2D color modes, results will vary dramatically depending on the parameter

settings in the 2D Color Editor, and on the image data itself.  Experimentation is the only

sure way to determine how the function can affect the visualization of your data.
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Note: Your acquired image must be shaded before you can apply either the Pseudo or

True 2D Color function.

Note: The True 2D Color function can create dramatic effects on images using

multiple-color palettes.

Pseudo 2D Color

Pseudo 2D Color (Display⇒ 2D Color⇒ Pseudo 2D) is used for manual

slope/height/sharpness mapping adjustment in the 8-bit (256 color) mode.  The option is

available whether your graphics card is set to 8-, 16-, or 24-bit color.

Figure 5-31.  The 2D Color Mapping dialog box:  Pseudo Color.

Pseudo 2D parameter editing is performed by selecting Display⇒ 2D Color Editor, then

choosing the Pseudo Color option.  The dialog box that opens, shown in Figure 5-31,

allows you to define the distribution of 230 (out of 256) colors between Height and Slope,

using the appropriate spinner controls or by typing in the values.  The Sharpness control

adjusts the surface reflectivity (shininess) of the image.  A higher sharpness creates a

more reflective image.  With a lower sharpness setting, the inverse is true.  Most color

palettes and images look best with the system default sharpness setting of 1.  All

subsequent applications of the Display⇒ 2D Color⇒ Pseudo 2D function will apply the

settings you configured in the 2D Color Mapping dialog box.

The objective is to create a combination that improves the color mapping as it applies to

the features of interest in your image.  Experimentation with the three variables is the best

method of determining optimal settings.  After adjusting the variables, you can apply the

changes temporarily with the Apply button.  All changes applied within the 2D Color

Mapping dialog box can be reversed by clicking on the Undo button.
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Figure 5-32.  Shaded image (left) vs. pseudo image (right).

True 2D Color

True 2D (Display⇒ 2D Color⇒ True 2D) evenly distributes the number of colors (16-bit

= 65k, 24-bit = 16M) between height and slope.  Editing is performed by selecting

Display⇒ 2D Color Editor, then choosing the True Color option.

Figure 5-33.  The 2D Color Mapping dialog box:  True Color.

In the True 2D Color mode, the 2D Color Mapping editing consists of adjustment to the

image’s sharpness value.  The Sharpness control varies the distribution of color intensity

between height data and shading data.  A higher sharpness value distributes more of the

spectrum to shading information and less to height.  With a lower sharpness setting, the

inverse is true.  As with Pseudo 2D color mapping, the objective is to determine the

setting that best displays the features of interest in your image.  Experimentation is the

best method of determining optimal settings.
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After adjusting sharpness, the Apply button updates the image with the current setting.

These changes can be reversed by clicking on the dialog box’s Undo button.

All subsequent applications of the Display⇒ 2D Color⇒ True 2D function will apply the

settings you configured in the 2D Color Mapping dialog box.

Figure 5-34.  Shaded image (left) vs. true 2D image (right).

Hint:  After applying 2D shading, adjusting contrast and brightness can further enhance

your image.

Data Histogram:  Color Distribution

The color histogram function allows you to limit most of the color palette’s distribution to

the Z range of interest in your data.  By default, the color palette is distributed linearly

across the full Z range.  For many types of scans, this is an acceptable or optimal color

distribution.  But on some scans, e.g., an upper surface surrounding a relatively deep hole,

much of the color distribution will be taken up by the walls of the hole, making it difficult

to resolve fine features in the upper or lower portions of the range (the surface around the

hole or the surface at the bottom of the hole).

Selecting Display⇒ Histogram opens the Histogram dialog box, shown in Figure 5-35,

which allows you to use the data’s histogram to define the specific portion (or portions) of

the Z range where the majority of the color palette will be distributed.  This function can

also be accessed by clicking on the Histogram button  on the tool bar.

In the topographic image of a CD stamper in Figure 5-35, the majority of the data

distribution of the histogram is taken up by the lower Z range features (the surface of the

CD).  This Z range occupies most of the lower end of the color scale.  The CD bits

occupy a narrow band of the mid-upper region of the scale.  The default color palette

distribution, however, distributes colors evenly across the entire Z range.
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CD Surface

CD Bits

Figure 5-35.  The Histogram dialog box.

Figure 5-36 illustrates how distributing most of the color palette to the Z range that

encompasses the base-level surface, rather than the raised bits, can dramatically enhance

the details of interest.  In this example, only a user-defined portion of the image had the

color palette redistributed.  You have the option of applying the function to all or a

portion of the image.  In this case, higher Z range features of less interest will be

essentially “whited out” by the redistribution.
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Figure 5-36.  Color palette re-distributed to highlight lower Z range features on a portion of
the image.

Color Redistribution Over the Whole Image

Use the following procedure to redistribute the color palette over a certain data range in

the histogram, applying the changes to the entire image.

1. Select the Whole Image option.

2. Click and hold the cursor in the field below the histogram, to the left edge of the

data range you want to highlight.

3. Drag to the right until the appropriate data range is highlighted, then release.

More than one data range can be highlighted on the histogram.

4. Click on Apply to redistribute the palette.

Clicking on Revert reverses the applied histogram modifications.

Figure 5-37.  Color redistribution over the whole image.
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Color Redistribution Over a Portion of the Image

Use the following procedure to redistribute the color palette over a certain data range in

the histogram, applying the changes to only a portion of the image.

1. Select the Partial Image option.

2. Using the crosshair cursor on the full image (not the Histogram dialog box

preview image), left-click and drag to draw a box around the area of interest,

then release.

Once the box is drawn, you can move it freely within the image.  Repeat this step

if you want to redraw the box.

3. Right-click to set the partial image frame.

To redraw the box, left-click, drag, and release again.

4. Click and hold the cursor in the field below the histogram, to the left edge of the

data range you want to highlight.

5. Drag to the right until the appropriate data range is highlighted, then release.

More than one data range can be highlighted on the histogram.

6. Click on Apply to redistribute the palette.

Clicking on Revert reverses the applied histogram modifications.

Zooming in on the Histogram

You can zoom in on any portion of the Z range by defining the upper and lower limits in

the Adjust Z Min and Adjust Z Max fields.  Clicking on the Apply button zooms in on the

defined portion of the histogram and redistributes the color palette over that range.  After

applying the function, you can click on the UnZoom button to return to the original full

histogram color distribution.
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Graphic/3D Image Manipulation

In addition to the standard top view, the active image can be rotated and displayed from

any angle, based on a 3D mesh grid interface.  The Graphic Control Panel, shown in

Figure 5-38, is accessed by selecting Display⇒ 3D Graphic or clicking on the  button

on the tool bar.

Figure 5-38.  The Graphic control panel.

This control panel allows the top-view image to be rendered in 3D to your exact

specifications, as illustrated in Figure 5-39.

Figure 5-39.  Example of 3D rendering:  before (left) and after (right).
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Display Type

Top View returns you to your top-view image, even if you have already rendered in a 3D
mode.

Mesh creates a 3-dimensional mesh representation of the scan image by drawing

topography lines in both the X and Y directions.

Polygon uses the entire color palette, fully rendering the scan data as a reoriented 3D

version of the top-view image.

Mesh renders much more quickly than Polygon and is usually used as a full-size preview

of the orientation.

View Point

Near adjusts the perspective to a close up view-point.

Medium adjusts the perspective to an average view-point.

Far adjusts the perspective to a distant view-point.

Perspective Parameters

Manual adjustment of the image’s perspective is accomplished simply by using the hand

cursor to manipulate the tilt and rotation of the 3D box that represents the image.

Z max/Z min allows you to render within a specific Z range of your data, essentially

cropping out the Z data above and below the maximum and minimum settings.  The

default setting is the full Z range.

Z Scale adjusts the scaling factor used to depict the height of the features in the 3D

image.  The function is usually used to exaggerate the Z height when features are so small

compared to the X,Y range that the sample appears flat.  A setting of 1 will use no

scaling, i.e., the X/Y to Z ratio will be 1:1.  For example, the features on an image with a

10 nm Z scale will appear twice as high if the value in the Z scale field is set to 2 (but will

still be represented by a 10 nm scale).

Tilt and Rotation change the orientation of the image.  This can also be done by placing

the cursor over the orientation boxes on the screen.  The cursor will change to a “helping

hand” which can be used to manipulate the image orientation with a left-click-and-drag

operation.

Zoom allows you to zoom in, at the current perspective and angle, by the factor specified

in the field.
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Standard reverts to the standard angle, rotation, and perspective.

Default reverts to the angle, rotation, and perspective of any previously accepted

application of the Graphic function.

Zero Set

The Zero Set function enables you to define a “zero” set point for the image's Z data.

This, in turn, allows you to use two different color palettes, i.e., a “split palette,” as shown

in Figure 5-40, to display the topographic data above and below the zero set point.  This

can greatly improve the ability for immediate visual identification of a particular Z range

within an image.

Figure 5-40.  Split palette.

The split palette allows easy illustration of all data below the specified Z level.  Figure 5-

41 shows how wells within the raised holes can be illustrated.

Figure 5-41.  Scan before (left) and after (right) applying the Zero Set function.

The Zero Set dialog box, shown in Figure 5-42, is opened by selecting Display⇒ Zero

Set.
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Figure 5-42.  The Zero Set dialog box.

To define the zero set point:

1. Place the cursor over the top-view image in the dialog box.

a. Left-click and drag until the horizontal line marker crosses a feature within

the Z range you want to split.

b. Release to set the line.

A corresponding line profile will appear in the dialog box.

You can repeat the step to redefine the line.

2. Select the palette below the zero set point.

a. Click to select the Dual Palette option in the Zero Set Palette area.

b. Select the second palette you want to use from the 2nd Palette drop-down

list.  This palette will represent the data below the zero set point.

The original palette will be used to display all of the data above the zero set

point.
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3. Place the cursor over the line profile.

a. Left-click and release on the line profile.

b. Move the cursor until the horizontal line marker is at the zero set point

where you want the palette to split.  You can monitor the exact position of

the cursor in the Z Level field, below the line profile.

c. Click again to set the zero set point.  The palette will split at the defined Z

level and the image will reflect the change.  You can repeat the step to

redefine the line.

d. Right-click to define the zero set point and exit the function.

Zero Set Off

Selecting Display⇒ Zero Set Off is a one-step command that returns the image to its

original full palette.  To return to a split palette, the Display⇒ Zero Set function will have

to be configured and applied again.

Scale XY

Selecting Display⇒ Scale XY opens the XY Scale dialog box, shown in Figure 5-43,

allowing you to change the X,Y scale on the displayed image.  Both the number and units

can be redefined, allowing relabeling of the image dimensions.  This function is generally

used to round the scale values.  When changing units, no automatic recalculation of the

numeric values takes place.  You must calculate any conversions manually and enter the

new values in the XY Scale field.

Figure 5-43.  The XY Scale dialog box.

IMPORTANT:  Use care to avoid misrepresenting your data.  Saving an image after

making changes to the X,Y scale will make those changes permanent in the data file.  For

example, if you change units from µm to Å without recalculating the numeric values,

when the image file is opened again, the scaling will be in angstroms but the X and Y

values will not have been recalculated, resulting in invalid data.
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Common Color Bar

This feature provides the ability to directly compare up to six similar images by applying

a common Z range.  Because the software automatically sets the Z range for each scan

based on the topography or other parameters encountered by the tip, Z ranges will vary

from scan to scan.  Therefore, the color palette’s distribution across the different scans’ Z

ranges will vary as well, as shown in Figure 5-44:  0-304 nm and 0-134 nm.  The

Common Color Bar function gives you the ability to apply the same Z range to all scans,

in essence allowing you to compare apples to apples.

Figure 5-44.  Two different scans before (top) and after (bottom) applying Common Color
Bar function for comparative analysis.

It is important to understand that the images must be of comparable data.  For example,

comparing topography with electrostatic force would not yield meaningful data.  For that

reason, the software will not allow application of the Common Color Bar function to

dissimilar data files.

Image Categories

As explained previously, in order for the Common Color Bar to be functional, the basic

requirement is that the function be applied to images of the same scan type.  All image

types (regardless of the scan method) also fall into two basic image categories—relative
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data and absolute data—which determine the configuration of the Common Color Bar

control panel.

Relative Data Images

Relative data images are relative to the lowest measured value, which will always be

assigned the value of 0 on the color scale bar (regardless of the unit).  Therefore, all data

is compared to the zero value on the scale, i.e., a topographic value of 125 nm simply

means the data point is 125 nm above a relative zero point in the scan area.

Absolute Data Images

With absolute data images, the Z values of all data points have actual meaning.  They are

related to some absolute zero.  Therefore, both ends of the scale bar can have any value,

depending on the data.  For example, in an STM current image, a data point with a 0 nA

value means that there is no tunneling current at that point.  A +1 nA current value could

indicate a tunneling current flowing from the tip to sample, and a -1 nA current could

indicate a tunneling current flowing from sample to tip.  In this case, the scale would be at

least ± 1 nA.

Image category by data type.

Data Type Image
Category

Unit

Topographic Image Relative µm, nm, Å

Sensor Signal Relative nA

AFM and STM Spectroscopy Absolute nA, A

STM Spectroscopy in V Absolute nA, V

LFM Image Absolute nA

Thermal, SEPM Absolute V

NSOM Absolute nA

Select Display⇒ Common Color Bar to open the basic Common Color Bar dialog box,

shown in Figure 5-45.  This dialog box will open in one of two configurations, depending

on the type of data:  relative or absolute.

The common Z range is set in the Common Range field for relative data or in the

Common Setting field for absolute data.  When the dialog box is initially opened, the

default values in these fields reflect a calculated range based on all the data in the files in

the Image List.  For relative data, this default value is calculated so the average Z level for

each image will be assigned the same color on the color palette.  For absolute data, the
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default Zmax and Zmin values are calculated based on the highest and lowest Z levels

among all of the selected image files.

Figure 5-45.  The two Common Color Bar dialog boxes:  relative (left) and absolute (right).

The Image List field displays the images that will have the Common Color Bar applied.

Images can be deleted or added.  To delete an image, click on the Delete Image button,

then click to select the file name to be deleted in the Image List field.  To select additional

open image files of compatible types, click on the Select Image function, then click on the

image window in the work-space.

Selecting Default applies the value displayed by default in the Common Range or

Common Setting fields.  Selecting Revert returns the color bars to their original range.

Advanced Common Color Bar

Selecting Advanced opens the Advanced Common Color Bar dialog box, shown in Figure

5-46, which displays a histogram for each selected image and allows configuration of

each histogram relative to the common color bar.  With the advanced control panel,  the

goal is still to define a common color scale to be applied to selected images, but with the

added capability of determining the best histogram offset for each image relative to the

color scale bar, and the best range for the color scale bar relative to the histograms.

Each image histogram is offset relative to the yellow cursor on the color bar by the value

indicated in the Offset fields.  Moving this cursor will adjust the position of all of the

images simultaneously, i.e., it will move all of the histograms up or down along the color

bar.

Setting the Offset fields to 0 will align the yellow cursor with all of the histograms’ data

average points (indicated by the magenta horizontal line marker in the center of the

histogram).  Setting a zero offset for each histogram ensures that all of the images will

have their data distributed evenly around the same color/Z level.  The offset can also be

changed by dragging inside the histogram with the left mouse button.  The histogram can

also be shifted by changing the values in the Zmax or Zmin fields.  All other values will

shift to correspond to the value entered.
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Figure 5-46.  The Advanced Common Color Bar dialog box.

The common Z range is set in the Common Range field for relative data or in the

Common Setting field for absolute data (in the same manner as the basic control panel).

When the dialog box is initially opened, the default values in the field(s) reflect a

calculated range based on all of the histograms.

The Image Area displays the maximum, minimum and average Z level within a user-

defined bounding box on any area inside one of the images.  To define the bounding box:

1. Left-click, drag, and release directly on the image, as shown in Figure 5-47.

This process can be repeated to redefine the box.

Figure 5-47.  Defining the bounding box.
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2. Move the mouse to place the box.

3. Right-click to apply the function.

The Z average, minimum, and maximum within the bounding box will be displayed in the

Image Area (see Figure 5-48), and markers defining the Zmin and Zmax will appear on

the image’s histogram (see Figure 5-49).

Figure 5-48.  The Image Area.

Figure 5-49.  Zmin and Zmax markers on the histogram.

This function can be used to target the Common Color Bar adjustments to the Z range of

particular features of interest on the images.

Apply displays the images with the currently selected parameters.  The Default button

operates in the same manner as the Basic Common Color Bar Control Panel.  Revert

returns to the original image Z range-versus-color bar values.  The Basic button returns

you to the Basic Control Panel.  Figure 5-50 shows two topographic scans (initially with

different Z ranges) with a common color bar applied and with both distributions averaged

at a null Z offset, using the advanced common color bar function.
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Figure 5-50.  Advanced common color bar applied to two scans.
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Image Processing

Leveling

Leveling is the process by which you can automatically or manually define a level plane

for the display of your data.  Because most modes of scanning probe microscopy describe

topography on a scale which is the absolute Z height from some “zero” point, the relative

Z value assigned to surface measurement points are directly affected by how level the

sample is.  To actually mount a sample perfectly level is usually not a realistic goal

because of the extremely small scale involved in SPM (1 µm or less).  But with the

leveling process, you can use the software to compensate for sample tilt, allowing

accurate measurement of Z height across a sample without adding any erroneous tilt

information to the data.

Figure 5-51.  Software leveling.

In some scans, the Z range of the sample tilt may be close to or greater than the Z range of

the topography of interest, as in Figure 5-51.  When this is the case, the color scale will be

distributed primarily across the Z height of the tilt, leaving relatively little to resolve the

topographic features on the surface.  Note the effects of leveling in Figure 5-52:  the

elimination of sample tilt, the improved resolution of surface features, and the change in

the total Z range.

Figure 5-52.  Topographic scan before (left) and after (right) leveling.
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1st order leveling levels the scan to a plane, as illustrated in Figure 5-51.  Second or

higher order leveling corrects for curvature or bow in the sample by fitting the data to a

curve, as shown in Figure 5-53.

Figure 5-53.  Higher order leveling.

For many images, basic one-step leveling can be applied.  This process initiates a 1st

order leveling of the entire sample to one plane, using a least-squares algorithm to fit the

image to a plane and then subtracting the plane from the image.  The function is applied

by clicking on the Level button  on the tool bar.

A more advanced set of leveling options are accessed by selecting Process⇒ Leveling.

This opens the Leveling dialog box, shown in Figure 5-54, with a preview of the (pre-

leveled) image.

Auto Leveling

Selecting the Auto Leveling option enables leveling in one of four modes:  Horizontal,

Vertical, 2D, or 3 Point.

Each mode allows leveling based on calculations which handle progressively more

complex image curvatures and tilts.  The process will fit each line of the image to a curve.

This fitted line is then used to level the line in the image.  The following equations

represent the fitted lines, based on the selected order:

1st:  Z = ax +b

2nd:  Z = ax2 + bx + c

3rd:  Z = ax3 + bx2 + cx + d

4th:  Z = ax4 + bx3 + cx2 + dx + e

5th:  Z = ax5 + bx4 + cx3 + dx2 + ex + f

6th:  Z = ax6 + bx5 + cx4 + dx3 + ex2 + fx + g
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Figure 5-54.  The Leveling dialog box.

Horizontal applies the leveling function from the top down, based on the value selected in

the Order field.  1st- through 6th-order calculations are possible.

Vertical applies the leveling function from side-to-side, based on the value selected in the

Order field.  1st- through 6th-order calculations are possible.

2D (Plane leveling) levels the data in both the x and y directions.  1st- through 3rd-order

calculations are possible, based on the following calculations:

1st Order:  Z = ax + by + c

2nd Order:  Z = ax2 + by2 + cxy +dx + ey + f

3rd Order:  Z = ax3 + by3 + cx2y +dxy2 + exy + fx + gy + h

Note: 2D, 1st-order leveling is the same function applied when clicking the Level

button  on the tool bar.
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3 Point allows you to choose three points anywhere on the image which will designate the

plane to which the image will be leveled.  3 point leveling is especially good for leveling

images in which “steps” occur.  To use the function, click on the 3 Point button, then click

on the three points on the scan image (not the dialog box preview image) where you want

to define the level plane.  After clicking on the third point, the leveling will be applied.

Advanced Leveling

Advanced Leveling allows you to include or exclude a specified Z range for application

of the leveling operation.  The function also allows you to include or exclude one or more

regions within the image.  You can also use both methods together.  As you are defining

the area/Z range to be leveled, the selected portions of the scan will be highlighted in

green.  Clicking the Advanced Leveling option enables the controls in the Advanced

Leveling group, as shown in Figure 5-55.

Figure 5-55.  The Advanced Leveling group.

Specifying Leveling of a Z Range:

The Z range function allows you to specify what Z range within the image will be used for

the leveling calculations.  You can do this by either excluding a given range from the

calculation or by including a given range.  A certain amount of trial and error may be

necessary to define the appropriate range.

1. Select the Exclude Range or Include Range option.

2. Enter the minimum and maximum values of the range in the Threshold fields.

After selecting the inclusion or exclusion area/range, the area to be leveled will be

highlighted in green.  Make adjustments to the maximum and minimum threshold values

as needed.

Specifying Leveling of an Area:

Area leveling allows you to manually draw a box over any region(s) that you want

included or excluded from the leveling process.
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1. Select the Exclude Area or Include Area option.

2. Use the left-click-and-drag operation to draw a box (or boxes) on the scan image

(not the dialog box preview image).

3. Right-click to define the image.

Applying Advanced Leveling

Select from the Horizontal, Vertical, or 2D functions to apply leveling to the defined area.

Figure 5-56 illustrates selection of a Z range using advanced leveling functions.  Using

the range threshold and area defining options, the areas to be leveled are highlighted in

dark green; the areas that will be excluded from the leveling calculations are not

highlighted.

Figure 5-56.  Applying advanced leveling functions.

Background Subtraction

Background subtraction is a filtering process used to eliminate a sample’s background

features for image analysis.  The process applies an algorithm which simulates applying

an arc in the vertical or horizontal direction, or a ball in both directions, to the underside

of the image surface.  The algorithm subtracts out underlying features that are larger than

or equal to the user-defined arc/ball radius (see Figure 5-57).  By compensating for the

height data of the larger features, the process becomes a valuable tool for resolving finer

features on the sample surface.
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Figure 5-57.  Background subtraction.

Selecting Process⇒ Background opens the Background dialog box, shown in Figure 5-58.

Figure 5-58.  The Background dialog box.

User Settings

Radius sets the radius of the arc or ball that will be applied to the image.  The sensitivity

of the feature depends on the radius of the arc/ball being applied.  It is best to determine

the radius value based on the dominant features in your image.  A line analysis

(Analysis⇒ Line Analysis) can be useful in determining the size of larger features before

setting the radius.  It is important to remember that setting the radius at too small a value
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may have the unwanted effect of eliminating smaller features from your image.  The

default value is 10% of the image size.

Use Reduced Resolution measures fewer points on the image, shortening processing

time.

Display Background sets the algorithm to display the subtracted background instead of

the remaining features (after a roll function is applied).

Figure 5-59.  Image and line analysis before applying background subtraction.

Figure 5-60.  Image and line analysis after applying background subtraction.

Roll Arc Hori. applies the background subtraction algorithm in the horizontal direction.

Roll Arc Vert. applies the background subtraction algorithm in the vertical direction.
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Roll Ball applies the background subtraction algorithm in both the horizontal and vertical

directions.

Revert negates the most recent operation, restoring the image to its original state.

System Background

System Background subtraction calculates and eliminates anomalous instrument/scanner

curvature (also called “bow”) from image data.  Bow is introduced to an image because of

low-level X and Y scanner error, and is generally only a factor in extremely flat samples

with surface structures below 100 nm.  After applying the function, surface feature

analysis/measurement is possible assuming a totally flat sample.

The best method of determining if bow is a factor in an image is to perform a line scan

after leveling.  If an underlying curve is apparent in either the X or Y direction (as shown

in Figure 5-59), and it is significant enough to affect analysis of Z height information,

then application of the System Background function may be useful.  Generally, system

background subtraction is applied to scans using the full scanner XY range.

Figure 5-61 shows a line scan exhibiting scanner bow in the X direction before and after

applying System Background subtraction.

Figure 5-61.  Line scan before (left) and after (right) applying system background
subtraction.

Before applying system background subtraction, the image should be leveled with the

appropriate leveling function (see “Leveling” on page 5-45) to remove sample tilt.  With

the image to be processed already active, select Process⇒ System Background to open

the System Background Subtraction dialog box, shown in Figure 5-62.

To apply system background subtraction:

1. Click on the Create Coef. button to calculate the scanner bow coefficients for the

active image.

2. Click on the Remove Background button to subtract the calculated scanner bow

from the image.  The function will be applied to the image.
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3. Click on OK to accept.

The XY and Z units used in data acquisition are defaults but can be changed with the XY

Unit and Z Unit fields.

Figure 5-62.  The System Background Subtraction dialog box.

Click on the Save button if you want to save the calculated coefficients (a1-a6) so they

can be applied to other images.  Because some samples may have their own characteristic

curvature independent of surface features or scanner bow, system background subtraction

coefficients cannot be accurately calculated on this type of data.  The Save function is

used with an extremely flat sample, where there is a reasonable certainty that the only

bow associated with the image is scanner bow.  After saving, these coefficients will be

opened with the dialog box so they can be applied to images where sample bow is also a

factor.

The X Offset and Y Offset fields are used to compensate for any X and/or Y offset used if

the scale and zoom functions are used to define an area within the full scan range (in

either the data acquisition or image analysis module).  For example, if a 25 µm image is

the result of a zoom in data acquisition with a +10 µm X offset and a +10 µm Y offset

from center, then a further zoom was applied in image analysis with an additional offset

of +5 µm X and +5 µm Y, the values in the X Offset and Y Offset fields should be 15 µm

for accurate calculation of the coefficients.

After applying the Create Coefficients function, you can view the background data that

will be subtracted from the image by clicking on the Bkg Image button.  After applying
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the background image function, you can revert to the original scan data by clicking on the

Reverse button.

Convolution

The convolution function allows you to apply smoothing, sharpening, or other filtering to

the image.  The operation is calculated pixel-by-pixel from either a standard kernel, a

user-defined-kernel, or a kernel library.  (Note that edge pixels are modified in a slightly

different manner, due to the limited number of neighboring pixels.)

Select Process⇒ Convolution to open the Convolution dialog box, shown in Figure 5-63.

Figure 5-63.  The Convolution dialog box.

A kernel is a matrix of numbers that is used to modify the pixel in its center.  For

example, a 3x3 kernel for smoothing could be laid out as shown in Figure 5-64.  The

higher the value of X, the less smooth (more sharp) the image, i.e., the outer pixels will

have less influence on the center pixel, resulting in less smoothing.
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Figure 5-64.  3 x 3 kernel for smoothing.

The filtering is applied by mathematically modifying each pixel, using the surrounding

pixels as a basis for the application of a filtering matrix (kernel).  The following equation

is used for this process:
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Where:

Pn = New pixel value

m = the number of pixels in the selected matrix

Pi = pixel value at the ith position

Fi = filtering factor for the ith pixel, per the kernel

The kernel is defined using one of three options:

1. Selecting Sharpen or Smooth.

This applies a standard kernel of the selected matrix size (3x3, 5x5, or 7x7) with

values as follows:

Smoothing

All matrix values = 1

X = 3 for all three matrices

Sharpening

All matrix values = -1

3x3 matrix, X = 12

5x5 matrix, X = 28

7x7 matrix, X = 52
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2. Loading a kernel from the kernel library by selecting the Load function.  The

selected matrix will be displayed.  Click on Apply to use the selected kernel on

the image.

3. Creating a new kernel (or modifying an existing one) by editing each individual

displayed number.  This new kernel can be saved to the kernel library by

clicking on the Save button.  Click on Apply to use the custom kernel on the

image.

Selecting Revert opens the original image.

Selecting the Default function opens kernels (3x3, 5x5, or 7x7) that are smoothing

matrices based on the entered value of X.

Figure 5-65.  Topographic scan before (left) and after (right) applying the sharpening
convolution function.

Filter

The filtering operation allows you to filter the image pixel-by-pixel using a low, median,

or high filtering process.  The function is useful for reducing single-pixel noise or

improving feature resolution in some images.  Experimentation with application of

filtering is the best method of determining its potential value with any scan.  Select

Process⇒ Filter to open the Filter dialog box, shown in Figure 5-66.

The filtering process is calculated by replacing the center pixel in a square matrix (3x3,

5x5, or 7x7) with the low, median, or high Z value (depending on the selected filter) of all

of the pixels in the matrix.  This matrix-filtering process is repeated for every pixel in the

image.
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Figure 5-66.  The Filter dialog box.

- Selecting Low changes the value of X to the lowest value in the matrix.

- Selecting High changes the value of X to the highest value in the matrix (as

shown in Figure 5-67).

Figure 5-67.  High filtering function applied to a 3x3 matrix.

- Selecting Median changes the value of X to the median value in the matrix.

(This function is especially useful for removing single pixel noise.)

Figure 5-68.  Atomic resolution scan before (left) and after (right) filtering, using the 7x7,
high filter.
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Arithmetic

SPMLab’s arithmetic functions allow mathematical operations to be performed on an

image or pair of images.  The selected, displayed image is altered by using a second

image as a mathematical operand or by applying a specified equation and numeric value

to the selected image.  The function can be useful when data from two different scans can

be arithmetically manipulated to produce a third image with meaningful characteristics,

e.g., the addition or multiplication of sensor and topography images generated during the

same scan.  The function is also used to apply mathematical scale factors to an image.

Select Process⇒ Arithmetic to open the Arithmetic dialog box, shown in Figure 5-69.

Figure 5-69.  The Arithmetic dialog box.

Image 1, displayed in the top window, is the first operand.  The image window that is

currently active when Process⇒ Arithmetic is selected will be the first operand in this top

window.  This can be raw data or a new image that has resulted from a previous
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arithmetic operation.  The image file name is listed in the first drop-down list, which also

allows you to select another file name to change the first operand.

Image 2, displayed in the bottom window, is the second operand.  The image file name is

listed in the second drop-down list, which also allows you to select another file name or a

number as the second operand.  Selecting a number, instead of an image, as the 2nd

operand changes the Scale 2nd field to the Number field.  The possible equations are as

follows:

I1 (+, -, ×, ÷) I2 = New Image

I1 (+, -, ×, ÷)(I2 × I2 scale) = New Image

where I1 = Image 1, I2 = Image 2, and I2 scale = scale factor defined in the Scale 2nd

field.

For single-image equations when Number is selected as the 2nd operand:

I1 (+, -, ×, ÷) x = New Image

where I1 = Image 1 and x = value defined in the Number field.

Note: In order for the arithmetic operation between two images to be valid, Image 1

and Image 2 must be of the same scan resolution (e.g., 300 x 300).

To perform an arithmetic operation:

1. Use the 1st drop-down list to define the image file name for the 1st operand (1st

image window).

2. Use the 2nd drop-down list to define the image file name for the 2nd operand

(2nd image window), or to select the Number option, which allows you to define

a number as the 2nd operand.

If “Number” is selected as the second operand, define the value of the number in

the Number field.

3. Select the arithmetic function:  +, ×, -, or ÷.

4. Click on the  button to perform the operation.

The operation will be performed and the resultant image will be created with the

default file name, New Image.  This image replaces the 1st operand, without

altering the original file.  You can save the new image to any file name you

choose.
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Figure 5-70.  The Arithmetic dialog box controls.

Revert returns the image to its state before the operation was performed.  Invert creates a

new image that is the topographic inversion of the first operand image or the

arithmetically resultant new image, i.e., the color scale is inverted and the lowest point

becomes the highest point.  This is the same operation as multiplying the image by a value

of -1.

X

=

Sensor image Topographic image

Figure 5-71.  The arithmetic result of the multiplication of a sensor image and a topographic
image generated during the same scan.
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Figure 5-71 shows the arithmetic result of the multiplication of a sensor image and a

topographic image generated during the same scan.  Arithmetic operations between

images with different data units (nA and nm in this example) is possible due to an

automatically applied scale factor.

Scale & Zoom

The Scale & Zoom function provides an easy method of zooming in on any specific area

within a displayed image and then defining the image resolution of the new, enlarged

view.  Additionally, you can change the resolution of any selected image without applying

the zoom function, e.g., 300x300 to 500x500.  When you enlarge (or reduce) the

resolution of an image with this feature, the software extrapolates the data to create a new

image that actually has the defined number of data points.  This provides much better

resolution than simply dragging to enlarge an image window.

Select Process⇒ Scale & Zoom to open the Scale & Zoom dialog box, shown in Figure 5-

72.

Figure 5-72.  The Scale & Zoom dialog box.

IMPORTANT:  When using the Scale & Zoom function, remember to save the new

image to a new file name, or the original file will be overwritten.
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To zoom in on an area of the displayed top-view image:

1. Left-click, drag, and release to draw a box around the area you want to zoom in

on (within the main image window, not the dialog box preview image).  As you

draw, the box size is displayed in both distance and pixels.  Repeat the process to

redraw the box.  Move the cursor to reposition the box.

2. Right-click to set the target area.

3. Select a pixel resolution.

The zoomed image will be displayed in the main window with the original maintained in

the dialog box preview image, as shown in Figure 5-73.

Figure 5-73.  Zoomed image.

After zooming in, the full array of processing and data analysis tools can still be applied

to the new image.  Selecting Revert returns you to the original image.

To resize an image without using the zoom function, simply select Process⇒ Scale &

Zoom while the image is active, then click on the appropriate resolution button to scale

the image up or down.

Rotation

The Rotation function allows you to automatically rotate the displayed image in 90°
increments or to manually rotate the image.  Select Process⇒ Rotation to open the

Rotation dialog box, as shown in Figure 5-74.
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Figure 5-74.  The Rotation dialog box.

There are two rotation options available:

- Fixed Rotation allows reorientation in 90° increments, maintaining the same

overall image dimensions.  Click on the 90, 180, or 270 button for the

appropriate rotation.

- Free Rotation allows you to rotate in 1/10° increments or greater by entering a

number in the Angle field or by using the spinners.  A box will appear on the

main image window showing the new orientation.  Once the appropriate angle

has been set, click on the Rotate button.

Note: Free rotation occurs within the confines of the active window, meaning that any

values other than 90° increments will effectively zoom in as necessary to fill the

window, and, consequently, the total image area will be reduced.

Revert returns to the original image.

1D FFT—Fast Fourier Transform

The 1D FFT function allows the display of a Fast Fourier Transform power spectrum

derived from the selected image data.  The power spectrum can then be used for filtering

of the displayed image in the X or Y direction, independently, based on selected

frequencies.  Select Process⇒ 1D FFT to open the 1D FFT dialog box, as shown in

Figure 5-75.
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Figure 5-75.  The 1D FFT dialog box.

The power spectrum is derived by performing a Fast Fourier Transform on each line in

the selected direction (X or Y) and then normalizing the results of all of the lines.  It is

important to remember that the two axes are transformed entirely independent of each

other.

The default setting of the power spectrum display is a linear display.  However, the Scale

PS drop-down list allows you to select a logarithmic scale or any root between the two.

This can help to use as much of the display as possible for performing editing operations.

The value of any level on the power spectrum can be found by clicking and dragging

within the spectrum.  A line cursor will be opened and the values for the following

parameters will be displayed for the cursor position:

k = 1/(unit defined by scan size).  This represents the Wave Number.

r = the reciprocal of k

z = the % of the Power Spectrum.  The highest peak will be 100%.

Performing Inverse FFT Filtering

The inverse FFT function is used to filter unwanted frequencies (usually noise) in the

power spectrum, thereby improving the overall detail of the image.  To perform inverse

FFT filtering:

1. Select the transform direction from the Transform area (X or Y).
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2. Select the frequency or frequencies to be retained during filtering.

There are several methods that can be used in combination for the selection:

- The Threshold Selection tool, the yellow pointer on the vertical axis of

the Power Spectrum, can be used to select the point below which all

frequencies will be removed.  Click and drag this pointer to the desired

level.  The retained frequencies will be highlighted on the Power

Spectrum, as shown in Figure 5-76.

Figure 5-76.  The Threshold Selection tool.

- The Threshold field allows you to input a specific value, below which

all frequencies will be removed.  The retained frequencies will be

highlighted on the Power Spectrum.

- The Frequency Selection tool is used to isolate specific frequencies for

retention by clicking and dragging the yellow pointer in the horizontal

axis, as shown in Figure 5-77.  This can be repeated at different

frequencies.

Figure 5-77.  The Frequency Selection tool.

These tools can be used in combination.  The Undo Editing button can be

depressed repeatedly to remove these edits one at a time.  Restore PS

restores the original Power Spectrum for the currently selected axis.

3. After selecting the appropriate frequencies, click on the Inverse FFT button to

perform the filtering operation.
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To switch axes, select the alternate button in the Transform area, click on the FFT button

to obtain the power spectrum on the new axis, then use the methods described above to

select any frequencies for retention during an inverse FFT operation.

Figure 5-78.  Topographic atomic resolution scan before (left) and after (right) 1D FFT
inverse FFT filtering.

2D FFT—Fast-Fourier Transform

The 2D FFT function allows the display of a four-quadrant Fast Fourier Transform power

spectrum derived from the selected image data.  Unlike the 1D FFT function (described

above), the 2D FFT power spectrum displays the spectrum for both the X and Y axes

simultaneously.  The spectrum can then be used for filtering of the displayed image based

on selected frequencies.  2D FFT filtering is most often used to eliminate noise from

uniform pattern images, such as atomic resolution molecular structure images.

Additionally, the power spectrum can be used to identify feature parameters such as wave

number, theta, and % of power spectrum of a given point.

Select Process⇒ 2D FFT to open the 2D FFT dialog box, as shown in Figure 5-79.  The

function can also be accessed by clicking on the  button on the tool bar.

The displayed Power Spectrum is created by combining an FFT on both the X and Y

axes.  Each data point corresponds to a single frequency in one direction.  In the 2D FFT

power spectrum, the diagonal quadrants are “mirror images.”

The default setting for the Power Spectrum display is logarithmic.  The Scale PS control

allows you to change this to a linear scale or any root between the two.  This function

does not change the data, but it can help to display the most prominent features for

filtering operations.
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Figure 5-79.  The 2D FFT dialog box.

The value of any point on the power spectrum can be found by placing the cursor over the

spectrum and noting the values shown for the following parameters:

k = 1/(unit defined by scan size).  This represents the wave number.

r = the reciprocal of k.

z = the % of the Power Spectrum.  The highest peak will be 100%.

theta = the angle from the exact center point, which corresponds to the lowest

frequency.

Performing Inverse FFT Filtering

The inverse FFT function is used to filter unwanted frequencies (usually noise) in the

power spectrum, thereby improving the overall resolution of the image.  The function is

applied by using the tools in the 2D FFT dialog box to select the specific frequencies in

the 2D Spectrum that will be retained.

Figure 5-80 shows the effects of 2D FFT inverse FFT filtering.
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Figure 5-80.  Atomic resolution scans of graphite (above) and mica (below) before (left) and
after (right) 2D FFT inverse FFT filtering.

To perform inverse FFT filtering:

1. Select the frequency or frequencies to be retained during filtering.  There are two

primary options for selecting frequencies on the spectrum:

Threshold—The Threshold field allows you to input a specific value, below

which all frequencies will be removed.  The retained frequencies will be

highlighted on the power spectrum (as shown in Figure 5-81).

Figure 5-81.  The Threshold field.
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Edit tools—Specific frequencies on the spectrum can be highlighted by using

the Rectangle, Square, Ellipse, and Circle editing tools, as shown in Figure 5-82.

Figure 5-82.  Editing tools.

If the Centered option is not selected, the selected tool will draw the inclusion

area with a left-click-and-drag operation, and the corresponding area will also be

highlighted in the diagonally opposite quadrant.  If Centered is selected, the

selected tool will draw the inclusion area from the center of the image.  When

the appropriate area is highlighted, right-click to set the area.

If OR is selected, overlapping highlight areas will remain highlighted.  If XOR is

selected, overlapping highlight areas will not be highlighted.

The object of the selection process is to highlight only the areas on the spectrum

that represent your data, thereby eliminating all extraneous data and noise.  This

is often a trial and error process, involving repeated attempts at isolating the

valid data and repeating the Inverse FFT operation.

Figure 5-83.  Selecting an area.
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Undo Editing removes the highlighted areas, one at a time, in the reverse order

they were drawn.  Restore PS restores the original power spectrum.

The Threshold and Edit functions can also be used in combination.

2. After selecting the appropriate frequencies, click on the Inverse FFT button to

perform the filtering operation.

Image-Based Calibration

Scanner calibration is usually handled automatically with the system calibration

coefficients at the time of scanning.  But in some acquisition operations, such as zoom or

rotation, system calibration is automatically switched off by the software, and no

calibration coefficients are applied to the image.  In this situation, if the hardware

configuration does not use linearized scanners, the acquired images may be out of

calibration.  Under certain conditions, the SPMLab Image Analysis module does provide

an option for recalibration of image data after the scanning has already taken place.

These post-acquisition calibration options are accessed by selecting

Process⇒ Calibration⇒ Make Coefficients and Process⇒ Calibration⇒ Load

Coefficients.

To use these options, one important criterion must be met:  during the acquisition without

calibration (e.g., zoom and/or rotate), you must also acquire a scan of a standard

calibration grid, under the same non-calibrated conditions.  Save this uncalibrated grid

scan along with the rest of your data.  It will be used for the image-based calibration in

image analysis.

In Image Analysis, the Make Coefficients option allows you to survey the (non-

calibrated) grid scan, create corrected coefficients for linearity, X/Y calibration, and/or

Crosstalk, then apply those corrected coefficients to all the images acquired under the

non-calibrated conditions.  Using the Load Coefficients function, you can load a set of

coefficients you have previously saved and apply them to the other images.

Make Coefficients

The Make Coefficients function can be used to create corrected coefficients for linearity,

calibration range, and Crosstalk.  After you have loaded the non-calibrated grid scan in

Image Analysis, select Process⇒ Calibration⇒ Make Coefficients to open the Image

Calibration dialog box, shown in Figure 5-84.  Then you can proceed to the process of

creating coefficients.
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Figure 5-84.  The Image Calibration dialog box.

Linearity

The image can be considered nonlinear if the squares in the calibration grid are of varying

sizes, and the calibration survey routine calculates non-linearity values greater than

specified for your instrument.

Defining Features:  In order to define the criteria that will be used in surveying the

sample, you need to determine the method of feature edge detection:  by slope or by

threshold.

Edge Detection:  Slope vs. Threshold:  The image is examined by the system in order

to detect and analyze the structures (grid pattern) based on the edge-detection criteria you

define.  These criteria are set within one of the two Find Dot options:  By Slope or By

Threshold.  Selecting either of the two buttons displays a sub-panel with controls specific

to that mode.

Slope is the recommended detection method when the sample has very clear, well-defined

edges.  Also, this is the best method when the sample is not flat or cannot be leveled well.

Threshold is the recommended method when the standard sample has well-defined height

transitions along the feature edges.

By Slope detects the edges of the structures by calculating the slope and slope width.

When you select the option, the Boundary Thickness field appears on the panel, as shown
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in Figure 5-85.  Any slope that is narrower in width than the value in the field is defined

as an edge.

Figure 5-85.  By Slope:  the Boundary Thickness field.

The accuracy of the calibration process is dependent on the definition of the structures

that are detected in this step.  Structures that are well-defined and have clean, closed

boundaries will result in a more accurate calibration.

In the slope mode, only the boundaries of the detected structures are highlighted.  (The

highlight color is chosen in the Color Settings dialog box, accessed by selecting

Setup⇒ Screen Colors.)

Figure 5-86.  Slope edge-detection mode.
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The value in the Boundary Thickness field sets the thickness of the boundary lines drawn

around the structures.  The smaller the number, the thinner the boundary; the greater the

number, the thicker the boundary.  Adjust the value in the field until you get a closed

boundary around the feature.  The goal is to get as many adjacent and well-defined

periodic structures as possible, in both the horizontal and vertical directions.  Figure 5-86

shows structures surveyed using the slope edge-detection mode.  Note that the edges of

the structures are highlighted, a function of the Boundary Thickness setting.

By Threshold detects the structures by setting a Z threshold and analyzing structures

above or below this threshold.  When you select the option, the Z Level field and

threshold buttons appear on the panel, as shown in Figure 5-87.

Figure 5-87.  By Threshold:  the Threshold buttons.

The Z Level field defines the location of the horizontal threshold.  Click on the 

(Above Threshold) button to highlight and consider the data above the selected Z level in

the calibration.  Click on the  (Below Threshold) button to highlight and consider the

data below the selected Z level in the calibration.  The Above Threshold option is

typically used for structures with a positive Z height (columns, dots, or mesas).  The

Below Threshold option is typically used for depressed structures (holes or trenches).

Image Editing In order to get well-defined structures for the function, it may be necessary

to use the image editing tools.  The purpose is to obtain clear, uniform periodic structures

that can be accurately measured.  These editing tools are available from the drop-down

list containing the Draw tool.  They are used after edge detection has been performed, to

edit the highlighted portion of the features, so edge detection is more accurate.

Paint Line paints a missing line in the highlight color.

Paint Area paints an area in the highlight color.

Erase Line erases a line from the highlighted area.

Erase Area erases a defined area from the highlighted area.
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All the tools follow the convention of left-click, drag, and release to define the line/area.

Move the cursor to position the line/area, and right-click to apply the function and exit the

command.

Creating the Coefficients:

1. Depending on your criteria, click on the either the By Slope or By Threshold

radio button.  (See “Edge Detection:  Slope vs. Threshold” on page 5-71.)

2. To generate a set of linearity coefficients, click on the Linearity button.

The image will be surveyed and the features detected based on the edge

detection option you selected.  If the images are not properly detected, you may

need to perform some image editing (see above).

3. Select the Draw option from the drop-down list.

The cursor will change to a cross-hair as you move it over the main image.

4. Left click-and-drag to draw a line that includes a row of complete features.  After

releasing the mouse button, the line can be moved and repositioned.

a. Position the line over the row of features and right-click.  (Do not select

partial features, such as broken segments or features that are cut off by the

edge of the scan range.)

The selected features will be highlighted, as shown in Figure 5-88.  If you

make a mistake, click on the Undo button.

Figure 5-88.  Selecting features.
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b. Left click-and-drag to draw a line that includes a column of complete

features.  After releasing the mouse button, the line can be moved and

repositioned.

c. Position the line over the row of features and right-click.  (Do not select

partial features, such as broken segments or features that are cut off by the

edge of the scan range.)

The selected features will be highlighted.  If you make a mistake, click on

the Undo button.

The X and Y nonlinearity values will be calculated and displayed.

5. Click on the Apply button to apply the new linearity coefficients to the image.

The new coefficients are applied, and the image is recalibrated.  If the linearity

was visibly off, you should be able to see the improvement in the image, as

shown in Figure 5-89.  Repeating the linearity survey steps should show the

improved linearity values in the Nonlinearity field.  In some cases, repeating the

application of the new coefficients can show further improvement.

Figure 5-89.  Grid before (left) and after (right) applying corrected linearity coefficients.

6. Click on the Review button if you want to review the full set of linearity

parameters.

7. If you are satisfied with the linearity results, click on the Save button to save the

coefficients.  This file will be used with the Load Coefficients function to apply

to the rest of the images scanned with the same set-up.
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Scan Range/Feature Size

If the scan range or feature size on the grid scan are out of calibration, you can correct

one or both the parameters.

To Correct Scan Range:

1. Click on the Scan Range radio button.

The X and Y fields will be displayed on the panel.

2. Enter the correct values in the X and Y fields.

3. Click on the Calibrate button.

The new scan range coefficients will be displayed on the image.

4. Click on the Apply button to apply the new scan range coefficients to the image.

5. If you are satisfied with the results, click on the Save button to save the

coefficients.  This file will be used with the Load Coefficients function to apply

to the rest of the images scanned with the same set up.

To Correct Feature Size:

1. Depending on your criteria, click on the either the By Slope or By Threshold

radio button.  (See “Edge Detection:  Slope vs. Threshold” on page 5-71.)

2. Click on the Dot Size radio button.

The feature size field will be displayed on the panel.

3. Click on the Calibrate button.

The image will be surveyed and the features detected based on the edge

detection option you selected.  If the images are not properly detected, you may

need to perform some image editing.  See “Image Editing” on page 5-9.

4. Select the Draw option from the drop-down list.

The cursor will change to a cross-hair as you move it over the main image.

5. Left-click and drag to draw a line that includes a row of complete features.  After

releasing the mouse button, the line can be moved and repositioned.
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a. Position the line over the row of features and right-click.  (Do not select

partial features, such as broken segments or features that are cut off by the

edge of the scan range.)

The selected features will be highlighted.  If you make a mistake, click on

the Undo button.

b. Left-click and drag to draw a line that includes a column of complete

features.  After releasing the mouse button, the line can be moved and

repositioned.

c. Position the line over the row of features and right-click.  (Do not select

partial features, such as broken segments or features that are cut off by the

edge of the scan range.)

The selected features will be highlighted.  If you make a mistake, click on

the Undo button.

6. Enter the correct value in the feature size field.

7. Click on the Apply button to apply the new feature size coefficients to the image.

8. If you are satisfied with the results, click on the Save button to save the

coefficients.  This file will be used with the Load Coefficients function to apply

to the rest of the images scanned with the same set-up.

Crosstalk

Crosstalk is considered out of calibration when the vertical and horizontal rows of the

calibration grid are not exactly perpendicular.

1. To generate a set of Crosstalk coefficients, click on the Crosstalk button.

2. Select the Draw option from the drop-down list.

The cursor will change to a cross-hair as you move it over the main image.

3. Left-click and drag to draw a line that runs along the side of a row of complete

features.  After releasing the mouse button, the line can be moved and

repositioned.

a. Position the line along the row of features and right-click.

If you make a mistake, click on the Undo button.
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b. Left-click and drag to draw a line that runs along the side of a column of

complete features.  After releasing the mouse button, the line can be moved

and repositioned.

c. Position the line along the column of features and right-click.

If you make a mistake, click on the Undo button.

The Crosstalk coefficients will be calculated and displayed.

4. Click on the Apply button to apply the new Crosstalk coefficients to the image.

The new coefficients are applied, and the image is recalibrated.  If the Crosstalk

was visibly off, you should be able to see the improvement in the image.

5. Click on the Review button if you want to review the full set of linearity

parameters.

6. If you are satisfied with the Crosstalk results, click on the Save button to save the

coefficients.  This file will be used with the Load Coefficients function to apply

to the rest of the images scanned with the same set-up.

Load Coefficients

After making a new set of corrected coefficients for nonlinearity, Crosstalk, and/or scan

range and feature size, you are ready to load any of the coefficient files to the rest of the

images you scanned with the non-calibrated set up (see “Image-Based Calibration” on

page 5-70).

To load the coefficients file(s):

1. Open the image that needs the corrected coefficients.

2. Select Process⇒ Calibration⇒ Load Coefficients to open the Calibration

Parameters List dialog box, shown in Figure 5-90.

3. Select the appropriate coefficients file name.

4. Click on the OK button to load the coefficients and apply them to the current

image.

The current image will be calibrated to the corrected coefficients file selected with

the Load Coefficients function.
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Figure 5-90.  The Calibration Parameters List dialog box.
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Image Analysis

The image analysis features allow detailed quantitative examination of images.  Analysis

is performed in a variety of modes, including line (cross-sectional) profile, line and area

analysis (roughness, fractal, bearing ratio, PS density, etc.), particle analysis, grain

analysis, and critical dimensions.

Line Measure

The Line Measure function allows a cross-sectional measurement along a user-defined

line on the selected image.  X, Y, and Z data can be obtained for any position along the

line profile, as well as point-to-point distance and angle information.  To open the Line

Measurement dialog box, shown in Figure 5-91, select Analysis⇒ Line Measure or click

on the Line Measure button  on the tool bar.

Figure 5-91.  The Line Measurement dialog box.

The File Information area displays basic data about the scan image, including scan range,

Z max, Z min, and image resolution.

Clicking and dragging on the image preview window creates a line marker on the image

which can be dragged until the appropriate line is found.  To create a line profile, choose

one of the three Line Types:  Hori (horizontal), Vert (vertical), or Var (variable).  The

horizontal and vertical options determine the orientation of the line across the entire

image.  Selecting the variable option allows you to draw a line of any angle and length for
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profiling anywhere on the image.  The appropriate method for defining the line depends

on the type of line profile selected:

- For horizontal and vertical lines, place the cursor on the displayed image and

hold the left mouse button down.  The line number is displayed to the right.

Drag the line to the desired location and release.  The line profile is continuously

updated as you drag the cursor in the active image, allowing you to preview the

selected line.  Repeat to define up to three lines simultaneously.  Upon selecting

a fourth line, the first three will be erased.

- For variable lines, left-click and drag on the image, and draw a line of any angle

and length over the feature of interest.  The line profile is continuously updated

as you drag the cursor in the active image, allowing you to preview the selected

line.  Release the left mouse button and move the line marker to re-position the

line if necessary.  As you re-position the line, the line profile is continuously

updated.  Clicking the left mouse button again decreases the line length by 50%.

Clicking the right mouse button sets your selection.  Note that the angles

between consecutive variable lines are shown below the image.

The Line Width list box allows you to choose a thickness for the line you are drawing.

By using thicker lines, you can smooth out the noise by getting a better signal-to-noise

ratio.  At each point along the line, the average value of that cross-section is taken, giving

a better overall average.  Using thicker lines can be useful in situations such as measuring

the width of a trench.

Point 1

Point 2

Figure 5-92.  Line profile analysis.
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To perform line analysis functions on the profile, click on the line profile window.  The

cursor will become a vertical line marker.  Move to the first measurement point and click

the left mouse button to select it, then repeat the process for the second measurement

point.  Note that the actual point along the line is shown as an “X” marker on the preview

image.  Right-click to exit the line profile window.  The following information is

displayed for each analysis on a line profile (see Figure 5-92):

X, Y, and Z locations for both points.

The difference in X, Y, and Z between the two points.

The line length between the two points.

The angle of the slope between the two points.

Peak and Valley Analysis

Peak and valley analysis is a measurement technique for analyzing roughness by defining

the lateral spacing and the angle (slope) of features.  As opposed to other analysis

techniques that focus primarily on the Z height component of the sample topography,

peak and valley analysis allows roughness analysis based on peak density (lateral spacing)

and on peak slope.  Lateral spacing, peak angle, and roughness are critical parameters in

the study of surface wear and surface/light interaction.

The function analyzes peaks in the image along user-defined cross-sectional lines.  Peak

spacing is defined as the distance between neighboring peaks.  Peak angle is defined as

the slope between a peak and its nearest valley.  Separate histograms for peak spacing and

peak angle are displayed.  The histogram distribution is user-definable via the minimum

and maximum spinners directly below each histogram.  The mean value of the peak

spacing and peak angle are also displayed.

Select Analysis⇒ Peak/Valley Measure to open the Peak/Valley Measurement dialog

box, shown in Figure 5-93.

User Settings

Line Orientation selects a 0° or 90° line orientation for the peak analysis (0° =

horizontal, 90° = vertical).  Alternatively, you can left-click and drag to draw a line across

the image, then right-click to define the orientation of the line analysis.

Line Interval selects the line interval for the peak analysis.  For example, a setting of 10

would use every 10th line for the analysis.

Peak Height defines the minimum peak height that will be included in the analysis (both

line profile and histogram).  Peak height is the distance from a peak to its nearest valley.

All peaks with a height greater than this value will be included.  This value is normally set
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just high enough to reject noise.  Peaks excluded with this variable will still be displayed

on the line profile.

Figure 5-93.  The Peak/Valley Measurement dialog box.

Peak Spacing defines which features will be considered single peaks in the analysis.  The

value sets the minimum spacing allowable between two adjacent peaks before the

software will determine the feature to be a single peak.  All peaks with a spacing greater

than this value will be considered separate.  This value is normally set just high enough to

reject noise.  Peaks excluded with this variable will still be displayed on the line profile.

Number of Bins adjusts the number of histogram distribution bins for both peak spacing

and peak angle.  Assigning a large number of bins increases precision, but it also

increases the software’s processing time.

Show Lines  Clicking the Show Lines... button opens the Line Profile window, shown in

Figure 5-94, which displays a cross-sectional line profile of the sample based on the value

entered in the Line Number field.  Peaks and valleys that fall within the user-defined

parameters are marked with green and yellow markers, respectively.
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Peak
Spacing

Peak
Height

Peak

Valley

Figure 5-94.  The Line Profile window.

The line is oriented across the sample based on the value entered in the Line Orientation

field of the Peak/Valley dialog box.  By changing the value in the Line Number field, you

can review any line in the sample (as long as it is divisible by the preset line interval).

The line being analyzed will be marked on the preview image in the dialog box.

Peaks that fall within the peak height and peak spacing criteria will be marked (and used

in the analysis).  You can change peak height and peak spacing in the main dialog box to

adjust the peaks that will be analyzed in the Line Profile dialog box.

Left-click in the line profile area to open a line marker that will indicate the Z height of

any point on the line and will allow you to calculate the distance between individual peaks

and/or valleys.  Right-click to exit the line marker function.

Show Data

Clicking on the Show Data… button opens the Report of Peak and Angle dialog box, as

shown in Figure 5-95, allowing you to review the data for each line.

The data includes peak spacing (as shown in Figure 5-94) and left and right angle (angle

from the peak to its nearest left or right valley, as shown in Figure 5-96).

You can review any line in the analysis data (as long as it is divisible by the preset line

interval) by entering the value in the Line Number field.  Clicking on the Save Report…

button opens the Export dialog box, allowing you to save the data in the appropriate

format.
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Figure 5-95.  The Report of Peak and Angle dialog box.

 
Peak 

Valley 

Valley 

Left Angle 

Right Angle 

Figure 5-96.  Left angle and right angle.

Apply allows you to apply changes in the Line Orientation field.
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Line Analysis

This analysis package provides a variety of tools for measuring the characteristics of user-

selected line profiles on the active image.  Select Analysis⇒ Line Analysis to open the

Line Analysis dialog box, shown in Figure 5-97.

Figure 5-97.  The Line Analysis dialog box.

Setup Variables

Initially, the Setup window is used to define all the necessary line parameters for the

various types of line analyses.

Line Length

The default line length value for line profiles, shown in the Line Length field, is the full

length of the image.  This can be changed to any value less than the default length.

Line Type

The Line Type field is used to define Hori (horizontal), Vert (vertical), or Var (variable)

line profiles.  Selecting the line type will automatically determine the respective direction

of lines 1, 2, and 3, as they are placed.
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- Horizontal and vertical lines are selected by selecting the appropriate button in

the field and single-clicking on the image or clicking and dragging to a specified

line on the image.

- Variable lines are drawn by clicking and dragging.  When the left mouse button

is released, the variable line can be moved and then is set in place by a single

right-click of the mouse button.

Line Edit

The actual line location within the image is defined in the Line Edit field and can be

changed by typing in a value corresponding to the desired line location, then pressing the

Enter key on your keyboard.  Clicking on the Undo button in this field clears all placed

lines.

Axes Units

The XY Axis Unit field defines the units of measurements in the lateral directions for all

analysis functions.  The Z Axis Unit field defines the unit of measurements in the Z

direction for all analysis functions.  Values are automatically converted.

Line Width

The Line Width list box allows you to choose a thickness for the line you are drawing.

By using thicker lines, you can smooth out the noise by getting a better signal-to-noise

ratio.  At each point along the line, the average value of that cross-section is taken, giving

a better overall average.  Using thicker lines can be useful in situations such as measuring

the width of a trench.

Z Scaling

Z scaling for all the analysis functions is defined in the Set Z Scaling field in one of three

modes:

- by Z range of whole image:  the Z scales of all three lines will be determined by

the overall Z range of the image.

- by Z range of each line:  each line profile will be scaled to its own Z range.

- by user’s Z range:  the Z range for the line analyses can be set by clicking on this

button and setting the lower and upper values in the fields directly below.  The

default values represents the overall image Z range.
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Line Analysis Report

After defining the analysis line(s) and parameters, click on the Analyze button to perform

the initial analysis.  The Line Analysis Report window opens, as shown in Figure 5-98.

Figure 5-98.  The Line Analysis Report window.

This window is the workspace for analyzing your line profiles.  The profiles for each line

are displayed on the left of the screen, with the active profile having a thicker border.

Any profile can be made active simply by clicking on it.  Note that standard roughness

calculations are already supplied when the report window comes up.  From this screen,

you will choose which of the other analysis functions to apply to any or all of the line

profiles.  Click on the Setup Screen button if you need to return to the initial setup screen

to change any setup parameters.

You can display the original image and the selected lines at any time by clicking on the

Image On button to open an image window that can be resized as necessary.  When the

image is opened, the button changes to Image Off and is used to close the image.

To enter the appropriate analysis window and perform the calculations on any line, click

to select a line profile, then click on either the Height, Fractal, or Bearing Ratio button.

Each of these analysis windows is described in the following sections.  You can make

your display selection at the bottom left of the screen.  After any of the other analysis

functions have been applied to a line profile, any two of the four data types (Standard
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Roughness, Height, Bearing Ratio, or Fractal) can be displayed in the report screen by

clicking on the appropriate boxes.

Standard Roughness Analysis

When you enter the Line Analysis Setup window, standard roughness measurements are

calculated and displayed by default, as shown in Figure 5-99.

Figure 5-99.  Standard Roughness measurements.

Ra—Roughness average:  the arithmetic average of the absolute values of the measured

profile height deviations:
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In the ThermoMicroscopes algorithms for line profile measurements of this type, Y is 20,

which takes into account the 20 highest features in the profile.
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Height Analysis

To perform a height analysis, click on a line profile in the Line Analysis Report window,

and then click on the Height button.  The Height Measurement window opens, as shown

in Figure 5-100.

Figure 5-100.  The Height Measurement window.

The image and line profile are displayed.  To measure the difference in height between

any two points:

1. Left-click on the line profile to activate the line cursor.

2. Position the cursor to the first measurement point on the line profile.  While you

are moving the line cursor, you can monitor the distance from zero in the X

direction (Distance) and the Z level at the point where the cursor intersects the

line profile (Height).

3. Left-click to set the first point in the pair.

4. Position the line cursor for the second point.  While you are moving the line

cursor, you can monitor the difference in distance from the first point (Diff. in

Distance) and the difference in Z level from the first point (Diff. in Height).

5. Left-click again to set the second point of the pair.  The statistics for the pair will

be displayed in the Report field.
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6. Right-click to exit the point-selection function, or repeat the process to define

more pairs of measurement points.  Each pair of measurement points is displayed

in a different color.

Up to six sets of point can be selected for comparison.

The measurement points will also be displayed on the line on the Image field.  Click,

drag, and release on the Image field to clear all measurement points and reposition the

line for another profile/height analysis.

To erase and reset one data pair, highlight that data row in the Report field, then click on

the Undo button.  You can then reposition those two data points on the line profile.  To

erase all data points and start over, click on the Clear button.

Click on Report Screen to return to the Line Analysis Report Window, where the new

height data will be added to the display selection.  Click on the Setup Screen button to

return to the Line Analysis Setup Window and reselect the line profiles.

Fractal Analysis

To perform a fractal analysis, click on a line profile in the Line Analysis Report window,

then click on the Fractal button.  The Fractal Analysis window is opened, as shown in

Figure 5-101, displaying the line profile, image, and a fractal graph of box count vs.

feature size.

Figure 5-101.  The Fractal Analysis window.
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1. Left-click on the fractal graph to activate the line cursor.

2. Position the cursor to the first measurement point on the graph.  While you are

moving the line cursor, you can monitor the corresponding Z level on the line

profile.

3. Left-click to set the first point in the pair.

4. Position the line cursor for the second point.  While you are moving the line

cursor, you can monitor the corresponding Z level on the line profile.

5. Left-click again to set the second point of the pair.  The statistics for the first pair

will be displayed in the Report field.

6. Right-click to exit the point-selection function or repeat the process to define

more measurement points.

Up to six sets of points can be selected for comparison.

Click, drag, and release on the Image field to clear all measurement points and reposition

the line for another profile/fractal analysis.

To erase and reset one data pair, highlight that data row in the Report field, then click on

the Undo button.  You can then reposition those two data points on the line profile.  To

erase all data points and start over, click on the Clear button.

Click on Report Screen to return to the Line Analysis Report Window, where the new

fractal data will be added to the display selection.  Click on the Setup Screen button to

return to the Line Analysis Setup Window, and reselect the line profiles.

The fractal algorithm used in this function is based on Stephan Chesters' paper, “A

Fractal-Based Method for Describing Surface Texture” (Solid State Technology, January

1991).

The roughness profile is analyzed in terms of a “roughness spectrum,” which gives the

fractal dimension as a function of feature size.  This method overlays the profile with a

uniform grid or a set of “boxes” of height b.  A count is made of the “non-empty” boxes

(N) for which any portion of the profile falls within the box.  Then the box size is divided

in half and the count is repeated.  The box dividing process continues until the box size is

very close to the pixel size.  Then the count vs. box size is plotted on a log scale.  Slope

of this plot represents the Fractal Dimension value, Rf.

N ∝ b-Rf
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Bearing Ratio Analysis

To perform a bearing ratio analysis, click on a line profile in the Line Analysis Report

window, then click on the Bearing Ratio button.  The Bearing Ratio window opens, as

shown in Figure 5-102.

Figure 5-102.  The Bearing Ratio window.

The line profile, image, and a graph of bearing ratio vs. Z level is displayed.

1. Left-click on the bearing ratio graph to activate the line cursor, then position the

cursor at the first measurement point on the graph.  While you are moving the

line cursor, you can monitor the corresponding Z level on the line profile.

2. Left-click again to set the first point.  The bearing ratio (the percentage of total

data appearing above the selected Z level) for the point is displayed in the

Report field, along with the corresponding Z level.  Left-click again to define

more measurement points (up to six).

Right-click to exit the point-selection function.

Click, drag, and release on the Image field to clear all measurement points and reposition

the line for another profile/bearing ratio analysis.  To erase and reset one data point,

highlight that data row in the Report field, then click on the Undo button.  You can then

reposition that data point on the line profile.  To erase all data points and start over, click

on the Clear button.
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Click on Report Screen to return to the Line Analysis Report window, where the new

bearing ratio will be added to the display selection.  Click on the Setup Screen button to

return to the Line Analysis Setup window and reselect the line profiles.  Bearing ratio is

the length of bearing surface (expressed as a percentage of the length):

( )
data total of #

100% level  Zthe above data of #
ratio bearing =

Area Analysis

The Area Analysis functions allow various surface analysis functions to be applied to the

image on the basis of the entire area or a user-defined area of a scan.  The area analysis

functions available are roughness, measurement (square unit surface area), fractal, bearing

ratio, and power spectral density.  These features are accessed by selecting

Analysis⇒ Area Analysis, then the appropriate function.

Roughness

With an image active, select Analysis⇒ Area Analysis⇒ Roughness to open the Area

Standard Roughness dialog box, as shown in Figure 5-103.

Figure 5-103.  The Area Standard Roughness dialog box.

Values for Ra, RMS, average height, and maximum range are automatically calculated

and displayed in the Whole Image area.



Image Analysis 5-95

Values can be calculated for Ra, RMS, average height, and maximum height including or

excluding a user-defined area.  These values are displayed in the Partial Image area.

To define a rectangular bounding box for inclusion or exclusion from the roughness

calculations:

1. Click, drag, and release on the image to define the bounding box.  You can move

the defined box to adjust its placement or click and drag again to redraw it.

2. Right-click to set the partial image area.

3. Select Include Area to calculate the values within the rectangle, or select

Exclude Area to calculate the values exclusively outside of the bounding box.

Multiple areas can be defined for inclusion or exclusion.

4. Click on the Apply button to perform the partial image calculations.

Clicking on the Clear button or redrawing the rectangle on the image clears all partial

image calculated values.

Area Ra—average roughness:  the arithmetic mean of the deviations in height from the

image (or partial image) mean value:
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Area RMS—root-mean-square roughness:  value is defined as the square root of the mean

value of the squares of the distance of the points from the image mean value:

∑
=

−=
N

i
ims ZZ

N
R

1

21

Avg Height:  an arithmetic mean defined as the sum of all height values divided by the

number of data points:
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Max Range (Zmax):  Maximum peak-to-valley range in the area.
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Measurement

With an image active, select Analysis⇒ Area Analysis⇒ Measurement to open the Area

Measurement dialog box, as shown in Figure 5-104.

Values for the projected area and the surface area are automatically calculated and

displayed in the Whole Area field.  Projected Area is defined as the X scan range

multiplied by the Y scan range (150 µm * 150 µm, in the scan illustrated in Figure 5-

104).  Surface Area is the calculated area including X, Y, and Z data (i.e., height

information is included in the calculation).

Figure 5-104.  The Area Measurement dialog box.

Projected area and surface area values can be calculated including or excluding a user-

defined area and areas.  These values are displayed in the Partial Area field.

To define a rectangular bounding box for inclusion or exclusion from the area

calculations:

1. Click, drag, and release on the image to define the bounding box.  You can move

the defined box to adjust its placement or click and drag again to redraw it.

2. Right-click to set the partial image area.
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3. Select Include Area to calculate the values within the rectangle, or select

Exclude Area to calculate the values exclusively outside of the bounding box.

4. Click on the Apply button to perform the partial image calculations.

Clicking on the Clear button or redrawing the rectangle on the image clears all partial

image calculated values.

The value is calculated using every four adjacent pixels of the measurement area from an

arbitrary prism in space, given the difference in height represented by each pixel.  Let Z1,

Z2, Z3, and Z4 represent the four height values for the four pixels.  These four Z values

make a rectangle in space.  The surface area is then computed and summed up over the

whole measurement area to result in the total area value.

The surface area of the rectangle described above is computed by dissecting the rectangle

into triangles and then computing the area for each triangle.  Let a, b, and c denote the

lengths of the sides of the triangle, computed as follows:

( ) ( )2
12

2 Zxa ∆+∆= where Z12 = Z1 - Z2

( ) ( )2
24

2 Zyb ∆+∆= where Z24 = Z2 - Z4

( ) ( )2
14

2 Zzc ∆+∆= where Z14 = Z1 - Z4

Now the surface area of a single triangle is computed as:

( )( )( )cpbpappS −−−= where p = ½ (a+b+c)

Now the same calculation is applied to compute the surface area of the second triangle.

The above processes are reiterated over the whole measurement area to compute the total

surface area.

Fractal

With an image active, select Analysis⇒ Area Analysis⇒ Fractal to open the 2D Fractal

Analysis dialog box, as shown in Figure 5-105.



5-98 Image Display, Processing, and Analysis

Figure 5-105.  The 2D Fractal Analysis dialog box.

Lake/Threshold Calculations

The maximum Z height for the image is automatically displayed in the Z

Threshold/Maximum Z area, with the default threshold set at 50% of that level.  To

change the Z threshold, enter a new value in the field.

Lakes will be calculated and plotted above the Z threshold level if the  button is

selected.  Lakes will be calculated and plotted below the Z threshold level if the 

button is selected.

To select the default value for the smallest lake area to be included in the calculation,

select Default.  To define the smallest lake area to be included in the calculation, select

Custom, and enter the value in the adjacent field.

In the Lake Search area, click on the Find Lakes button to plot and calculate the lakes as

defined.  The results will be displayed in the Number of Lakes and Total

Perimeters/Areas fields.

Fractal Analysis

After performing the lakes calculations, click on the Fractal Analysis button to plot the

Log (10) Perimeter vs. Log (10) Area and the Fractal Dimension value, as shown in

Figure 5-106.
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Figure 5-106.  Log (10) Perimeter vs. Log (10) Area and the Fractal Dimension value.

Click on the Undo button to reset the analysis parameters.

The algorithm used for 2D fractal area analysis is based on J.M. Gomez- Rodriguez’

“Fractal Characterization of Gold Deposits by Scanning Tunneling Microscopy,” (Vac.

Sci. Technol. B, Vol. 9, No. 2, Mar/Apr 1991).  The method used is called the “Lake

Pattern,” since the analysis is based on lake patterns recognized on a Z plane intersecting

the image.  The relationship between two variables of each lake—the perimeter (L) vs.

area (A)—is evaluated.  The fractal dimension will be defined as (D):

L = α D' AD’/2

D = D' + 1

Where α is a constant, and D' is the fractal dimension of the lakes' coastlines.  The fractal

dimension of the three-dimensional surface (D) can be calculated from a log L vs. log A

plot.

Bearing Ratio

With an image active, select Analysis⇒ Area Analysis⇒ Bearing Ratio to open the

Bearing Ratio dialog box, as shown in Figure 5-107.
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Figure 5-107.  The Bearing Ratio dialog box.

A plot of the Bearing Ratio (the percentage of total data appearing above the selected Z

level) is displayed along with the image.

To define bearing ratio points along the graph:

1. Left-click on the bearing ratio graph to activate the line cursor.

2. Position the cursor to the point on the graph where you want to calculate bearing

ratio.  As you move the cursor, you can track the curve’s corresponding Z height

and bearing ratio with the values below the graph.

3. Left-click again to define the point.  The bearing ratio at that point will be

displayed in the Z Level/Bearing Ratio table, and the scan area above that Z

level will be highlighted on the image.

Up to nine points can be defined.  The scan area above the highest Z level of the

points will be highlighted.

4. Right-click to exit the function.

Click on the Undo button to clear the graph and reset the bearing ratio points.
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2D bearing ratio is a measure of the relative size of the bearing surface.  The bearing

surface is the maximum surface area that is exposed above a certain Z plane:

( )
data total of #

100 level  Zthe above data of #
ratio bearing =

PS Density

With an image active, select Analysis⇒ Area Analysis⇒ PS Density to open the PS

Density dialog box, as shown in Figure 5-108.

Figure 5-108.  The PS Density dialog box.

The displayed power spectrum is derived by performing a fast Fourier transform in the X

or Y direction.  The calculation is automatically performed and the spectrum displayed

for the X direction when the PS Density function is initially accessed (therefore the FFT

button is disabled).  To calculate a new Spectrum for Y, select Y Direction in the

Transform area, then click on the FFT button.  The PSD function is defined as the square

magnitude of the Fourier transform of the surface profile and offers both the amplitude of

the surface features and spatial frequency information.  The graph displayed is a

logarithmic scale.

Note: The X and Y axes are transformed totally independent of each other.

To obtain the value between any two points on the power spectrum:

1. Left-click anywhere on the graph.  The line cursor will be opened.

2. Move the cursor to the first point you want to define on the power spectrum, and

left-click again.  The first marker in the first pair of points will be set.
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3. Move the cursor to the second point you want to define on the power spectrum,

and left-click again.  The second marker in the first pair of points will be set.

The RMS [Å] and frequency values for the point set will be displayed in the

RMS Measurements table.

4. Repeat the process to define more pairs of points, or right-click to exit the point-

selection function.

As you move the cursor along the spectrum, you can note the values for the following

parameters:

k = 1/(unit defined by scan size).  This represents the wave number.

r = the reciprocal of k.

z = the absolute height value.

When selecting the second of two points, you can also observe the RMS value over the

frequency range between the first point and the cursor.  After selecting the second point,

the RMS value for the pair is displayed in the table.  This is particularly helpful in

studying repeatable features and correlating SPM data with optical techniques.
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Particle Analysis

The particle analysis function, which can be purchased as an option, allows you to

characterize particle parameters by overall volume, particle count, and individual particle

characteristics (area, perimeter, average height, etc.).  Graphs for particle volume, area,

perimeter, and lateral spacing can also be generated and analyzed.  With an image active,

select Analysis⇒ Particle Analysis to open the Particle Analysis dialog box, as shown in

Figure 5-109.

Figure 5-109.  The Particle Analysis dialog box.

Particle Recognition

Of the several functions available within this feature, the first that needs to be

accomplished is particle recognition and calculation.  To define the particles in the image,

you need to define the Z threshold (range) and smallest particle size that will be counted

in the analysis.

Threshold

The Z threshold can be defined with the Threshold limit fields or by clicking and

dragging on the image color bar.  With either method, as you define the upper and lower

Z limits, the selected data range will be highlighted on the color bar and on the

corresponding data in the image.  The total Z range of the scan is displayed at the top of

the Threshold area, as shown in Figure 5-110.

Once the threshold is defined, dragging the highlighted range on the color bar allows you

to move the selected range through the data Z range, monitoring the corresponding

change in highlighted data on the image.  You can also grab the upper or lower boundary

of the highlighted portion of the range to expand or contract it.
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Figure 5-110.  Threshold defined and data range highlighted.
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Figure 5-111.  Moving the selected range through the data Z range.

Minimum Particle Size

Once the threshold has been established, the minimum particle size can be specified in the

Smallest Particle field.  A Default value is calculated, or you can define a value in the

Custom field.  Particles smaller than this value will not be counted in the analysis.
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Finding Particles

To find the total number of particles (that fall within the previously defined parameters) in

the entire image, click on the Whole Image button.

To find the total number of particles within a defined rectangle, click on the Partial Image

button, left-click and drag to draw a bounding box that encompasses the area on the image

that you want to analyze, then right-click to set the bounding box and perform the

calculation.

As the calculation is performed, a black border will be drawn around each of the particles

that fall within the defined parameters.  The global particle information and histogram

will appear in the dialog box, as shown in Figure 5-112.

Figure 5-112.  Global particle information and histogram.

The value set in the Number of Bins field sets the resolution of the Volume Histogram,

i.e., the number of “bins,” or categories used to define the different levels of particle

volume.  The best resolution is achieved when the bin value is closer to the number of

particles counted (displayed in the Particles Found field).  Changes in the number of bins

are reflected in the Volume Histogram immediately.

Click on the Enlarge Image button to bring up a top-view of the displayed image at its

original resolution (which can be resized).  Click on the Image Off button to remove the

enlarged image.

Click on the Undo button to reverse the particle detection routine and reset the

parameters.
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Single Particle Analysis

To determine the characteristics of a single particle, click on a particle on the image (after

the Find Particles function has been applied).  The particle will be highlighted in yellow,

and the volume, area, perimeter, and height information will be displayed in the Single

Particle Info area, as shown in Figure 5-113.

Figure 5-113.  Single Particle Info area.

Lateral Spacing

After performing the Find Particles operation, you can access spacing information on the

selected area by clicking on the Lateral Spacing button, which opens the Lateral Spacing

Information window, shown in Figure 5-114.  Average, minimum, and maximum lateral

spacing data will be displayed.

Figure 5-114.  Lateral Spacing Information window.
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Select the Centers option to measure lateral particle spacing from center-to-center, or

select Edges to measures lateral particle spacing from the nearest edges.  Increasing the

bins in the Bin Number field will increase the displayed histogram resolution.

Image Survey

After performing the Find Particles operation, click on the Survey On button to open the

Whole Image Survey window, shown in Figure 5-115, and perform an image survey.  The

function calculates and charts Volume vs. Z, Area vs. Z, and Perimeter vs. Z.

Figure 5-115.  Whole Image Survey window.

Values along any of the graphs can be determined by left-clicking on the graph.  A line

cursor will be opened, which can be moved along the graph, and the values for Z level,

Volume, Area, and Perimeter will be displayed in the left portion of the Whole Image

Survey window.  Right-click to exit the line cursor function on the graph.

If you want the calculations to reflect values above the Z level defined with the line

cursor, click on the  button.

If you want the calculations to reflect values below the Z level defined with the line

cursor, click on the  button.

A particle is defined as a surface entity which is completely separated spatially as an

individual unit.

Grain Analysis

The grain analysis function, which can be purchased as an option, allows you to

characterize grain parameters by overall volume, area, grain count, and individual grain

characteristics (area, perimeter, average height, volume, etc.).  With an image that

exhibits grain characteristics active, select Analysis⇒ Grain Analysis to open the Grain

Analysis dialog box, as shown in Figure 5-116.
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Figure 5-116.  The Grain Analysis dialog box.

The grain analysis function is used for finding and analyzing grains on grainy surfaces.

By definition, the neighboring grains can have common boundaries.  Hence, grain

analysis should be used when the surface elements being sought are likely to have

common boundaries.

Grain Recognition

Of the several functions available within this feature, the first that needs to be

accomplished is grain recognition and calculation.  To define the grains in the image, you

need to determine if you want to define grains by slope or by Z threshold.  Selecting the

By Slope option in the Grain Definition field will detect grains based on the slope of the

feature.  Selecting the By Z Threshold option will detect grains based on the specified Z

threshold (range).

By Slope

When defining grains by slope, you have the option of selecting the degree of smoothing

that will be applied in the grain definition process.  A higher value specified in the

Smooth field will enable a higher level of smoothing, which will reduce the effect of data

glitches, noise, and small features when finding grains.  The appropriate degree of

smoothing used with the slope detection method is best determined by experimentation

with each image.

By Z Threshold

The Z threshold can be defined with the Threshold limit fields or by clicking and

dragging on the image color bar.  With either method, as you define the upper and lower
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limits, the selected data range will be highlighted on the color bar and on the

corresponding data in the image.  The total Z range of the scan is displayed at the top of

the Threshold area.

High-
lighted

Z Range

High-
lighted

Z Range

Figure 5-117.  Threshold defined and data range highlighted.

Once the threshold is defined, dragging the highlighted range on the color bar allows you

to move the selected range through the data Z range, monitoring the corresponding

change in highlighted data on the image.  You can also grab the upper or lower boundary

of the highlighted portion of the range to expand or contract it.

Minimum Grain Size

Once the grain selection method (and threshold level, if applicable) has been established,

the minimum grain size can be specified in the Smallest Particle field.  A Default value is

calculated, or you can define a value in the Custom field.  Grains smaller than this value

will not be counted in the analysis.

Finding Grains

To find the total number of grains (that fall within the previously defined parameters) in

the entire image, click on the Whole Image button.
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To find the total number of grains within a defined rectangle, click on the Partial Image

button, left-click and drag to draw a bounding box that encompasses the area on the image

that you want to analyze, then right-click to set the bounding box and perform the

calculation.

With either method, you can exclude grains on the border of the image area from analysis

by clicking on the Exclude Boundary Grains option.

As the calculation is performed, a black border will be drawn around each of the grains

that fall within the defined parameters.  The global grain information and histogram will

appear in the dialog box, as shown in Figure 5-118.

Figure 5-118.  Finding grains:  global grain information and histogram.

The value set in the Number of Bins field sets the resolution of the Volume Histogram

and Area Histogram, i.e., the number of “bins,” or categories used to define the different

levels of grain volume and area.  The best resolution is achieved when the bin value is

closer to the number of grains counted (displayed in the Grains Found field).  Changes in

the number of bins are reflected in the Volume Histogram immediately.

Click on the Enlarge Image button to bring up a top-view of the displayed image at its

original resolution (which can be resized).  Click on the Image Off button to remove the

enlarged image.

Click on the Undo button to reverse the grain detection routine and reset the parameters.

Click on the Export button to export the grain analysis window as ASCII (.tst) data.
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Single Grain Analysis

To determine the characteristics of a single grain, click on a grain on the image (after the

find grains function has been applied).  The grain will be highlighted in yellow, and the

volume, area, perimeter, and average height information will be displayed in the Single

Grain Info area.

Grain(s) highlighted in this way can also be deleted from, or added back into, the overall

analysis by clicking on the Delete and Add buttons in the Edit Grain area.

Critical Dimension

The Critical Dimension functions provide measurement tools which analyze average

dimensions of various feature patterns.  This can be useful, for example, in calculating the

average width between a segment of parallel lines, as opposed to measuring the width

only at the intersecting cross section of a single line (with the line analysis tools).  Select

Analysis⇒ Critical Dimension to open the Critical Dimension dialog box, as shown in

Figure 5-119.

Figure 5-119.  The Critical Dimension dialog box.

The tools allow you to measure average parallel line width, average ellipse radius,

average curve radius, average angle (on the X,Y plane), and average step height.

In general, the critical dimensions analysis tools are most effective when measuring clean,

sharply defined features.
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Parallel Line Width

1. With the image you wish to measure active, select Analysis⇒ Critical Dimension

to open the Critical Dimension dialog box.

2. Click on the  button.

3. Left-click and drag directly on the image to draw a rectangle around the

feature(s) containing parallel lines.

After drawing the rectangle, you can re-position it or left-click and drag again to

redraw the boundary.

4. Right-click to set the fit area.

The parallel slope areas will be highlighted, two averaging measurement fit lines

will be drawn, and the width between the lines will be displayed in the Results

area of the dialog box, as shown in Figure 5-120.

Highlighted
parallel
slopes

Measurement
fit lines

Figure 5-120.  Parallel line width measurement.

High Average is the averaged width between the parallel lines at the highest

level on the slope.  Low Average is the averaged width between the parallel lines

at the lowest level on the slope.

Circle Radius

1. With the image you wish to measure active, select Analysis⇒ Critical Dimension

to open the Critical Dimension dialog box.
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2. Click on the  button.

3. Left-click and drag directly on the image to draw a circle around the circular

feature.

After drawing the circular boundary, you can reposition it or left-click and drag

again to redraw it.

4. Right-click to set the fit area.

The calculated fit circle will be highlighted, and the radius measurement will be

displayed in the Results area of the dialog box, as shown in Figure 5-121.

Highlighted fit circle

Figure 5-121.  Circle radius measurement.

Curve Radius

1. With the image you wish to measure active, select Analysis⇒ Critical Dimension

to open the Critical Dimension dialog box.

2. Click on the  button.

3. Left-click and drag directly on the image to draw a rectangle that encompasses at

least part of the curve.

After drawing the boundary, you can re-position it or left-click and drag again to

redraw it.

4. Right-click to set the fit area.
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The calculated fit curve will be highlighted, and the radius will be displayed in

the Results area of the dialog box, as shown in Figure 5-122.

Figure 5-122.  Calculated fit curve.

Angle

1. With the image you wish to measure active, select Analysis⇒ Critical Dimension

to open the Critical Dimension dialog box.

2. Click on the  button.

3. Left-click and drag directly on the image to draw a rectangle that encompasses

the first line in the angle measurement.

After drawing the boundary, you can reposition it or left-click and drag again to

redraw it.

4. Right-click to set the fit area.

5. Left-click and drag to draw a rectangle that encompasses the second line in the

angle measurement.

6. Right-click to set the fit area.

The two angle areas will be highlighted, two averaging measurement fit lines

will be drawn, and the angle between the lines will be displayed in the Results

area of the dialog box, as shown in Figure 5-123.
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Highlighted
angle
sides

Figure 5-123.  Angle measurement.

Step Height

1. With the image you wish to measure active, select Analysis⇒ Critical Dimension

to open the Critical Dimension dialog box.

2. Click on the  button.

The Histogram Data window is opened, displaying the step histogram for the

entire image, and the Peak 1, Peak 2, and Step Height information is displayed in

the Results area of the dialog box, as shown in Figure 5-124.

The Peak 1, Peak 2, and Step Height values actually indicate the height values

and distance between the red and yellow triangles at the bottom of the Histogram

Data plot.  When the Step Height function is first selected, the software

automatically selects the two highest peaks in the Histogram and places the

triangles at those points.

You can click and drag on either triangle to move it to a different location on the

Histogram Data plot, and the values in the Critical Dimensions box will be

continuously updated as the triangles move.
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Figure 5-124.  Step height data.

Next, you need to select two rectangular regions inside the image.

3. Left-click and drag on the image within the active window to select a region.

After drawing the rectangle, you can reposition it or left-click and drag again to

redraw the boundary.

4. Right-click to set the selected area.

A rectangle appears in the image.

5. Repeat Steps 3 and 4 to select a second region.

The step histogram for the selected regions is displayed in the Histogram Data window,

and the Peak 1, Peak 2, and Step Height information appears in the dialog box.

Each time you select a new region, the data for the most recently selected regions is added

to the Histogram Data window.

6. Select Undo Region to successively go back and eliminate, one by one, user-

selected regions.  This feature will become inactive after you return to the initial

“full area” histogram.
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Presenting Your Processed Image

Once you have processed and analyzed your data, display, presentation, and printing

functions are available in SPMLab from the Screen Editor module, accessed from the

Image Analysis or Data Acquisition menus by selecting Edit⇒ Screen Edit.  Screen

Editing is a powerful capability that allows you to present your image and data, with

added graphics and text.  The file can then be exported in a number of graphics formats,

compatible with most presentation software.  The Screen Editor module functions are

fully described in Chapter 6, “Screen Editor.”





Chapter 6
Screen Editor
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Overview

The Screen Editor module allows you to present and print your SPM data.  The module

functions as a free-form presentation tool, allowing the manipulation and output of the

gathered data (either from Image Analysis or Data Acquisition).  Text, lines, arrows,

boxes, and graphics files (TIF, BMP, etc.) can be added to the screen, and the position

and size of the images, text, and graphs can be modified.  You can also print the screen or

any portion of the screen, or you can save the defined area to disk.  The graphics files can

then be printed, saved, or inserted into future sessions with the Screen Editor or used in

other graphics and presentation programs.

The Screen Editor mode can be accessed from either the Data Acquisition or Image

Analysis modules by selecting Edit⇒ Screen Edit.  The main window of the Screen

Editor is shown in Figure 6-1.  When you enter the Screen Editor module from the Data

Acquisition module, all the screen controls in the Data Acquisition module, including the

Acquisition control panel and the Signal window, will be displayed if the Screen Edit Full

Details box in the Acquisition Preferences dialog box is checked (see page 21). When you

enter the Screen Editor module from the Image Analysis module, the Image Analysis

screen controls will always be displayed.

Added text

Added lines

Processed image

Figure 6-1.  Screen Editor.

Note: In order to use the Screen Editor module, you must have a printer driver installed

on your computer, as the Screen Editor software uses the printer settings.
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The Screen Editor tool bar, shown in Figure 6-2, provides single-click access to the most

commonly-used functions.

File        Open

File        Save As...

File        Print...

Edit        Cut

Edit        Copy

Edit        Paste
Edit        Delete

Edit        Insert        Text

Edit        Insert        Line

Edit        Insert        Rectangle
Edit        Insert        Ellipse

Edit        Undo
Edit        Redo

Mouse select
mode

Object        Move to front

Object        Move to back

Object        Group

Object        Ungroup

Figure 6-2.  The Screen Editor tool bar.

Screen Editor Menu Items

File Menu

The File menu, shown in Figure 6-3, allows you to open, save and print images.  The File

menu items are described briefly in Table 6-1.

Figure 6-3.  The File menu.
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Table 6-1.  The File menu items.

Menu Item Function

Open Opens the Open File dialog box, allowing you to open files in any of

the supported formats (including .ras, .tga, .wmf, .tif, etc.).  This

function can also be accessed by clicking on the  button on the

Screen Edit tool bar.

Save As… Opens the Save File dialog box, which enables you to save the

screen in any of the supported graphics file formats (including

WMF, TIF 1, TIF 8, TIF 24, TIF LZW 8, Windows BMP 8, PCX 1,

PCX 2, GIF, and TGA 8).  This function can also be accessed by

clicking on the  button on the Screen Edit tool bar.  With nothing

selected, the function will save all items on the screen.  Saving with

any items individually selected will save only those selected items.

Convert… Opens the Convert dialog box, allowing you to convert supported

file formats from one type to another (e.g., TIF 24 to PCX 24).

Preview… Opens the Print Preview window, which shows the orientation and

placement of the image as it will be printed.

Print… Opens the Print dialog box, which provides printing options and

allows you to send the image to the printer.  This function can also

be accessed by clicking on the  button on the Screen Edit tool

bar.

Print Setup… Opens the Print Setup dialog box, which allows you to select the

printing output device, page orientation, and paper options.  (Refer

to your Windows documentation for printer configuration

procedures.)  This function can also be accessed by clicking on the

Setup button in the Print dialog box.

Exit Edit Returns you to the module (Data Acquisition or Image Analysis)

from which you entered Screen Edit.
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The Edit Menu

The Edit menu, shown in Figure 6-4, provides access to the basic editing functions, which

are described briefly in Table 6-2.

Figure 6-4.  The Edit menu.

Table 6-2.  The Edit menu items.

Menu Item Function

Undo Reverses the last operation performed on the screen.  This function

can also be accessed by clicking on the  button on the Screen Edit

tool bar.

Redo Reverses the last Undo operation performed.  This function can also

be accessed by clicking on the  button on the Screen Edit tool

bar.

Cut Cuts any selected item(s) from the screen.  This function can also be

accessed by clicking on the  button on the Screen Edit tool bar.

Copy Copies any selected item(s) to the clipboard.  This function can also

be accessed by clicking on the  button on the Screen Edit tool

bar.

Paste Pastes the last item(s) cut or copied back onto the screen.  This

function can also be accessed by clicking on the  button on the

Screen Edit tool bar.

Delete Deletes any selected item(s) from the screen.  This function can also

be accessed by clicking on the  button on the Screen Edit tool

bar.
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Menu Item Function

Select/Deselect All Selects every graphic item on the screen.  If all items are selected,

this menu item changes to Deselect All, which will deselect all

items.

Insert Provides access to the four Insert functions.  See “The Insert Sub-

menu,” below.

The Insert Sub-menu

The Insert sub-menu, shown in Figure 6-5, provides access to the four insert functions,

described below.

Figure 6-5. The Insert sub-menu.

Text

When you select Edit⇒ Insert⇒ Text, the cursor turns to a crosshair, allowing you to

click and drag to create a text field.  After defining the text field, the Text Properties

dialog box, shown in Figure 6-6, will automatically open for creating and editing the text.

Double-clicking on any text already on the screen re-opens the dialog box so the existing

text can be edited.  This function can also be accessed by clicking on the  button on the

Screen Edit tool bar.

The Alignment controls determine the paragraph alignment of the text.  The Background

controls determine how the text box displays.  When Opaque is selected, the text will

appear against a solid background.  The default background color is white, as shown in

Figure 6-7.
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Figure 6-6. The Text Properties dialog box.

Figure 6-7.  Opaque text box background.
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The color of the background can be defined by clicking on the Colors button.  The Color

dialog box, shown in Figure 6-8, opens.

Figure 6-8.  The Color dialog box.

Choose from one of the Basic colors, and click OK to return to the Text Properties dialog

box.

When Transparent is selected, the text will appear without any background, as shown in

Figure 6-9.

Figure 6-9.  Transparent text box background.



Screen Editor Menu Items6-9

To format the text, click on the Font… button.  The Font dialog box opens, as shown in

Figure 6-10.

Figure 6-10.  The Font dialog box.

Select the desired font settings and click OK to return to the Text Properties dialog box.

Click OK to accept your selections.

Line

The Line function allows you to click and drag to create a line and insert it onto the

screen.  This function can also be accessed by clicking on the  button on the Screen

Edit tool bar.

Rectangle

The Rectangle function allows you to click and drag to create a rectangle and insert it

onto the screen.  This function can also be accessed by clicking on the  button on the

Screen Edit tool bar.

Ellipse

The Ellipse function allows you to click and drag to create an ellipse and insert it onto the

screen.  This function can also be accessed by clicking on the  button on the Screen

Edit tool bar.
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The Object Menu

The Object menu, shown in Figure 6-11, allows you to determine the properties,

positioning, and grouping of objects on the screen.  The Object menu items are described

briefly in Table 6-3.

Figure 6-11.  The Object menu.

Table 6-3.  The File menu items.

Menu Item Function

Properties… Opens one of the Properties dialog boxes, depending on the type of

object selected:  Image, Text, Line, Rectangle or Ellipse.  See “The

Properties Dialog Box” below for a description of each of these

functions.

Move to Front Moves a selected object to the front (top) of a stack of objects.  This

function can also be accessed by clicking on the  button on the

Screen Edit tool bar.

Move to Back Moves a selected object to the back (bottom) of a stack of objects.

This function can also be accessed by clicking on the  button on

the Screen Edit tool bar.

Move Forward Moves a selected object forward (up) one level in a stack of objects.

Move Backward Moves a selected object back (down) one level in a stack of objects.

Group Groups more than one selected object into a single object.  This

function can also be accessed by clicking on the  button on the

Screen Edit tool bar.

Ungroup Ungroups a selected group object.  This function can also be

accessed by clicking on the  button on the Screen Edit tool bar.
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The Properties Dialog Box

When you select Object⇒ Properties with an object or text box selected, one of the

Properties dialog boxes opens, depending on the type of object currently selected.

Image

The Image Properties dialog box, shown in Figure 6-12, allows you to show or hide the

image axes and labels on the screen.  This function can also be accessed by double-

clicking on the image.

Figure 6-12.  The Image Properties dialog box.

Text

The Text Properties dialog box, shown in Figure 6-13, allows you to edit the text in the

field.  This function can also be accessed by double-clicking on the text box.

Figure 6-13.  The Text Properties dialog box.
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Line

The Line Properties dialog box, shown in Figure 6-14, allows you to change the line style,

width, and color, and add arrowheads.  This function can also be accessed by double-

clicking on the line.

Figure 6-14.  The Line Properties dialog box.

Rectangle

The Rectangle Properties dialog box, shown in Figure 6-15, allows you to edit the frame

and fill and specify the degree of rounding of the corners (if any).  This function can also

be accessed by double-clicking on the rectangle.

Figure 6-15.  The Rectangle Properties dialog box.

Ellipse

The Ellipse Properties dialog box, shown in Figure 6-16, allows you to edit the frame and

fill.  This function can also be accessed by double-clicking on the ellipse.
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Figure 6-16.  The Ellipse Properties dialog box.

The Options Menu

The Options menu, shown in Figure 6-17, provides access to the basic display options.

Figure 6-17.  The Options menu.

Photo Mode

The Photo Mode function hides the Screen Editor module’s title bar, menu bar, tool bar,

and scroll bars so a screen capture or screen photo can be taken without the extraneous

information.  Once in the photo mode, clicking on the screen returns to the standard

mode.

Grid…

The Screen Edit Options dialog box, shown in Figure 6-18, allows you to enable and

disable the Screen Editor grid and define the grid’s configuration and placement

resolution (snap spacing).

Figure 6-18.  The Screen Edit Options dialog box.
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Screen Colors…

The Color Settings dialog box, shown in Figure 6-19, enables you to set various user

interface colors for the screen, image, and graphs.

Figure 6-19.  The Color Settings dialog box.

Dithering Method…

The Dithering Method dialog box, shown in Figure 6-20, allows you to select a dithering

method.

Figure 6-20.  The Dithering Method dialog box.
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Threshold field

1D FFT, 5-65
2D FFT, 5-68

Threshold Selection tool, 5-65
tilt

Graphic, 5-35
Tilt

Window menu item, 1-17
Tip Approach, 2-10, 2-23
Tip Down button

Data Acquisition tool bar, 1-19
Tip Up button

Data Acquisition tool bar, 1-19
Tip Voltage, 2-32
translation

scan, 2-6
True 2D Color, 5-29

U

U button, 5-22
Undo

Screen Editor Edit menu item, 6-5
Undo button

Screen Editor tool bar, 6-3
Ungroup, 6-10
Ungroup button

Screen Editor tool bar, 6-3
Update Z Scaling, 2-20
User button, 5-22

V

Vector Shading, 5-25
Verify Calibration, 3-3

Acquire menu item, 1-9
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Verifying Calibration, 3-8
vertical leveling, 5-47
Video

bulb, 2-58
camera, 2-58

Voltage Positioning, 2-57
Volume Histogram, 5-106, 5-111

W

Window menu, 1-16, 4-17

X

X, Y, Z coordinates, 5-23
XYZ

Commands menu item, 1-13

Y

Y/X Ratio, 2-36

Z

Z Adjust, 2-14
Z Gain, 2-36
Z max, 5-35
Z min, 5-35
Z Motor Speed Control, 2-58
Z Scale

graphic, 5-35
Z scaling

Data Acquisition module, 2-16
Z Setpoint, 2-33
Zero Set, 5-36

Display menu item, 4-10
Zero Set Off, 5-38

Display menu item, 4-10
Zoom, 2-6

graphic, 5-35
Zoom/Translate button, 2-6
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